Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 02-13-2010, 06:11 AM   #1
LQ Newbie
Registered: Jan 2009
Distribution: Ubuntu / LFS/BLFS/CLFS
Posts: 20

Rep: Reputation: 1
bridging wired and wireless Ethernet - wireless fails to arp, ping, but creates loop

I am bridging the wired and wireless Ethernet together, my intent is that it's connectivity is seamless with either connection.

The system boots, starts the wireless, and builds the bridge with both. DHCP assigns an IP address and the wired connection is fine. When I change the security settings on the wireless connection, from 128bit WEP to open, it associates with the access point, and I get errors "received packet with own address as source address". So I remove the wired connection.

Now I cannot ping anything, arp shows the entry as incomplete. The bridge keeps the DHCP assigned IP address. If I reattach the wired Ethernet, I have connectivity but I also get a loop and associated errors.

I can ifconfig the bridge down, the wireless connection up individually, assign a static IP address, nothing gets it working.

Iwconfig shows that the wireless is associated with the access point, ifconfig shows the static IP address, everything looks like it should work.

If I remove the wireless connection from the bridge, separately bring it up and assign it an IP address, then the connection works, ping, arp, all work.

The wired ports are Realtek 8139 chipsets, the wireless is IPW2100, or Intel Pro Wireless 2100. Kernel is, and the bridge is busybox-1.13.2.

Thank you for any input.
Old 02-18-2010, 04:18 AM   #2
LQ Newbie
Registered: Jan 2009
Distribution: Ubuntu / LFS/BLFS/CLFS
Posts: 20

Original Poster
Rep: Reputation: 1
I have updated to busybox-1.15.3 with no change in behavior.

I have also disabled busybox's brctl, and added bridge-utils-1.4, again with no change in behavior.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Bridging wired and wireless network Astral Projection Linux - Networking 8 10-06-2009 10:57 AM
bridging a wireless and wired network causes wired to stop working royce2020 Linux - Networking 0 04-21-2009 05:48 PM
Bridging the Wired Segment (Ethernet) & Wireless Segments (Access Point) Paris Heng Linux - Wireless Networking 0 07-14-2007 09:38 AM
Bridging Wireless interface with the Wired one hohenzolern Linux - Wireless Networking 3 04-04-2006 04:49 PM
Wireless Laptop to Wired ethernet via Linux PC (wired/wireless) sambartle Linux - Wireless Networking 0 01-30-2005 05:37 AM

All times are GMT -5. The time now is 04:56 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration