LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-19-2004, 04:52 PM   #1
teona
Member
 
Registered: Oct 2003
Distribution: Slackware 9.1
Posts: 64

Rep: Reputation: 15
bootsplash in slackware problem


I'm having a problem with the installation of bootsplash software,.. I've followed the instructions at the bootsplash webpage and when I come to the part of attaching the theme this is what happends...

so I try to attach it;

Code:
/sbin/splash -s -f /home/user/slackwaretheme/config/bootsplash-1024x768.cfg >> /boot/initrd.splash
and I get this message;

Code:
/etc/bootsplash/themes/current/images/silent-1024x768.jpg: No such file or directory
so what did I miss? I've tryed to go through the installation process several time and still there is something missing...
any clues on what to do?
thanx
 
Old 05-19-2004, 05:00 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Take a look in "/home/user/slackwaretheme/config/bootsplash-1024x768.cfg" there is probably a line that points to the image "/etc/bootsplash/themes/current/images/silent-1024x768.jpg" you will need to point this at the true location of the file which is probably "/home/user/slackwaretheme/images/silent-1024x768.jpg".

Alternatively you can move the location of the files:
mv /etc/bootsplash/themes/current /etc/bootsplash/themes/old
mv /home/user/slackwaretheme /etc/bootsplash/themes/current

Then build the ram disk again:
/sbin/splash -s -f /etc/bootsplash/themes/current/config/bootsplash-1024x768.cfg >> /boot/initrd.splash

/etc/bootsplash/themes - is the default location for bootsplash images so moving the theme may be a better idea.
 
Old 05-20-2004, 04:01 AM   #3
teona
Member
 
Registered: Oct 2003
Distribution: Slackware 9.1
Posts: 64

Original Poster
Rep: Reputation: 15
Well, I moved the theme to /etc/bootsplash/themes/current/ and then built the ram again, everything seemed fine, but when I rebooted nothing had changed... still that little penguin sitts in the upper left corner insted of the new theme.. and so I edited lilo.cfg and added

vga=791

and

initrd=/boot/initrd

and still nothing... ?
 
Old 05-20-2004, 12:48 PM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
What happens if you try to load the splash image after boot? On tty1 try running:
/sbin/splash -s /etc/bootsplash/themes/current/config/bootsplash-1024x768.cfg

Does the image load?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
bootsplash problem mailbinoy Suse/Novell 9 08-17-2005 10:59 AM
Slackware newbie... Questions about usb mouse, power, bootsplash, GNOMEs big_syner Slackware 3 02-12-2005 01:02 PM
Bootsplash - Slackware - Kernel 2.6.6 - NOT working pat99 Linux - Software 3 06-23-2004 12:29 PM
How to use bootsplash in Slackware 9.1? rsamurti Slackware 1 05-22-2004 08:16 PM
Bootsplash in Slackware ! Cdzin Slackware 15 03-03-2004 10:20 AM


All times are GMT -5. The time now is 09:20 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration