LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-14-2010, 06:21 PM   #1
djfuzz
LQ Newbie
 
Registered: Aug 2009
Posts: 2

Rep: Reputation: 0
Unhappy Bluez A2DP audio streaming


Dear Linux users,

I'm trying to stream audio from my iPhone 3GS iOS 4.01 to my linux computer via Bluetooth and A2DP.

My setup:
(ArchLinux)
Linux CoreNAS 2.6.34-Custom-Core #10 SMP PREEMPT Thu Aug 5 15:13:53 CEST 2010 i686 Intel(R) Atom(TM) CPU D510 @ 1.66GHz GenuineIntel GNU/Linux

Bluez 4.69

pulseaudio 0.9.21

The stream actually works, but every 1/2 seconds there is a glitch in the audio. Sometimes there are pitches in the audio. The audio is being streamed at 44.1Khz and my phone is in an acceptable range of the bluetooth enabled computer.

Pulseaudio outputs about every 5 seconds:

I: module-loopback.c: Should buffer 36012 bytes, buffered at minimum 92178 bytes
I: module-loopback.c: Old rate 45022 Hz, new rate 45046 Hz
I: module-loopback.c: Loopback overall latency is 63.33 ms + 352.51 ms + 39.51 ms = 455.35 ms

I load the loopback module as follows:

pactl load-module module-loopback source=bluez_source.00_26_B0_8D_6F_39 sink=alsa_output.usb-Native_Instruments_Audio_2_DJ_SN-v42x7kbg-00-Audio2DJ.analog-stereo rate=44100

Does anybody have a clue or direction to solve this issue? Thanks in advance!

Last edited by djfuzz; 08-15-2010 at 02:58 AM.
 
  


Reply

Tags
bluez, distorted, pulseaudio, sound


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Audio is not coming perfectly through A2DP. paldebojyoti Linux - Distributions 1 10-13-2009 02:55 PM
Trying to get a2dp device working... niidea Slackware 1 05-18-2008 07:12 AM
audio cd works - mp3's, streaming audio, flash sound don't spoody_goon Linux - Software 7 07-08-2006 03:11 PM
streaming audio icehenge Slackware 7 01-09-2005 05:46 PM
Streaming Audio matt Linux - General 3 08-02-2001 10:42 PM


All times are GMT -5. The time now is 11:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration