LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 10-31-2005, 01:19 AM   #1
what_is_dot
LQ Newbie
 
Registered: Oct 2005
Location: Purdue University - West Lafayette, Indiana
Posts: 5

Rep: Reputation: 0
Blank screen when loading fglrx ATI drivers on Debian


Hello,

This is my first post, so I'll try to make it a good one.

I have been having many frustrations trying to get 3D hardware support working with Debian.
I have an ATI 9800 Pro video card that I'm running on my P4/1.8Ghz (Gateway) motherboard.
I am using a Gateway FPD1800 flat panel display as my primary, and I have a Compaq S710 as my secondary. So far I have been just trying to get my FPD working, so I'm haven't tried any of the dual monitor configurations quite yet.
I started out running Debian 3.1 with kernel 2.4... I tried to install the drivers that I found from the ATI website, but after some errors I realized that I needed to install the kernel headers for my version of Debian using apt-get or Synaptic. After doing that, I had no problem installing and configuring the drivers for my system. The problem came when I tried to reboot. This is what happened:
Everything seemed to be working fine, until gde started up. Then my monitor looked like it was changing video modes for a second. After that, it took me back to the boot screen, where it displayed a console prompting me to log in. After about 1.5 seconds, the screen then looked like it was changing video modes again, but this time it gave me a completely blank screen without a cursor or anything. It remained to hang there, unresponsive to the keyboard.
I began to investigate the problem. After becoming very familiar with my /etc/X11/XF86Config-4 file, I discovered that this behavior follows when I load the "fglrx" module, even with the default settings. I had read some forum posts where a person had problems with getting fglrx to work with kernel 2.4, but they said they were able to get it working with 2.6, so I downloaded the latest kernel from kernel.org and followed one of the many online tutorials to get it compiled. After some frustrations with that task, I also discovered that I could have just used the apt-get to update my kernel to 2.6 on Debian. Since I was having problems loading certain modules with the kernel I compiled, I just used apt-get and installed that version. After updating the kernel and booting up onto it, everything apeared to be working fine. I thought I would try running the installer I downloaded from the ATI site again. I, once again, followed all the steps, and configured everything to default settings. So I rebooted to see what would happen. Guess what.
After all that, there was absolutely no change. Same exact problem.
This makes me think it has something to do with the /etc/X11/XF86Config-4 file. But this is confusing because I have tried many variations and gotten this file pretty close to my exact hardware, but I only get problems when I load the "fglrx" module.
Any clues???

P.S.
Just to give you a recap of my system:
I have an ATI 9800 Pro video card that I'm running on my P4/1.8Ghz (Gateway) motherboard.
I am using a Gateway FPD1800 flat panel display as my primary, and I have a Compaq S710 as my secondary. So far I have been just trying to get my FPD working, so I'm haven't tried any of the dual monitor configurations quite yet.
I am running Debian 3.1 with kernel version 2.6...
 
Old 10-31-2005, 02:29 AM   #2
b0uncer
Guru
 
Registered: Aug 2003
Distribution: CentOS, OS X
Posts: 5,131

Rep: Reputation: Disabled
my clue is that fglrx drivers from ATI suck..the "official" drivers are BAD, in my opinion, and generally ATI cards are a problem when used with Linux. nVidia works fine (though some newer cards tend to have problems, I've heard), but I haven't heard any single happy story about ATI and 3d. 2d drivers work of course, and I mean the ones that do not come from ATI but with a normal Linux installation.

if you really really want 3d, I suggest you go buy an nVidia card (and make sure before buying that it works, since some new cards might not, as I said). they don't cost _that_ much if you _really_ want 3d. and if you don't need it that much, I'd advice starting to study (driver) programming - ATI probably will not help you.
 
Old 10-31-2005, 02:59 AM   #3
what_is_dot
LQ Newbie
 
Registered: Oct 2005
Location: Purdue University - West Lafayette, Indiana
Posts: 5

Original Poster
Rep: Reputation: 0
Quite a few people have posted their problems with ATI video drivers, but a majority of the ones I read eventually resolved their problems. It's true that the drivers might not be good, but their all I've got.
Considering the amount of money I've invested in my nice video card, purchasing another one is not an option. Also, I might be able to program, but developing my own drivers for my own video card would take way too much time.
Especially if my problem has to do with some config file not having a flag set correctly...

Thanks anyway.
 
Old 10-31-2005, 10:11 AM   #4
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
Well, let me be the first one you have heard say positive things then. I know in the past the ATI drivers for linux weren't well documented and were massively picky. But when I did a fresh install over the weekend of SuSE 10, I was pleasently surprised to see a new file on ATI's website, new install instructions. And this time they lead your through checking to verify everything you need enabled first, is working before you install the drivers and have issues. And it worked perfectly. They tell you how to setup and then run,and then test for POSIX shared memory, that the Kernel Source you need itt you current Linux Kernel source, and where it checks for it, How to set and test for the proper AGPGART.

I won't lie and say it should be that way, al of it should be able to be done automatically, nvidia obviously does. But the fact is, if you follow their instructions, the new ones, and you do it all step by step, not saying, I have that and skipping anything. They will work.
 
Old 11-09-2005, 04:07 AM   #5
what_is_dot
LQ Newbie
 
Registered: Oct 2005
Location: Purdue University - West Lafayette, Indiana
Posts: 5

Original Poster
Rep: Reputation: 0
Well, I have meticulously followed the ATI instructions and arrived at the same point. Since a lot of people are having problems with the drivers, and I think no one wants to bother with my problem, I'll just use this thread to document my problem and my progress towards solving it.

I at first looked at the other posts on LinuxQuestions.
http://www.linuxquestions.org/questi...k+screen+fglrx
In this thread, compiling a new kernel helped them out, but I did the same and it didn't seem to change anything or give me any different results...

In this article...
http://www.linuxquestions.org/questi...k+screen+fglrx
...and this article...
http://www.linuxquestions.org/questi...k+screen+fglrx
...they checked the file /var/log/XFree86.0.log and found that
�DRI initialization failed�
I started looking to see what was in my log file after all I got was a blank screen. DRI seemed to start up with no problems...

Code:
...
(II) fglrx(0): [drm] ringbuffer size = 0x00100000 bytes
(II) fglrx(0): [drm] DRM buffer queue setup: nbufs = 100 bufsize = 28672
(II) fglrx(0): [drm] texture shared area handle = 0xe8d9d000
(II) fglrx(0): shared FSAAScale=1
(II) fglrx(0): DRI initialization successfull!
(II) fglrx(0): FBADPhys: 0xe8000000 FBMappedSize: 0x00701000
(II)fglrx(0): FBMM initialized for area (0,0)-(1280,1434)
...
In fact, there appeared to be no problems at all in the log file with the exception of this line:

Code:
...
(II) Primary Device is: PCI 01:00:0
(II) ATI Proprietary Linux Driver Version Identifier:8.18.6
(II) ATI Proprietary Linux Driver Release Identifier: LGDr8.18g1                           
(II) ATI Proprietary Linux Driver Build Date: Oct 11 2005 11:02:10
(II) ATI Proprietary Linux Driver Build Information: autobuild-rel-r6-8.18.1-driver-lnx-218592
(WW) fglrx: No matching Device section for instance (BusID PCI:1:0:1) found
(--) Chipset RADEON 9800 PRO (R350 4E48) found
(II) resource ranges after xf86ClaimFixedResources() call:
...
I have found this articles that have given me some hints:
http://odin.prohosting.com/wedge01/g...#4_blackscreen

...but changing the "UseInternalAGPGART" value didn't change anything...
I tried using the default monitor layout and dual head configurations. I only have 640Megs of RAM, so that shouldn't be a problem.

I'm going to continue to look, but I'm starting to run out of ideas...any help/ideas/directions would be more than welcome...

 
Old 11-09-2005, 08:01 AM   #6
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
Okay, well I can try to give you some help.

I will need to see the output of a few commands:

Code:
mount | grep "shm"
Code:
lsmod
Code:
rpm -q glibc
Which XFree version are you running, from the debian site, it appears it may be XFree86 4.1?
Okay, then you have Kernel 2.6, is this 2.6.14?
And you know for sure you have the Linux Kernel Source installed(you kept it after upgrading the kernel, right?)
 
Old 11-09-2005, 04:42 PM   #7
what_is_dot
LQ Newbie
 
Registered: Oct 2005
Location: Purdue University - West Lafayette, Indiana
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks, RedShirt.

Here is the output:

Code:
COM:/# mount | grep "shm"
tmpfs on /dev/shm type tmpfs (rw)
COM:/# lsmod
Module                  Size  Used by
isofs                  33976  1
ipv6                  229892  8
lp                     10408  0
af_packet              20872  2
floppy                 54992  0
parport_pc             33348  1
parport                37320  2 lp,parport_pc
pcspkr                  3816  0
rtc                    12088  0
eth1394                19976  0
ohci1394               32004  0
ieee1394              100408  2 eth1394,ohci1394
emu10k1_gp              3840  0
gameport                4736  1 emu10k1_gp
snd_emu10k1            80776  0
snd_rawmidi            23204  1 snd_emu10k1
snd_pcm                85384  1 snd_emu10k1
snd_timer              23300  1 snd_pcm
snd_seq_device          7944  2 snd_emu10k1,snd_rawmidi
snd_ac97_codec         59268  1 snd_emu10k1
snd_page_alloc         11144  2 snd_emu10k1,snd_pcm
snd_util_mem            4608  1 snd_emu10k1
snd_hwdep               9092  1 snd_emu10k1
snd                    50660  8 snd_emu10k1,snd_rawmidi,snd_pcm,snd_timer,snd_seq_device,snd_ac97_codec,snd_util_mem,snd_hwdep
shpchp                 87148  0
pciehp                 83948  0
pci_hotplug            30640  2 shpchp,pciehp
intel_agp              20512  1
usblp                  12032  0
joydev                  9536  0
usbhid                 28864  0
uhci_hcd               29328  0
usbcore               104164  5 usblp,usbhid,uhci_hcd
emu10k1                71812  3
sound                  75308  1 emu10k1
soundcore               9824  6 snd,emu10k1,sound
ac97_codec             16908  1 emu10k1
tulip                  42528  0
agpgart                31784  1 intel_agp
nls_iso8859_1           4352  2
nls_cp437               6016  3
vfat                   13184  2
fat                    41792  1 vfat
tsdev                   7168  0
mousedev                9996  1
evdev                   9088  0
capability              4872  0
commoncap               7168  1 capability
psmouse                17800  0
ide_cd                 38176  1
cdrom                  35740  1 ide_cd
ext3                  109672  2
jbd                    54552  1 ext3
ide_generic             1664  0
piix                   12448  1
ide_disk               16768  6
ide_core              125028  4 ide_cd,ide_generic,piix,ide_disk
sd_mod                 20480  0
ata_piix                7812  0
libata                 36228  1 ata_piix
scsi_mod              115148  2 sd_mod,libata
unix                   26036  693
font                    8576  0
vesafb                  6688  0
cfbcopyarea             3840  1 vesafb
cfbimgblt               3200  1 vesafb
cfbfillrect             3712  1 vesafb
COM:/# rpm -q glibc
rpm: To install rpm packages on Debian systems, use alien. See README.Debian.
error: cannot open Packages index using db3 - No such file or directory (2)
...and...
XFree86 Version 4.3.0.1
Linux version 2.6.8
and I do still have the source.


Last edited by what_is_dot; 11-09-2005 at 04:44 PM.
 
Old 11-09-2005, 07:43 PM   #8
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
Posix shared memory is working, AGPGART is set to intel and should be working, you still have the source. Did you use the Xfree86 4.3 rpm as your download of choice(aka not 4.1 or 4.2 or XOrg 6.8)?

I'll assume you did as you said it seemed to be working at first. Okay, so then you did the ./run-yadayadayada, and ran the fglrx command in the terminal, did you choose all default options, or did you change some?

That glibc line has me a touch worried... can alien check for install rpms the same way as other package managers? Because that would mean typing "alien -q glibc" should be fine for checking for proper glibc versions(2.2 or 2.3 only). If it cannot, you will need to find out if you have glibc, and which version you might have another way.
 
Old 11-09-2005, 08:36 PM   #9
Rollinco
LQ Newbie
 
Registered: Oct 2005
Location: Monmouth, Oregon
Distribution: Slackware 12.1
Posts: 6

Rep: Reputation: 0
Talking

I followed the instructions at the following website ( http://serios.net/content/debian/ati/ ) and got my 9600XT working with debian 3.1 with the 2.6.8 kernel in about 15 minutes. Hope this helps!!
 
Old 11-10-2005, 01:05 PM   #10
what_is_dot
LQ Newbie
 
Registered: Oct 2005
Location: Purdue University - West Lafayette, Indiana
Posts: 5

Original Poster
Rep: Reputation: 0
Success!!

I followed the link that Rollinco sent me to. There was one thing that they did that I hadn't.
They ran the ATI installation, then they ran this command as root:

# dpkg-reconfigure xserver-xfree86 --priority=medium

This made a dialog box pop up, where I manually selected "fglrx" as my video driver. I had to select a few other options, and then I ran the "fglrxconfig" command as root. After following those instructions, I rebooted.

And IT WORKED!

Thank you so much!!!
 
Old 11-10-2005, 01:06 PM   #11
RedShirt
Senior Member
 
Registered: Oct 2005
Location: Denver
Distribution: Sabayon 3.5Loop2
Posts: 1,150

Rep: Reputation: 45
Well, that just figures, some distros just gotta be different I suppose. I will add that line to my website later with acomment for Debian users.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10.2 and fglrx (ATI Drivers) cythrawll Slackware 7 10-18-2005 06:44 PM
ATI drivers: fglrx vs dri. What's the difference?? rose_bud4201 Linux - Hardware 3 09-09-2005 08:18 PM
Explanation please: ATI Drivers - fglrx and agpgart statguy Linux - Hardware 1 03-24-2005 11:53 AM
ATI fglrx drivers being slow ben77 Linux - Hardware 2 10-01-2004 04:08 PM
ATI binary drivers and Kernel 2.6: BLANK SCREEN FIX adamjaskie Linux - Hardware 0 02-09-2004 12:13 AM


All times are GMT -5. The time now is 03:03 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration