LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-17-2003, 09:44 AM   #1
Smog
LQ Newbie
 
Registered: Feb 2003
Location: uk
Posts: 11

Rep: Reputation: 0
Angry Blackbox


Hi, im runing redhat linux 8.0 on my machine and i cant get blackbox runing i downloaded "blackbox-0.65.0-fr2.i386.rpm" and installed it i have all the DIR and stuff i think its just the editing of the xinitrc file, and when i log into my linux box (GNOME) and i push CTRL+ALT+F2 and login there to type startx i get an error

Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.

If anyone out there knows how to sort my problem please post and say i would really appreciate it
 
Old 06-17-2003, 09:56 AM   #2
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
well what did you edit in your .xinitrc file? you didn't say
 
Old 06-17-2003, 09:59 AM   #3
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
actually i just realized something you just said...as of right now disregard my last post as that is not the point of the matter as i just noticed something:
you said you pressed ctrl-alt-f2 and then typed startx, that is wrong..
when you press ctrl-alt-f2 you are only going into a terminal for lack of better terms....if you press ctrl-alt-f7 you will see that you X windows is still running...so you can't startup blackbox when you still have a window manger runnning, hence this is where the error comes in...so you should trying "killing" the X session by ctrl-alt-backspace, make sure the files are edited properly, and then type startx..
 
Old 06-17-2003, 09:59 AM   #4
Smog
LQ Newbie
 
Registered: Feb 2003
Location: uk
Posts: 11

Original Poster
Rep: Reputation: 0
well........

well i go onto websites they tell me to edit it with bla bla
then i go onto another site and they tell me to edit in somtin completly diferent im so confused :S

so i need to know exacly how to edit it wel not how but what to put
 
Old 06-17-2003, 10:01 AM   #5
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
i personally think you may have to edit the .xinitrc.switchdesk file, but thats besides the point...try shutting down the X server properly this time cause maybe what you edited is correct, but you won't know until X is shutdown and no display manager is running
 
Old 06-17-2003, 10:03 AM   #6
Smog
LQ Newbie
 
Registered: Feb 2003
Location: uk
Posts: 11

Original Poster
Rep: Reputation: 0
This is wots in my file

#!/bin/sh

########################################################################
# .xinitrc #
# 5/22/00 Stefan Jeglinski, jeglin@rapierbit.org #
# based on one written by hollis+@andrew.cmu.edu 1/5/99 #
# Thanks Hollis! #
# #
# To use: #
# * if you have a ~/.Xclients, remove it. The system copy is in #
# /etc/X11/xinit/Xclients if you ever want it back. #
# #
# * place this file in your home (~) directory. For root, #
# home is /root. #
# #
# * Type 'startx after', 'startx kde', etc. #
# #
########################################################################

userresources=$HOME/.Xresources
usermodmap=$HOME/.Xmodmap
xclients=$HOME/.Xclients
sysresources=/usr/X11R6/lib/X11/xinit/.Xresources
sysmodmap=/usr/X11R6/lib/X11/xinit/.Xmodmap

# merge in defaults and keymaps

if [ -f $sysresources ]; then
xrdb -merge $sysresources
fi

if [ -f $sysmodmap ]; then
xmodmap $sysmodmap
fi

if [ -f $userresources ]; then
xrdb -merge $userresources
fi

if [ -f $usermodmap ]; then
xmodmap $usermodmap
fi

########################################################################
# #
# to fix backspace and delete in X if necessary; #
# these may need to be removed for XFree86 4.x #
# #
########################################################################
xmodmap -e "keycode 59 = BackSpace"
xmodmap -e "keycode 125 = Delete"

########################################################################
# #
# accelerate the mouse in the window manager; #
# Gnome and KDE typically override this #
# #
########################################################################
xset m 8 3

########################################################################
# #
# define mouse button usage in the window manager; #
# this directive may be "eaten" by the Gnome or KDE startup #
# and may therefore need to be run again after the environment #
# is started #
# #
########################################################################
xmodmap -e "pointer = 2 1 3"

########################################################################
# #
# * Set variables for different window managers and environments #
# #
# * $1 represents the first argument to startx. #
# #
# * WM is the name of the program to execute. This is normally the #
# window manager itself, but in the case of kde or gnome it needs #
# to be the gnome-session or startkde script. #
# #
########################################################################

ARG=$1

# specify the default argument here:
DEFAULTWM="gnome-session"

if [ ! $ARG ]; then
ARG=$DEFAULTWM
fi

########################################################################
# #
# The difference between a desktop environment and a window manager #
# is that an environment provides a desktop, while a window manager #
# just handles the window dressing. An environment needs a WM, but #
# not vice versa. The only 2 environments are Gnome and KDE. Common #
# window managers for Gnome are Sawfish and Enlightenment. KDE #
# has its own window manager (kwm). #
# #
########################################################################

# to add another wm/environment here, just copy, paste,
# and edit the 'elif' line:

if [ $ARG = "gnome" ]; then
WM=gnome-session
elif [ $ARG = "kde" ]; then
WM=startkde
elif [ $ARG = "after" ]; then
WM=afterstep
elif [ $ARG = "wm" ]; then
WM=wmaker
elif [ $ARG = "en" ]; then
WM=enlightenment
elif [ $ARG = "bb" ]; then
WM=blackbox
elif [ $ARG = "ice" ]; then
WM=icewm
else
WM=$DEFAULTWM
fi

########################################################################
# #
# set a background window color for window managers only; #
# if an environment starts up, it will override this #
# #
########################################################################
xsetroot -solid MidnightBlue

########################################################################
# #
# don't turn on screen-saver for window manager #
# #
########################################################################
#xset s on

########################################################################
# #
# turn on a REAL screensaver, http://www.jwz.org/xscreensaver/ #
# #
########################################################################
xhost +localhost
xscreensaver &
xscreensaver-command -activate

########################################################################
# #
# The next line actually runs the selected window manager and logs #
# the output (stdout AND stderr) to the file ~/console. If you run a #
# #
# tail -f ~/console #
# #
# in an xterm, it will display the (constantly updated) contents of #
# that file. This can be usful for talk requests, wm errors, etc. #
# #
########################################################################

exec $WM >& ~/console
 
Old 06-17-2003, 10:32 AM   #7
DrOzz
Senior Member
 
Registered: May 2003
Location: Sydney, Nova Scotia, Canada
Distribution: slackware
Posts: 4,185

Rep: Reputation: 59
you have the default window manager set as gnome...
try adding --> exec blackbox <-- to the .xinitrc.switchdesk file.
 
Old 06-17-2003, 12:39 PM   #8
Smog
LQ Newbie
 
Registered: Feb 2003
Location: uk
Posts: 11

Original Poster
Rep: Reputation: 0
where is that :S

i cannot find it i tried command locate and command find nout happend could u point me to a folder please? or can i just edit the file i showed u up there ^^ to what u said
 
Old 06-17-2003, 01:07 PM   #9
Smog
LQ Newbie
 
Registered: Feb 2003
Location: uk
Posts: 11

Original Poster
Rep: Reputation: 0
whats going on!

no matter how many times i edit the file when i login and press ctrl+alt+F2 and login and type startx i always get this :

Fatal server error:
Server is already active for display 0
If this server is no longer running, remove /tmp/.X0-lock
and start again.

can u help om this problem like turn somtin off?
 
Old 06-17-2003, 01:21 PM   #10
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
Pressing Ctrl+Alt+Fx isnt stopping the X server, it's just showing you a terminal login instead of the graphical one which is still at Ctrl+Alt+F7.
Log in as root and run telinit 3
This will stop the display manager/Xserver.
Then log in as your username, and the startx command will use the .xinitrc files mentioned above.
 
Old 06-17-2003, 01:45 PM   #11
Smog
LQ Newbie
 
Registered: Feb 2003
Location: uk
Posts: 11

Original Poster
Rep: Reputation: 0
sorry

i only been running linux for 5 weeks how do i run that :S sorry
 
Old 06-17-2003, 02:00 PM   #12
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,386

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
just open a terminal window (e.g. Konsole), or choose ctrl+alt+f1to6
 
Old 06-17-2003, 02:01 PM   #13
Smog
LQ Newbie
 
Registered: Feb 2003
Location: uk
Posts: 11

Original Poster
Rep: Reputation: 0
yea

its okay ive got it but when i start up the blackbox i cant see nout it all black when i right click i got a menu box but its really black
 
Old 06-17-2003, 02:50 PM   #14
Proud
Senior Member
 
Registered: Dec 2002
Location: England
Distribution: Used to use Mandrake/Mandriva
Posts: 2,794

Rep: Reputation: 116Reputation: 116
So change the theme...
Get new ones from themes.freshmeat.net
 
Old 06-17-2003, 03:11 PM   #15
Smog
LQ Newbie
 
Registered: Feb 2003
Location: uk
Posts: 11

Original Poster
Rep: Reputation: 0
THAN YOU

thank you to evryone who replied back with good answers you really helped on this subject thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
BlackBox look shoki_neu Linux - Software 0 05-21-2004 04:23 AM
blackbox? Alderian Linux - Newbie 1 08-23-2003 03:37 AM
Blackbox Drogo Linux - Software 25 06-18-2003 05:15 PM
blackbox lil_becky Linux - Software 7 11-17-2002 11:11 AM
blackbox help cerberus Linux - General 2 04-29-2002 03:22 AM


All times are GMT -5. The time now is 09:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration