LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Black screen when I quit xfce (http://www.linuxquestions.org/questions/linux-software-2/black-screen-when-i-quit-xfce-499526/)

fredricsandberg 11-07-2006 04:16 PM

Black screen when I quit xfce
 
I have a weird problem.

When I boot my computer (os: Gentoo Linux) everything works perfect, and I get the shell and everything, and then I "startxfce4", use xfce4, but THEN when I quit xfce4, the screen becomes entirely black, instead of returning to the previous working shell and commandprompt. Same thing goes for me when I am tabbing between my TTY:s. (F1, F2, F3 a.s.o.)

Any ideas?

My xorg.conf if that is of any help:

Quote:

Section "ServerLayout"
Identifier "default"
Screen "DFP Screen"
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
RgbPath "/usr/share/X11/rgb"
ModulePath "/usr/lib/xorg/modules"
FontPath "/usr/share/fonts/misc"
FontPath "/usr/share/fonts/75dpi"
FontPath "/usr/share/fonts/100dpi"
FontPath "/usr/share/fonts/TTF"
FontPath "/usr/share/fonts/Type1"
EndSection

Section "Module"
Load "glx"
Load "extmod"
Load "xtrap"
Load "record"
Load "dbe"
Load "dri"
Load "freetype"
Load "type1"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "se"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
EndSection

Section "Monitor"
Identifier "DFP"
UseModes "16:10" # Monitor accepts modes we gave earlier
DisplaySize 323 215 # Size of 15.4 in screen used for calculating dpi
Option "dpms"
EndSection

Section "Device"
Identifier "ATI Graphics Adapter 0"
Driver "fglrx"
BusID "PCI:1:5:0"
EndSection

Section "Device"
Identifier "Radeon Xpress 200M"
Driver "fglrx"
Option "mtrr" "off"
Option "DesktopSetup" "(null)" # this is used for dual monitor setups
Option "VideoOverlay" "on"
Option "OpenGLOverlay" "off"
Option "CenterMode" "off"
Option "PseudoColorVisuals" "off"
BusID "PCI:1:5:0"
EndSection

Section "Screen"
Identifier "DFP Screen"
Device "Radeon Xpress 200M"
Monitor "DFP"
DefaultDepth 24
SubSection "Display"
Modes "1280x800" "1152x720" "1024x640" "800x500" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Modes"
Identifier "16:10"
# 1280x800 @ 60.00 Hz (GTF) hsync: 49.68 kHz; pclk: 83.46 MHz
Modeline "1280x800" 83.46 1280 1344 1480 1680 800 801 804 828 -HSync -Vsync
# 1152x720 @ 60.00 Hz (GTF) hsync: 44.76 kHz; pclk: 67.32 MHz
Modeline "1152x720" 67.32 1152 1208 1328 1504 720 721 724 746 -HSync -Vsync
# 1024x640 @ 60.00 Hz (GTF) hsync: 39.78 kHz; pclk: 52.83 MHz
Modeline "1024x640" 52.83 1024 1072 1176 1328 640 641 644 663 -HSync -Vsync
# 800x500 @ 60.00 Hz (GTF) hsync: 31.08 kHz; pclk: 31.33 MHz
Modeline "800x500" 31.33 800 824 904 1008 500 501 504 518 -HSync -Vsync
EndSection

Section "DRI"
Mode 0666
EndSection
/Fredric

konsolebox 11-07-2006 08:44 PM

are you using 2 video drivers? One for the console (perhaps fb drivers) and one for X (AGP enabled drivers)?

Perhaps you might find this thread helpful:

http://www.linuxquestions.org/questi...d.php?t=465305


All times are GMT -5. The time now is 01:47 AM.