LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-13-2003, 12:39 PM   #1
HitmanIP7
Member
 
Registered: May 2003
Location: UK
Distribution: Mandrake 9.2 and SuSE 9
Posts: 45

Rep: Reputation: 15
Black Screen after Boot


I recently installed Red Hat 8.0, and the install went fine (apart from a problem with the Grub bootloader, so I had to do a re-install and choose Lilo instead. Which works fine)

The problem is that Linux boots, but when it finishes and is about to go to the graphical login, I just get a black screen.

I had the same problem when I tried to use the graphical installer as well. I did try to get the graphical install working by trying 'linux lowres', 'linux resolution=800x600', etc, but none worked.

How can I fix this?
 
Old 05-13-2003, 12:44 PM   #2
yowwww
Member
 
Registered: Apr 2003
Location: Ontario, Canada
Distribution: Arch Linux
Posts: 533

Rep: Reputation: 30
do you have more than one video card? ie - one onboard and one agp/pci? you would need to specify which one to use during the install, also check to make sure the sync rates of your monitor are correct.
 
Old 05-13-2003, 12:51 PM   #3
HitmanIP7
Member
 
Registered: May 2003
Location: UK
Distribution: Mandrake 9.2 and SuSE 9
Posts: 45

Original Poster
Rep: Reputation: 15
I have onboard graphics only.

Im using the ASUS A7N266-VM motherboard, which has onboard GeForce 2 graphics.
 
Old 05-13-2003, 05:11 PM   #4
HitmanIP7
Member
 
Registered: May 2003
Location: UK
Distribution: Mandrake 9.2 and SuSE 9
Posts: 45

Original Poster
Rep: Reputation: 15
Any suggestions?
 
Old 05-13-2003, 06:22 PM   #5
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,978
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Quote:
Originally posted by HitmanIP7
Any suggestions?
Just questions ... does the box die then?
Or can you get to a text console by
pressing Ctrl-Alt-F1 (or 2,3,4... :})?



Cheers,
Tink
 
Old 05-14-2003, 12:48 PM   #6
HitmanIP7
Member
 
Registered: May 2003
Location: UK
Distribution: Mandrake 9.2 and SuSE 9
Posts: 45

Original Poster
Rep: Reputation: 15
I havent tried that yet. I will give it a try tonight.
 
Old 05-14-2003, 01:05 PM   #7
masand
Guru
 
Registered: May 2003
Location: INDIA
Distribution: Ubuntu, Solaris,CentOS
Posts: 5,522

Rep: Reputation: 58
try ctrl-alt_(f1 f2 )
then at the prompt login and try "startx"
or "Xconfigurator"( i am not sure abt. the correct command of Xconfigurator, i think this the one with X in caps)
 
Old 05-14-2003, 01:15 PM   #8
HitmanIP7
Member
 
Registered: May 2003
Location: UK
Distribution: Mandrake 9.2 and SuSE 9
Posts: 45

Original Poster
Rep: Reputation: 15
Oaky, thanks.

I will give it a try.
 
Old 05-14-2003, 02:34 PM   #9
HitmanIP7
Member
 
Registered: May 2003
Location: UK
Distribution: Mandrake 9.2 and SuSE 9
Posts: 45

Original Poster
Rep: Reputation: 15
I tried pressing Ctrl-Alt-F1 (F2, F3 and F4) when I got the black screen. But I didn't get anything.

I can press Ctrl-X at startup to get to a prompt saying 'boot:', but the only command that works there is 'Linux', which boots linux.

Last edited by HitmanIP7; 05-14-2003 at 02:37 PM.
 
Old 05-14-2003, 02:38 PM   #10
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
1) Add " 3" to your kernel arguments then when you boot you should be in CLI mode.
2) Login as root
3) Run "redhat-config-xfree86" to configure your hardware
4) Test your settings by running "Xtest", you will get a message on your screen asking if it has worked. If it hasn' then just leave it for 15 seconds and it will exit automatically. You can then go back to step 3 and reconfigure your hardware.
 
Old 05-14-2003, 02:54 PM   #11
HitmanIP7
Member
 
Registered: May 2003
Location: UK
Distribution: Mandrake 9.2 and SuSE 9
Posts: 45

Original Poster
Rep: Reputation: 15
Thanks, but I am a bit of a Linux newbie. Sorry.

How do I add " 3" to my kernel arguments?

Will I need to boot into rescue mode to do this? and what is the command to do it?

I do get the last few bits though!
 
Old 05-14-2003, 03:35 PM   #12
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
At the bootloader stage there should be an option to edit the proccess. You press "e" in grub - I'm not sure about LILO. Then look for the line starting with kernel and add " 3" (no quotes) to the end of that line.
 
Old 05-14-2003, 04:40 PM   #13
HitmanIP7
Member
 
Registered: May 2003
Location: UK
Distribution: Mandrake 9.2 and SuSE 9
Posts: 45

Original Poster
Rep: Reputation: 15
Okay, I will give it a try.
 
Old 05-14-2003, 04:58 PM   #14
davecs
Member
 
Registered: Feb 2003
Location: Dagenham, Essex, Britain
Distribution: PCLinuxOS
Posts: 485

Rep: Reputation: 31
I have the same motherboard as you and I do not have this problem (I use Mandrake 9.1)

Have you downloaded and installed the nVidia driver?

Also: I did have a problem with my on-board graphics due to a timing problem. If you have Windows, can you use Win to put your monitor into the desired resolution, then press the button(s) on the front of your monitor to find out the Vertical Refresh and Horizontal Sync.

Then as root, edit your XF86Config-4 file (if it is not there, use XF86Config), and ensure that the range given in the lines VSync and HSync or similar cover your monitor's timings. I did this and my picture went from a complete disaster (so much shaking it was impossible to read normal text) to solid.

DAVE
 
Old 05-14-2003, 05:10 PM   #15
HitmanIP7
Member
 
Registered: May 2003
Location: UK
Distribution: Mandrake 9.2 and SuSE 9
Posts: 45

Original Poster
Rep: Reputation: 15
I haven't downloaded the nVidia driver.

Thanks for the info, but I dont have Windows on the machine, only Linux, so I cant do what you said. If I get the same problem as you though, then at least I know what to try.

I dont know the option to edit the proccess in LILO, or the key to press. I have looked around, and searched on Google, but I cant seem to find what it is.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
I messed with the screen resolution and now Redhat will boot into a black screen! Mr. Hill Linux - Newbie 29 05-04-2009 11:52 AM
Black screen on boot cach Linux - Newbie 1 02-09-2005 07:55 AM
Black screen on boot Michael Davont Linux - Newbie 10 01-25-2005 03:35 PM
Black Screen At Boot Obscure Slackware 12 12-21-2003 12:03 AM
Black Screen At Boot Up Ax787 Linux - Newbie 1 10-02-2003 12:23 PM


All times are GMT -5. The time now is 01:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration