LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 09-11-2002, 06:43 AM   #1
Kryptow
LQ Newbie
 
Registered: Aug 2002
Location: Miami, Florida
Distribution: Redhat 7.3 / 8.0
Posts: 23

Rep: Reputation: 15
BitchX Error


I downloaded the source but after i run the ./configure command and try to run gmake or make i get the follwoing error.........


Code:
/bin/sh: test: /home/Kryptow/downloads/chat: binary operator expected
cd source \
  && gmake 'local_dir=/root' 'INSTALL_IRC=/usr/local/bin/BitchX' 'IRCLIB=/usr/local/lib/bx' 'CC=gcc' 'CFLAGS=-O2 -Wall -g ' 'HELPDIR=/usr/local/lib/bx/help' 'INSTALL_WSERV=/usr/local/lib/bx/wserv' 'IRCPATH=~/.BitchX:~/.BitchX/plugins:.:/usr/local/lib/bx/plugins:/usr/local/lib/bx/script:/usr/local/lib/bx' 'TRANSLATION_PATH=/usr/local/lib/bx/translation' 'LDFLAGS=' 'LIBS=-lcrypt -lm -lncurses -lresolv ' 'LN=ln -s' 'RM=rm -f' 'TCL_SRCS=' 'TCL_OBJS=' 'CD_PLAY=' 'CD_SRCS=' 'CD_OBJS=' 'TCL_LIBS=' 'PLUGINDIR=/usr/local/lib/bx/plugins' '_VERSION_=BitchX' 'VERSION=BitchX-1.0c19' 'INSTALL_DATA=/usr/bin/install -c -m 644' 'INSTALL_SCRIPT=/usr/local/lib/bx/script' 'EXEEXT=' 'SHLIB_CFLAGS=' 'SHLIB_SUFFIX=.so' all
gmake[1]: Entering directory `/home/Kryptow/downloads/chat clients/BitchX/source'
gmake[1]: *** No rule to make target `../include/../.config.h', needed by `alias.o'.  Stop.
gmake[1]: Leaving directory `/home/Kryptow/downloads/chat clients/BitchX/source'gmake: *** [BitchX] Error 2
What am i doing wrong here is there a prefix that needs to be specified? Because I used ./configure without any sort of prefix considering it was suppose ot use the default.


Thank you

Last edited by Kryptow; 09-11-2002 at 06:50 AM.
 
Old 09-11-2002, 11:56 AM   #2
Kryptow
LQ Newbie
 
Registered: Aug 2002
Location: Miami, Florida
Distribution: Redhat 7.3 / 8.0
Posts: 23

Original Poster
Rep: Reputation: 15
Damn didn't think it would have been like this doesn't anyone use BitchX anymore? Or is this error something that is new and unheard of?
 
Old 09-11-2002, 12:41 PM   #3
Kryptow
LQ Newbie
 
Registered: Aug 2002
Location: Miami, Florida
Distribution: Redhat 7.3 / 8.0
Posts: 23

Original Poster
Rep: Reputation: 15
This i can't figure out what is wrong with the install everything will go ok for the first 3 steps then once i try and make it it gives me the error above. here are my steps.........


Installing BitchX with source


Download the source file, ircii-pana-xx-xx.tar.gz, and do this:
gzip -d ircii-pana-xx-xx.tar.gz
tar xvf ircii-pana-xx-xx.tar
cd ./BitchX
more INSTALLATION (Specific OS problems, etc...)
./configure
make
make install (only if you are root - to install for system)


Where is the problem?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
about BitchX skate Linux - Software 2 12-01-2004 11:21 PM
BitchX hraposo Slackware 1 10-13-2004 07:34 AM
BitchX ?? xviddivxoggmp3 Linux - Software 2 03-28-2004 06:04 PM
BitchX Help digsby0007 Linux - Software 1 01-24-2003 10:25 AM
bitchx xlord Linux - Newbie 2 03-16-2002 09:40 PM


All times are GMT -5. The time now is 04:31 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration