LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-10-2006, 09:24 AM   #1
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Lenny/Squeeze/Wheezy/Sid
Posts: 4,087

Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
BIND9 reject characters in host names


I noticed that bind9 version 9.3.1 (from the Debian testing distribution) does not accept certain characters like "_" (underscore)

I have another machine running DNS with bind9 9.2.4 which does accept this.

Unfortunately I have set up another machine for which I needed some files from the testing distribution, and I cannot install bind9 9.2.4. For different reasons this new machine *has* to become DNS server.

I don't get it. In some bind version, the option check-names was introduced to reject for characters which were not allowed. It is stated explicitely that in bind9 this option is removed and that all characters *are* accepted. To make it worse, bind9 will not load a zone file with a single error at all.

I have a local network with some tens of machines, with names like star_pc.mydomain.com. The underscore is there for historical reasons. (When our DNS was still on the windows platform, long time ago) Changing all the host names both in the zone file and on the hosts *is* doable, but these host names are also used in numerous settings in applications (like in mail clients etc), and that is NOT doable to change it there.

Does someone know whether this is a bug or a feature in bind9? Is it intentional? Is there a newer version which does not do check-names?

jlinkels
 
Old 02-10-2006, 10:00 AM   #2
jlinkels
Senior Member
 
Registered: Oct 2003
Location: Bonaire
Distribution: Debian Lenny/Squeeze/Wheezy/Sid
Posts: 4,087

Original Poster
Rep: Reputation: 492Reputation: 492Reputation: 492Reputation: 492Reputation: 492
Solved

Almost at the instant of the previous post I solved the problem by including the check-names directive in the (named.conf or named.conf.local for Debian) file.

It looks now like this:

Code:
zone "mydomain.com" {
     type master;
     file "/etc/bind/mydomain.db";
     check-names ignore;
//   check-names warning; <== This also allowed.
     };
I was confused, because this site states that check-names is not implemented in bind9. Later I discovered that ics.org states that it is back (or new) in bind9 version 9.3.

Anyway, it took only 6 hours or so to work this out

I hope it was not useless to post this experience here... although many of you are smarter than I am.
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can i limit new file names created to 8 characters with samba ? amitsharma_26 Linux - Networking 1 12-16-2005 05:42 AM
rename file names with " ? characters fishbonz Linux - Newbie 2 05-31-2005 11:20 AM
Samba host names - how? levand Linux - Networking 3 11-18-2004 04:01 AM
multiple host names tux1982 Linux - Networking 3 06-08-2004 06:35 AM
host names??? jonfa Linux - Networking 1 05-28-2001 08:15 PM


All times are GMT -5. The time now is 09:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration