LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   BFD: Dwarf Error: while profiling openmp program with HPCToolKit using GNU 4.7.2 (http://www.linuxquestions.org/questions/linux-software-2/bfd-dwarf-error-while-profiling-openmp-program-with-hpctoolkit-using-gnu-4-7-2-a-4175455033/)

pghosh06 03-21-2013 02:08 PM

BFD: Dwarf Error: while profiling openmp program with HPCToolKit using GNU 4.7.2
 
I want to profile an openMP program using the HPCToolkit tool.

I have installed hpctoolkit-externals-5.3.2-r3950 & hpctoolkit-5.3.2-r3950 (latest tarball source from the website) using the GNU 4.7.2 compiler.

I have added the hpctoolkit installation directory to my path.

However I am now encountering issues while profiling the code
This is what I did:
I want profile an openmp program with tasks: task_ex.c

1) gcc -fopenmp task_ex.c -o task_ex -O3
2) hpcrun ./task_ex 1024 4
3) hpcstruct task_ex
4) hpcprof -S task_ex.hpcstruct -I /home/priyanka/examples hpctoolkit-task_ex-measurements

This is when I obtain the following error:
msg: Line map : /home/priyanka/opt/hpctoolkit-install-5.3.2/lib/hpctoolkit/ext-libs/libmonitor.so.0.0.0
BFD: Dwarf Error: found dwarf version '4', this reader only handles version 2 and 3 information.
BFD: Dwarf Error: found dwarf version '0', this reader only handles version 2 and 3 information.
BFD: Dwarf Error: found dwarf version '886', this reader only handles version 2 and 3 information.
BFD: Dwarf Error: found dwarf version '38401', this reader only handles version 2 and 3 information.
.......
.......

Any idea as to what this error means and how one can resolve this?
Thanks in advance.


All times are GMT -5. The time now is 10:23 AM.