LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 03-10-2007, 09:48 PM   #1
cdm710
LQ Newbie
 
Registered: Oct 2005
Distribution: Suse 10.0
Posts: 11

Rep: Reputation: 0
Beryl Partially Working


Currently, some of the features of Beryl do work. I can rotate the cube, make windows transparent, zoom, make water effects, and a few other things. Windows don't wobble or anything like that. Every time I run beryl-manager nothing works.

I'm running Suse 10.2 64-bit with a 7800GT.
I used this guide to get Beryl to the point it's at now and I went with the XGL method:

http://en.opensuse.org/Beryl

When I run the gnome-xgl-switch --enable-xgl command I get the following message:

Warning! MD5DIR is not set: you probably called this script outside SuSEconfig...!
Using MD5DIR="/var/adm/SuSEconfig/md5"...
No changes for /etc/X11/xdm/Xservers
No changes for /etc/X11/xdm/xdm-config
Can't find the PID file in the configuration file, going to try:
/var/run/gdm.pid
/var/run/gdm.pid doesn't exist, perhaps GDM isn't running


I'm not sure what this means or if it's even related to the problems I'm having. I would really appreciate some help resolving this problem. Thanks!
 
Old 03-11-2007, 04:20 PM   #2
Xian
Member
 
Registered: Feb 2004
Location: 33.31N -111.97W
Distribution: SuSE
Posts: 918

Rep: Reputation: 31
My own recommendation would be to not go with the Xgl method.
 
Old 03-11-2007, 04:51 PM   #3
cdm710
LQ Newbie
 
Registered: Oct 2005
Distribution: Suse 10.0
Posts: 11

Original Poster
Rep: Reputation: 0
Alright I guess I'll try the Beryl with nVidia drivers - no Xgl/AIGLX method and see how that works. I don't have time to do it right now, but I'll let you know how it goes.
 
Old 03-15-2007, 04:39 PM   #4
cdm710
LQ Newbie
 
Registered: Oct 2005
Distribution: Suse 10.0
Posts: 11

Original Poster
Rep: Reputation: 0
In case it helps anyone, here's what I had to do to get Beryl working.

First of all, for the longest time everything I tried failed. I finally got to the point where I would get a white screen when Beryl would load. This problem eventually led me to this site:

http://www.suseforums.net/lofiversio...hp/t27038.html

After following those directions it worked...kind of...My windows had no borders. Here's what fixed that problem:

http://nlindblad.org/2007/01/28/no-w...-nvidia-aiglx/

I hope nobody has as much trouble getting Beryl to work as I did, and hopefully these instructions end up helping someone else!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installed beryl, now screen savers not working??? Xswitch Ubuntu 1 12-02-2006 03:43 AM
Beryl problems not working and locks keys in gentoo Maverick1182 Linux - Software 3 11-19-2006 05:06 PM
[Compro VideoMate TV PVR/FM] SAA7134 only partially working kashzone Linux - Hardware 1 10-13-2006 05:01 PM
firefox partially working need help possibly configuring laminac Linux - Newbie 4 10-12-2005 07:33 PM
File associations (partially) not working in KDE J_Szucs Linux - General 0 02-11-2005 12:58 AM


All times are GMT -5. The time now is 05:57 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration