LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 03-06-2007, 01:38 PM   #1
TotalLinuxNoob
Member
 
Registered: Apr 2005
Distribution: Ubuntu
Posts: 109

Rep: Reputation: 15
Beryl install - X server - no screens found


Hello fellow users
Last night I came across beryl and decided that it would be worth the little effort of installing it.. I grabbed the script of the Beryl site to install it on my Ubuntu box (Edgy Eft).
It informed me I needed a restart but this advice was ignored and Beryl was run. It looked gooood. apart from some title bar and taskbar glitches everything seemed fine.

To fully enjoy my desktop on acid I decided to restart and now it fails to start the x server:
The error is:
No devices detected.
Fatal server error:
no screens found.

Directory /usr/share/X11/fonts/misc does not exist
/usr/share/X11/fonts/misc does not exist
..load more fonts..

More output:
Default generic monitor
generic video card
(even though nvidia drivers were installed)

It does try to loadmodule nvidia..

Is there an easy way to fix this? Like reinstalling drivers or other?
Obviously I would like to have another go at running Beryl once this issue is fixed.

Thanks all
 
Old 03-06-2007, 03:24 PM   #2
TotalLinuxNoob
Member
 
Registered: Apr 2005
Distribution: Ubuntu
Posts: 109

Original Poster
Rep: Reputation: 15
Ok, I ran sudo dpkg-reconfigure xserver-xorg and selected the nv driver instead of nvidia and I can get X back up. Great.

Unfortunately I won't be playing CoD using Wine for a while. Setting the driver to nvidia returns me to the no monitor found error (this happens when I run nvidia-xconfig).

Running Beryl now totally screws up the GUI. Well, it was to be expected..

The distraction that is AMSN refuses to load (Is this a bad thing? ) - wish not found. Reinstalling fails. tk not found.

glxgears: Error: couldn't get an RGB, Double-buffered visual

I have tried reinstalling the nvidia drivers with Automatix but this returns me to the problem of no screens found. Setting the driver to nv offers half a fix.

Last edited by TotalLinuxNoob; 03-06-2007 at 04:35 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Updated SuSE 10.1 to 10.2- X server: no screens found timothyb89 Linux - Software 3 12-11-2006 07:07 AM
Fatal server error: no screens found swodniw Linux - Hardware 5 04-06-2006 01:43 PM
X server can't start Error: No screens found perl Ubuntu 3 11-28-2005 03:06 AM
The X Server cannot start because no screens are found Eerath Suse/Novell 7 11-21-2005 09:56 AM
Fatal server error: no screens found walsht3108 Linux - Newbie 1 08-26-2003 05:42 PM


All times are GMT -5. The time now is 07:32 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration