LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-19-2004, 06:37 PM   #1
talkingwires
Member
 
Registered: Jan 2004
Location: Boone, NC
Distribution: Debian SID
Posts: 49

Rep: Reputation: 15
Azureus, FAT32, and File Permissions


I'm dual booting Windows XP with Debian. Most of my harddrive is allocated to a FAT32 partition that both operating systems share. I can read and write to the FAT32 partition with Debian, creating documents and things like that. My problem comes is that when I run Azureus, it can't create files on the partition. It has no problem using my /home directory, but it won't touch my FAT32 partion.

Here's my /etc/fstab file:
Code:
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda3       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda6       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   iso9660 ro,user,noauto  0       0
/dev/hdd        /media/cdrom1   iso9660 ro,user,noauto  0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0

#let's try to mount windows, shall we?
/dev/hda5       /windows/media  vfat    defaults,rw,user,umask=000 0 2
The only the only unique thing about my setup is that the FAT32 partion is also designated as the "My Documents" folder in Windows. But as I said before, I have no troubles creating documents with other programs there. Any ideas?
 
Old 09-19-2004, 06:49 PM   #2
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
Drop defaults from the begining of the options.
 
Old 09-19-2004, 07:09 PM   #3
talkingwires
Member
 
Registered: Jan 2004
Location: Boone, NC
Distribution: Debian SID
Posts: 49

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by leonscape
Drop defaults from the begining of the options.
Do you mean from here?
Code:
proc            /proc           proc    defaults        0       0
Should I replace it with anything, or just delete "defaults" from that line? Sorry if I seem a little slow, but I need to make sure before I start taking out parts of my fstab file.
 
Old 09-19-2004, 07:12 PM   #4
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
/dev/hda5 /windows/media vfat rw,user,umask=0000 0 2

No like above. Also the umask could need an extra 0.
 
Old 09-19-2004, 08:18 PM   #5
talkingwires
Member
 
Registered: Jan 2004
Location: Boone, NC
Distribution: Debian SID
Posts: 49

Original Poster
Rep: Reputation: 15
Thanks, I'll check it out.
 
Old 09-21-2004, 09:01 PM   #6
talkingwires
Member
 
Registered: Jan 2004
Location: Boone, NC
Distribution: Debian SID
Posts: 49

Original Poster
Rep: Reputation: 15
It's still not working.

I thought that it may have to do with the permissions of /windows/media/, where the partition is mounted. I've been trying to set it up like the /home directory with group/user for /windows being staff/root and the group/user for /windows/media being ben/ben. That would be convient, since /windows/media is My Documents in Windows. Then I could just make a link to it and have My Music, My Pictures, etc in my /home directory. But I can't change the membership/ownership of /windows/media, only /windows, even as root. The recurisive option doesn't work, either. Oh, and I tried mounting /dev/hda5 as /home/ben/media, too.

Here's my current setup:

fstab
Code:
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda3       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda6       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   iso9660 ro,user,noauto  0       0
/dev/hdd        /media/cdrom1   iso9660 ro,user,noauto  0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0

#let's try to mount windows, shall we?
/dev/hda5       /windows/media  vfat    rw,users,umask=000 0 0

#hrm, i dunno. some forum post told me to add this when upgrading to 2.6
none /sys sysfs defaults 0 0
Is there any way I can make /windows/media belong to my user id, and not root? Is there any way to get Azureus to be able to write to my FAT32 partition? I'm pulling my hair out here...
 
Old 09-21-2004, 09:07 PM   #7
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
you should have four zeros on umask=0000. You can give a uid or gid for the device.
If your user id is a 1000.

/dev/hda5 /windows/media vfat rw,users,umask=0000,uid=1000 0 0
 
Old 09-21-2004, 09:39 PM   #8
talkingwires
Member
 
Registered: Jan 2004
Location: Boone, NC
Distribution: Debian SID
Posts: 49

Original Poster
Rep: Reputation: 15
Okay, I set my uid and gid in fstab:
Code:
/dev/hda5       /windows/media  vfat    rw,users,umask=0000,uid=1000,gid=1000 0 0
I show up as the group and owner of /windows/media and everything in it. And I still get this:
http://img.photobucket.com/albums/v6...ureuserror.png

Could this somehow be related to Java? (grasping at straws...)

Last edited by talkingwires; 09-21-2004 at 09:41 PM.
 
Old 09-21-2004, 09:43 PM   #9
leonscape
Senior Member
 
Registered: Aug 2003
Location: UK
Distribution: Debian SID / KDE 3.5
Posts: 2,313

Rep: Reputation: 47
Try opening the file in something else. If it opens ( which I think it will ) then its a fault in the program your trying to use. or its set up.
 
Old 09-21-2004, 09:52 PM   #10
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
FAT does not support Linux permissions, so you will be stuck to whatever permissions you set through fstab or the mount command. You can add a group called windows and note the gid number. Then specify the gid in your fstab file. Next pick users that you want to have access to the drive by adding them to the group.

After you mount /dev/hda5, make sure you chmod it too 777.
 
Old 09-21-2004, 10:05 PM   #11
talkingwires
Member
 
Registered: Jan 2004
Location: Boone, NC
Distribution: Debian SID
Posts: 49

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Electro
FAT does not support Linux permissions, so you will be stuck to whatever permissions you set through fstab or the mount command. You can add a group called windows and note the gid number. Then specify the gid in your fstab file. Next pick users that you want to have access to the drive by adding them to the group.

After you mount /dev/hda5, make sure you chmod it too 777.
I've essentially done that. The fstab specifies the group and owner as ben. Needless to say, I'm a member of ben (it's my uid and gid). The directory is chmod'ed 777. The program is setup properly, because I can download files to /windows/media with it while logged in as root.

I'm at a loss as what else to do. If I modify Azureus' start script to do a sudo before it launches the JAR file, will the files it writes to my directory be owned by root, or will they assume the permissions and ownership of the directory they are written to? I can live with that, I guess...
 
Old 09-21-2004, 10:09 PM   #12
talkingwires
Member
 
Registered: Jan 2004
Location: Boone, NC
Distribution: Debian SID
Posts: 49

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by talkingwires
If I modify Azureus' start script to do a sudo before it launches the JAR file, will the files it writes to my directory be owned by root, or will they assume the permissions and ownership of the directory they are written to?
I tested it out, and they are owned by me instead of root. I guess that goes back to what you said about FAT32 not supporting Linux file permissions. So I guess I'll just modify the start script for Azureus. And maybe go file a bug report....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
fat32 file access permissions wwnexc Linux - Security 2 09-05-2005 10:04 PM
Can't change permissions for FAT32-HD ghanalinux Linux - Hardware 2 06-19-2005 11:10 PM
Azureus file resuming on fat32 therock598 Linux - Software 0 10-27-2004 03:51 PM
problem changing file permissions on fat32 partition coolamit78 Linux - Software 4 01-18-2004 01:44 PM
permissions on fat32 fubar Treat84 Linux - Hardware 2 09-05-2003 07:36 PM


All times are GMT -5. The time now is 04:47 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration