LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-03-2005, 07:01 PM   #1
ktane
LQ Newbie
 
Registered: Oct 2005
Location: Mars
Distribution: Mandriva 2006
Posts: 1

Rep: Reputation: 0
Azureus


I have installed Azureus for Linux, and everytime i want it to start-up, i type in the command line ./azureus, which is pretty annoying .. Is there any other way then typing in the konsole everytime i want to start up the Azureus ?

Like Put The Azureus in /home/ktane/Desktop and just double-click it to start it up, just like MicroSuck Windows !

Azureus file is in my /usr/local/src/azureus, and onces i went into that directory, I just type in ./azureus !

Hope you can help ! Thanks
 
Old 11-03-2005, 08:50 PM   #2
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
As root, su, or sudo create a bash script in /usr/bin called azureus and chmod to 750. Something like the code below should work for any user.

#!/bin/sh
AZUREUS_PATH="/usr/local/src/azureus"
cd $AZUREUS_PATH
./azureus

Another way is to add an alias to .bashrc_profile, .bashrc, or /etc/profile.
 
Old 11-04-2005, 05:15 AM   #3
muddywaters
Member
 
Registered: May 2005
Location: Winnipeg, Canada
Distribution: mostly mepis
Posts: 427

Rep: Reputation: 30
Are you asking how to put a shortcut on your desktop ?

If using kde;
-right click desktop
-create new file->link to application
-application
-fill in Azureus as description
-In command box fill in path to application ie; /usr/local/src/azureus/azureus , the second azureus being your shell script
-That cute frog png can be used as an icon

Gnome works much the same. I'll let you figure out the double-click thing.

EDIT: In the general tab change 'link to application' to read 'Azureus'. Looks tidier this way

Last edited by muddywaters; 11-04-2005 at 05:54 AM.
 
Old 11-04-2005, 07:57 AM   #4
Dtsazza
Member
 
Registered: Oct 2005
Location: Oxford, UK
Distribution: Debian Etch (w/ dual-boot XP for gaming)
Posts: 282

Rep: Reputation: 30
You know what's strange? I ended up always running Azureus from the console, because I couldn't get it to run in any other context. No error messages or anything - it just didn't start (even when I ticked KDE's "run in console" option on the shortcut). It was probably something to do with my Java runtime config, though after a quick google I gave up since I usually do things from the console anyway.

I'd be interested to know if you had the same issue, since it's one of those niggly annoying things that I don't know what the problem with it was. If so, I'll help you through it as best I can.
 
Old 11-04-2005, 08:31 AM   #5
arre
LQ Newbie
 
Registered: Nov 2005
Location: Belgium
Distribution: Slackware 10.2 & Windows 98 & Windows XP Pro & ...
Posts: 10

Rep: Reputation: 0
Rightclick on the KDE button, menu editor, start path, where you compiled it, and command ./azeurus

Pretty obvious
 
Old 11-17-2005, 03:29 AM   #6
Snacho
LQ Newbie
 
Registered: Nov 2005
Distribution: Ubuntu
Posts: 2

Rep: Reputation: 0
Quote:
Originally posted by Dtsazza
You know what's strange? I ended up always running Azureus from the console, because I couldn't get it to run in any other context. No error messages or anything - it just didn't start (even when I ticked KDE's "run in console" option on the shortcut). It was probably something to do with my Java runtime config, though after a quick google I gave up since I usually do things from the console anyway.

I'd be interested to know if you had the same issue, since it's one of those niggly annoying things that I don't know what the problem with it was. If so, I'll help you through it as best I can.
I had the same issue. It's annoying..
I use ubuntu 5.10 (upgraded from hoary).
It's very strange that it's not working even I try to run it from gnome-console with -e azureus option. (It will run when I type azureus in gnome-console)
So what's the problem?
 
Old 11-17-2005, 04:10 PM   #7
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
I already posted the fix but it seems nobody wants to do it.
 
Old 11-17-2005, 04:45 PM   #8
Snacho
LQ Newbie
 
Registered: Nov 2005
Distribution: Ubuntu
Posts: 2

Rep: Reputation: 0
Quote:
Originally posted by Electro
I already posted the fix but it seems nobody wants to do it.
Tried but still doesn't work.. annoying..
 
Old 11-17-2005, 05:13 PM   #9
Electro
Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
Quote:
Originally posted by Snacho
Tried but still doesn't work.. annoying..
The reason it does not work for you. You do not know bash scripting. It does work though. I tried it in many distributions such as Mandrake 9, Mandrake 10, Slackware, and Gentoo. All work the same way. Depending how the distribution is setup, you may need to set the permissions to 755 for /usr/bin/azureus. If /usr/bin comes after /usr/local/bin in the PATH environment variable then you have to change the order. The path that AZUREUS_PATH points to was for the thread starter, so you may have to change it to work for your setup.
 
Old 11-17-2005, 08:10 PM   #10
muddywaters
Member
 
Registered: May 2005
Location: Winnipeg, Canada
Distribution: mostly mepis
Posts: 427

Rep: Reputation: 30
Re: Azureus

Electro

Sorry if it appeared that I was second guessing your advice. If so it wasn't intentional. It just seemed that part of the question was not addressed.

Quote:
Originally posted by ktane

Like Put The Azureus in /home/ktane/Desktop and just double-click it to start it up, just like MicroSuck Windows !
The method I outlined for the shortcut works for me with blender. /usr/local/src/blender/blender. It seems it's not a working solution for others. Also tried launching it with your short script. It works fine.
 
Old 11-29-2005, 06:19 PM   #11
positrox
LQ Newbie
 
Registered: Nov 2005
Distribution: SuSe, Debian
Posts: 26

Rep: Reputation: 15
I have the same problem too when starting Azureus. It's strange because the shotcut in desktop works with every other program. I would be happy to solve this thing up.
 
Old 11-29-2005, 09:12 PM   #12
number9
Member
 
Registered: Dec 2003
Location: Fresno
Distribution: Gentoo Ricer
Posts: 85

Rep: Reputation: 15
You might need to put the full path the the binary in the properties for the icon you are creating.
 
Old 11-30-2005, 03:02 PM   #13
positrox
LQ Newbie
 
Registered: Nov 2005
Distribution: SuSe, Debian
Posts: 26

Rep: Reputation: 15
Yes isnt that an truism?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Azureus viciadoemlinux Linux - Software 3 12-02-2005 10:13 PM
Azureus +firewall: UDP-discovery drop packetsport 8008 alt_http What is Azureus doing Emmanuel_uk Linux - Networking 0 08-31-2005 06:06 AM
Azureus lostdata Linux - Software 6 08-24-2005 12:52 AM
Azureus lostdata Linux - Software 2 08-20-2005 07:14 AM
azureus installed..azureus script can be moved? nixel Slackware 1 05-22-2004 10:22 PM


All times are GMT -5. The time now is 09:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration