LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 09-08-2004, 12:45 AM   #1
Norin311
Member
 
Registered: Sep 2004
Location: USA/Maine
Distribution: SuSE 9.1 on P4 2.8E GHz 800 MHz, 1.5GB RAM, ATI Radeon 9200SE 128MB, 120GB SATA Master, 80GB Slave
Posts: 79

Rep: Reputation: 15
autoplay audio cds and dvds


this question may have been asked. or not untill now. but it seems this is the only way i can see if some one knows how to answer my question. how can i get linux to autoplay my audio cds, and play them with sound?
 
Old 09-08-2004, 07:12 AM   #2
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
More information, please.

Now, what you are saying is that audio CDs don't autoplay (which is an optional feature, so we'll put that aside), and also that when you play them manually, you don't get sound?

So you have an interface problem (autoplay audio CDs), and a hardware or configuration problem (no sound from audio CDs)?

Let's deal with the sound problem first.

Do you have sound generally, but just not with audio CDs? If you do not have sound at all, what is your sound card, and do you know what drivers you are using? If you do have sound, but not when playing an audio CD, what program are you using to play them?
 
Old 09-08-2004, 11:27 AM   #3
Norin311
Member
 
Registered: Sep 2004
Location: USA/Maine
Distribution: SuSE 9.1 on P4 2.8E GHz 800 MHz, 1.5GB RAM, ATI Radeon 9200SE 128MB, 120GB SATA Master, 80GB Slave
Posts: 79

Original Poster
Rep: Reputation: 15
ok well here it is. well the autoplay yes is a opt-in feature. i know but i may have worded that poorly. what i meant was that when i insert the audio cd the cd will begin to play but there will be no sound whatsoever. i have sound. only i don't get sound with Gaim. that is really the only other program i know of that will not use sound efficiently. with Gaim i only get system beeps. but that is default in the sounds option in Preferences. I only need to figure out how i can get more sound options. as far as other sounds are concerned. YaST plays sounds when i download packages and when i download a file i get sounds. so i do have sounds. just not with Gaim [atleast not the desired sounds] nor with Kscd. or any other cd player program. i have tried all the default media programs that are preconfigured with SuSE 9.1
 
Old 09-08-2004, 01:00 PM   #4
motub
Senior Member
 
Registered: Sep 2003
Location: The Netherlands
Distribution: Gentoo (main); SuSE 9.3 (fallback)
Posts: 1,607

Rep: Reputation: 46
OK, two things you need to do:

1) Since you are using KDE, and therefore the aRTs sound server, you should configure Gaim and all other multimedia programs to use any aRTs output plugin they may possess, so that aRTs can manage their sound output. Otherwise, aRTs will take control of the sound card so that nothing else can use it.

2) I've just opened up Kscd, to look at the config, and I see that it's very similar to the way I would tell you to configure XMMS (which is what I use on the rare occasion that I play an audio CD in my PC).

Here's what you do:

a) In the main Kscd window, click "Extras", and go to "Configure Kscd".

b) In the "General" tab, confirm that the CD-ROM Device field is the correct one for your CD-ROM (the /dev/cdrom that is filled in is just the default; your device may be /dev/hdc, like mine, or /dev/cdroms/cdrom0, or even /dev/sg*. So if you don't know, check /etc/fstab or the /dev/ folder itself for the actual device designation.

c) Check the "Use digital device playback" checkbox. Unless you have a physical audio cable connecting your CD-ROM drive to your soundcard (most current PCs no longer have this cable, although one may have come with your CD-ROM drive if you bought it standalone), you will not be able to hear anything unless this box is checked (not having the box checked means you'd be using analog sound, which needs the analog cable specified above).

d) Checking the "Use digital device playback" checkbox will display a couple more sub-choices; make sure that the "audio backend" is set to "arts". I'm not completely sure if you need to fill in the field labelled "use audio device", but if so, the field should probably contain something along the lines of /dev/dsp (or /dev/dsp0, depending on your setup). It's quite possible that once you have specified the arts server as the audio backend, it will use those settings without you having to fill in anything further.

Anyway, hope this helps. It just worked for me (as I said, I don't play many audio CDs on my PC, so Kscd was not configured). I just did so successfully-- but the difference between my setup and yours is that I don't use arts, but alsa. The Kscd alsa backend seems to be fine, though-- it just looked up a CD from freecddb and it's working properly.
 
Old 09-08-2004, 02:11 PM   #5
Norin311
Member
 
Registered: Sep 2004
Location: USA/Maine
Distribution: SuSE 9.1 on P4 2.8E GHz 800 MHz, 1.5GB RAM, ATI Radeon 9200SE 128MB, 120GB SATA Master, 80GB Slave
Posts: 79

Original Poster
Rep: Reputation: 15
ok well first i don't have the use digital device checkbox. and there is no general tab only CD Player and freedb. but yes my cdrom is listed there in the cdrom device box. and i do use the analog cable connected from the cdrom as well as dvdrom connected to the sound card. should i remove this? and not use it? would that work?

well here is a run down of options i can use,...

-CD Player-

[interface]
LCD color:............[..............]
BG color:..............[..............]
[ ] Show icon in sys tray

[play options]
Skip interval:.....[.....30 Secs]
[X] Autoplay CD when Inserted
[..] eject cd when finished
[X] stop playing on exit

[Cdrom device]
[/dev/cdrom........................................................] [|/_'/]
[ ] use direct digital playback

^--- i did not see that before... ^_^ shall i remove the analog cables and see if this box will now be un hidden. [it is currently grayed out.]

i hope this helps in helping me figure this out.

and what about gaim? how can i use different sounds enabled?
and what of this alsa? is that gaim compatable? and how will i find and install it. and yes i did get xmms but i am having trouble installing. i believe i made a post about it. i am not sure.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
automounting cds/dvds nelsonlobo Debian 5 10-12-2005 10:02 AM
burning cds and dvds kurrupt Linux - Software 1 08-20-2004 10:36 PM
Command to autoplay audio cd cgoerner Linux - Software 1 08-19-2004 04:12 AM
problems reading audio CDs, data DVDs and CD-Rs umberleigh Linux - Hardware 4 07-29-2004 08:46 AM
Burning CDs and DVDs KillerFry Slackware 2 09-28-2003 11:31 AM


All times are GMT -5. The time now is 01:27 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration