LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   autogen.sh fails: libtool.m4 / ltmain.sh version mismatch (http://www.linuxquestions.org/questions/linux-software-2/autogen-sh-fails-libtool-m4-ltmain-sh-version-mismatch-612033/)

jrtayloriv 01-08-2008 01:23 PM

autogen.sh fails: libtool.m4 / ltmain.sh version mismatch
 
I am trying to run an autogen.sh script and am receiving the following error:

Quote:

checking for correct ltmain.sh version... no
configure: error:

*** [Gentoo] sanity check failed! ***
*** libtool.m4 and ltmain.sh have a version mismatch! ***
*** (libtool.m4 = 1.5.24, ltmain.sh = 1.5.22) ***

Please run:

libtoolize --copy --force

if appropriate, please contact the maintainer of this
package (or your distribution) for help.
I tried running libtoolize --copy --force as it said and received the following message:


Quote:

Using `AC_PROG_RANLIB' is rendered obsolete by `AC_PROG_LIBTOOL'

I tried reinstalling m4, autoconf, libtool, and make. No dice.

So then I tried copying /usr/share/libtool/ltmain.sh into the build directory, to overwrite the ltmain.sh that was in there. Now autogen.sh gets through without errors.


I've never had to do this before,though (copying ltmain.sh). Is this something that is normally done automatically? How do I fix it?


Thanks,
Jesse

Emerson 01-09-2008 02:06 PM

Search http://bugs.gentoo.org/ and file a bug if it's new.


All times are GMT -5. The time now is 02:29 PM.