LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-23-2004, 11:59 AM   #1
marsques
Member
 
Registered: Jan 2004
Location: Manchester
Distribution: slackware...
Posts: 343

Rep: Reputation: 31
auto start kde...


i use firestarter as ma firewall on kde... is there anyway to make firestarter start automatically when kde loads as root without me having to enter the root password everytime...

if i wanted programs to start automatically in X is there a file that i can edit and put the path to the program there?

thank in advance....

Last edited by marsques; 07-23-2004 at 12:01 PM.
 
Old 07-23-2004, 01:28 PM   #2
larrykeenan
Member
 
Registered: Apr 2004
Location: Brisbane Australia
Distribution: UBUNTU 13.04
Posts: 59

Rep: Reputation: 19
Log in as root
Load /etc/rc.local in your favorite editor.
Place your commands after the conditional stuff.

Have Fun,
Larry
 
Old 07-23-2004, 02:57 PM   #3
marsques
Member
 
Registered: Jan 2004
Location: Manchester
Distribution: slackware...
Posts: 343

Original Poster
Rep: Reputation: 31
cheers... will give that a ago...
 
Old 07-23-2004, 04:33 PM   #4
marsques
Member
 
Registered: Jan 2004
Location: Manchester
Distribution: slackware...
Posts: 343

Original Poster
Rep: Reputation: 31
tried it... but it tries to start firestarter which required X-windows in console mode...

is there any way where i can make firestarter to start automatically after kde has loaded with out me having to enter the root password (ie when anyone logs in and when on and it boots in to kde ... that firestarter starts automatically and that any user other than root cannot close it down)

thank in advance...

Last edited by marsques; 07-23-2004 at 04:35 PM.
 
Old 07-23-2004, 04:41 PM   #5
tbeehler
Member
 
Registered: Aug 2003
Location: Washington State, USA
Distribution: Mainly RH 9.0
Posts: 226

Rep: Reputation: 30
Sure thing. open up a console window, I think you need to be root to do this as well, and type in "chkconfig firestarter on" without the quotes. That'll tell the firestarter service to turn on at boot. If you restart you're machine, you should see it start up when it starts up everything. Or you could just type in the command and leave it. Hope that helps you out! Also, if you type in "chkconfig --list" without the quotes again, it'll list all of your services that you can turn on and off at will. You can also do the command "service firestarter on" without the quotes, but that just turns it on for as long as you have your machine turned on and it goes back to off when you reboot. If you have any problems or questions, feel free to ask!

Travis Beehler
 
Old 07-23-2004, 05:18 PM   #6
marsques
Member
 
Registered: Jan 2004
Location: Manchester
Distribution: slackware...
Posts: 343

Original Poster
Rep: Reputation: 31
followed your instructions but i keep getting the message
Code:
error reading information on service firestarter: No such file or directory
it looks like "chkconfig" look in the /etc/rc.d/rc[1-6].d directories for services... but i dont have a service called firestarter running as it is a program...

then what i did was in /etc/rc.d/rc6.d directory created a link
Code:
ln -s /usr/local/bin/firestarter fireservice
then
Code:
chkconfig fireservice on
but i still keep getting the message
Code:
error reading information on service fireservice: No such file or directory
pls advice....

thanks in advance...
 
Old 07-23-2004, 05:26 PM   #7
tbeehler
Member
 
Registered: Aug 2003
Location: Washington State, USA
Distribution: Mainly RH 9.0
Posts: 226

Rep: Reputation: 30
Just out of morbid curiousity, are you running the latest version of firestarter? When I installed mine, it automatically added the service for me. Also, have you run through the little firestarter wizard? (That may be when it installs the service, but that's a guess.) Let me know and we'll squash this bug for ya.

Travis
 
Old 07-23-2004, 05:39 PM   #8
marsques
Member
 
Registered: Jan 2004
Location: Manchester
Distribution: slackware...
Posts: 343

Original Poster
Rep: Reputation: 31
i'm running 0.9.3... yeah ran the wizard as well (also the wizard was run on first use)...

Last edited by marsques; 07-23-2004 at 05:41 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I auto start modules that aren't auto loaded on boot? darkbluedrew Debian 2 09-18-2005 09:10 AM
eth0 Auto Connect, How to auto start on logon cornish Linux - Networking 2 05-09-2005 12:02 PM
auto start up Daz_Man2803 Linux - Newbie 1 06-14-2004 02:32 PM
KDE auto start script problem Coolrunr Programming 2 09-08-2003 09:55 PM
Auto Start eggoz Linux - General 1 03-21-2003 09:10 PM


All times are GMT -5. The time now is 09:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration