LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 11-01-2008, 05:09 PM   #1
rc nai
Member
 
Registered: Jun 2008
Distribution: Slackware 13.37,14
Posts: 73

Rep: Reputation: 18
Audio/Skipping Issues With .MOV Files


Hi, I have several questions to ask, please bare with me.

I don't know much about media stuff, but I have here a .mov file that's 85mb. When I play it with Xine it works but no audio. And also, whenever I want to skip to a certain point in the video by clicking the streaming bar, the video automatically skips back to the beginning. Is there an explanation for this?

I am able to play .avi, .wmv, and the likes with no problems. The video and audio is perfect on those types of files with Xine.

Anyway I thought this was a codec issue and so I checked over at /usr/lib/codecs/ and their were no codecs present. I thought by installing mplayer codecs in /usr/lib/codecs and make Xine use those codecs it would fix this audio and skipping issue, but it didn't. Forgot to mention that before I did that I uncommented out a line in .xine config file which was this:
Code:
#decoder.external.win32_codecs_path:/usr/lib/codecs
And another thing with .mov files, in order for me to skip to a certain point in the video, I have to wait 1-2 minutes before I can skip the video. Can someone explain?

I thought by installing mplayer, it would fix this issue and so I installed mplayer including all its codecs with slackbuild scripts on my other test machine. Then I played the .mov files and I could hear the audio which is good but I couldn't skip the video. Everytime I tryed skipping the video to a certain point, the video would automatically go back to the beginning. Is their an explanation for this?

The only fix that I know is if I convert the .mov file to a .wmv file with ffmpeg:
Code:
ffmpeg -i original.mov -acodec wmav2 new.wmv
^ If I did that, the video will lose some quality but that's the only way I know of fixing this audio and skipping issue.

How can I make Xine or Mplayer to play and skip .mov files properly?

Any help or suggestions would be appreciated, thanks in advance.
 
Old 11-02-2008, 03:00 PM   #2
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,353

Rep: Reputation: 205Reputation: 205Reputation: 205
What's the CPU usage when playing the MOV file? Most audio issues I experience are CPU related when trying to play HD video on a relatively slow maching ~2GHz. Probably not an issue with the media itself since you seem to suggest that it plays fine, if converted. You may also have some filters applied that are using your cpu. VLC and sometimes mplayer have the ability to deinterlace and other image improving / cpu cycles eating steps to the playback process.

As far as jumping back to the beginning when trying to jump around. The video may not have an index. You can make mplayer make and index before playback with -idx or -forceidx parameters. It delays the start a little bit, but it should work.

mplayer -idx -lavdopts skiploopfilter=all file.mov
vlc -skiploopfilter 4 file.mov
 
Old 11-02-2008, 06:25 PM   #3
rc nai
Member
 
Registered: Jun 2008
Distribution: Slackware 13.37,14
Posts: 73

Original Poster
Rep: Reputation: 18
Quote:
What's the CPU usage when playing the MOV file?
With Xine it's below 15%, I'm guessing that's a good thing.
Quote:
You may also have some filters applied that are using your cpu.
Under Xine, I enable and disable a few settings that can increase performance and lower my cpu usage. The settings displayed help tips so no confusion on that part.

As for mplayer settings, I left everything at default. I'll experiment with the settings a bit and see what I can do.
Quote:
As far as jumping back to the beginning when trying to jump around. The video may not have an index. You can make mplayer make and index before playback with -idx or -forceidx parameters. It delays the start a little bit, but it should work.

mplayer -idx -lavdopts skiploopfilter=all file.mov
vlc -skiploopfilter 4 file.mov
Thanks I'll try that and see if it works and if it doesn't work I'll post back asap.
 
  


Reply

Tags
audio, codec, mov, mplayer, slackware, xine


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Extract audio from mov file sigma_50 Linux - Desktop 3 05-31-2008 02:35 AM
Hellacious Audio Skipping chris319 Ubuntu 1 09-08-2007 11:14 PM
.MOV audio codecs?!? Vid Linux - Software 3 02-11-2004 11:36 PM
Trouble getting .avi .mov .mov files to run redman13 Linux - Newbie 4 11-09-2003 01:46 PM
mplayer // I am only getting audio for .mov files Wapo Linux - Software 6 07-29-2003 08:06 PM


All times are GMT -5. The time now is 01:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration