LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-31-2000, 03:09 AM   #1
ToodC
LQ Newbie
 
Registered: Dec 2000
Location: Hawaii
Posts: 1

Rep: Reputation: 0
Angry


Hi

I had a very succefull initial redhat linux install on my laptop. In my initial step to remove bill gates from my life. Anyway all went well except the audio card is not responding...

Here is what windoze said about it before I fired that operating system

Audio Properties ESS1879
DMA 2
IRQ 90
220-022f
0388-038b
0300-0301

I have ran sndconfig and it did not have a driver tried using es1868 no luck there even modified the modules.conf file to try and get all the settings perfect here is what that file is showing now.

alias parport_lowlevel parport_pc
alias usb-controller usb-uhci
alias sound-slot-0 sb
options sopund dmabuf=1
alias midi opl3
options opl3 io=0x388
options sb io=0x220 irq=9 dma-2 mpu_io=0x300

It gives me a bunch of failure indications when it boots. I am brand new at this and have took the help files and on-line docments as about as far as I can go....

A detailed hey dummy look here would be appreciated.

Todd....
 
Old 01-06-2001, 01:00 PM   #2
ssadams
Member
 
Registered: Dec 2000
Location: Toronto Canada
Distribution: slackware 7.1
Posts: 95

Rep: Reputation: 15
taken from the linux kernel Documentation for sound.


modprobe sound
insmod uart401
insmod sb ...

This loads the driver for the Sound Blaster and assorted clones. Cards that
are covered by other drivers should not be using this driver.

The Sound Blaster module takes the following arguments

io I/O address of the Sound Blaster chip (0x220,0x240,0x260,0x280)
irq IRQ of the Sound Blaster chip (5,7,9,10)
dma 8-bit DMA channel for the Sound Blaster (0,1,3)
dma16 16-bit DMA channel for SB16 and equivalent cards (5,6,7)
mpu_io I/O for MPU chip if present (0x300,0x330)

mad16=1 Set when loading this as part of the MAD16 setup only
trix=1 Set when loading this as part of the Audiotrix setup only
pas2=1 Set when loading this as part of the Pas2 setup only
sm_games=1 Set if you have a Logitech soundman games
acer=1 Set this to detect cards in some ACER notebooks
mwave_bug=1 Set if you are trying to use this driver with mwave (see on)

You may well want to load the opl3 driver for synth music on most SB and
clone SB devices

insmod opl3 io=0x388

check your settings,modules.conf or conf.modules and how the system is loading modules.

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
VSFTP is giving me fits! Swatson Linux - Newbie 2 07-04-2004 09:32 AM
MySQL 4.0.15 giving me fits with recent 9.1 slack upgrade absolute0net Slackware 5 06-07-2004 09:37 AM
Why is MySQL 4.0.15a giving me fits in Slack 9.1? absolute0net Linux - Newbie 0 06-06-2004 11:47 PM
Es1879 and SuSE 8.1 Cern Linux - Laptop and Netbook 0 08-04-2003 11:09 AM
Help needed for ethernet card giving messenger card could not be intilized tarak4u Linux - Networking 1 02-20-2002 10:41 AM


All times are GMT -5. The time now is 01:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration