Register a domain and help support LQ
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 05-14-2004, 08:42 PM   #1
Registered: May 2004
Distribution: Ubuntu Warty
Posts: 61

Rep: Reputation: 15
Audacity Make Error

cd libmad && make
/bin/sh: line 1: cd: libmad: No such file or directory
make[1]: *** [libmad/.libs/libmad.a] Error 1
make[1]: Leaving directory `/home/stephen/downloads/audacity-src-1.2.0/lib-src'
make: *** [audacity] Error 2

I have the binary of libmad and the devel installed.
Dunno where or why it's going wrong.
Anyone shed any light on it ?

ps when configuring I'm using the --with-libmad
if I don't then when compiled it won't open mp3.

Old 04-16-2005, 02:06 PM   #2
Registered: Oct 2003
Location: Singapore
Distribution: Fedora Core 2
Posts: 32

Rep: Reputation: 15
you need to run the configure script as follows:

./configure --with-libmad=system

and make sure that libmad libraries are in /usr/lib or in a directory in LD_LIBRARY_PATH
Old 04-16-2005, 04:09 PM   #3
Senior Member
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
i'm certainly not saying the above is not a fix but you really don't have to pass any arguments to audacity for it to support the things you have installed. It checks and configures correctly on it's own.
i just did ./configure and my config.log says
#define USE_LADSPA 1
#define USE_LIBMAD 1

first it checks for bsd style mad and that fails then later it does
configure:3794: checking mad.h presence
configure:3804: g++ -E
configure:3810: $? = 0
configure:3830: result: yes
configure:3865: checking for mad.h
configure:3872: result: yes


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Audacity: error initializing i/o layer linmix Linux - Software 3 10-28-2005 05:22 PM
Audacity i/o error linmix Linux - Software 4 02-03-2005 10:32 AM
audacity compile error spoto Linux - Software 0 12-21-2003 10:39 AM
audacity run error jasonmcneil0 Linux - Software 4 11-12-2003 07:46 PM
audacity compile error vance Linux - Software 0 10-26-2003 11:50 PM

All times are GMT -5. The time now is 08:06 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration