LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-06-2003, 02:59 PM   #1
Calum
Member
 
Registered: Mar 2002
Location: London
Distribution: Red Hat 9
Posts: 302

Rep: Reputation: 30
Audacity - /dev/dsp is an invalid device


hello.
when i go into file > preferences in audacity and try to change anything, i get this:

"Error - invalid playback device" whenever i try to change anything and then click OK to exit.
the playback device is set to /dev/dsp which is the only valid playback device on my system.

this stops me from changing any of the other prefs, specifically bitrates etc.

i googled for this but only found people saying "don't change the preferences", which is no help to me.

Any ideas?

thanks in advance...
 
Old 11-06-2003, 10:24 PM   #2
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
maybe check the permissions for /dev/dsp. is it accessible to everyone?
 
Old 11-08-2003, 04:43 PM   #3
Calum
Member
 
Registered: Mar 2002
Location: London
Distribution: Red Hat 9
Posts: 302

Original Poster
Rep: Reputation: 30
permissions are 777 on /dev/dsp
the default permissions on /dev/dsp in slack 9 are pretty strict so i generally change them to 777 out of habit.

incidentally, i read your signature and thought of this, from a book i am reading:

Quote:
The news that they have nothing to fear is guaranteed to strike terror into the hearts of innocents everywhere - Terry Pratchett - The Fifth Elephant
 
Old 12-13-2003, 11:35 AM   #4
paulo1b
LQ Newbie
 
Registered: Dec 2003
Posts: 1

Rep: Reputation: 0
>when i go into file > preferences in audacity and try to change anything, i get this:
> "Error - invalid playback device" whenever i try to change anything and then click OK > to exit.

I have the very same problem, except that /dev/dsp is just a link to /dev/sound/dsp, but anyway, it wouldn't work either with that one.
NB: My distro is Mandrake 9.2
 
Old 12-14-2003, 05:50 PM   #5
Calum
Member
 
Registered: Mar 2002
Location: London
Distribution: Red Hat 9
Posts: 302

Original Poster
Rep: Reputation: 30
the best advice ive heard so far is to upgrade to a newer beta version of audacity, or to edit the config files by hand.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
device /dev/dsp can't be opened (No such device) brilvan Linux - Distributions 4 02-10-2007 09:26 PM
device /dev/dsp can't be opened (No such device) bigbossandy Slackware 4 06-17-2005 03:14 PM
no sound in transfusion - /dev/dsp invalid argument LavaDevil94 Linux - Games 5 11-28-2004 10:02 PM
?dev/dsp no such device RedHat 9.0 mickboda Linux - Hardware 1 12-06-2003 07:17 PM
device /dev/dsp can't be opened (no such device) ex0r Linux - Newbie 3 06-27-2003 10:41 AM


All times are GMT -5. The time now is 11:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration