LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-12-2006, 06:16 AM   #1
albertBeach
LQ Newbie
 
Registered: May 2006
Location: Australia
Distribution: Fedora Core 7,9,12 CentOs 5
Posts: 26

Rep: Reputation: 15
Question audacity config err. not recognising wx-config ver 2.6


A little advice please.. On Audacity configuration

I am running FC5 2.6.17-1.2174_FC5smp
I have built everything so far from source and I am having trouble.. understanding in what I don't have.
I have vers wxGTK-2.6.3 and it compiled ok
I can see the wx-config file in /usr/local/lib also the symlinks pointing to
/usr/local/lib/wx/config where gtk2-ansi-release-2.6 is?

The following is the tail of the config script.

" checking for wx-config... /usr/local/bin/wx-config
configure: Checking that the installed version of wxWidgets is 2.4.x

Warning: No config found to match: /usr/local/bin/wx-config --version=2.4 --release
in /usr/local/lib/wx/config
If you require this configuration, please install the desired
library build. If this is part of an automated configuration
test and no other errors occur, you may safely ignore it.
You may use wx-config --list to see all configs available in
the default prefix.

configure: error: Unable to locate a suitable configuration of wxWidgets v2.4.x.
The currently available configurations are listed below. If necessary, either
install the package for your distribution or download the 2.4.x version of
wxWidgets from http://wxwidgets.org.
To help configure find the right version set WX_CONFIG to point to it.
wxWidgets 2.5.x and 2.6.x are NOT supported!

Can you point me in the right direction..I think I have googled in a circle so far and
I can stand a little more beating.. toe get this right.
but I'm dead keen

Thanks in advance

regards
albert
 
Old 12-13-2006, 01:26 PM   #2
albertBeach
LQ Newbie
 
Registered: May 2006
Location: Australia
Distribution: Fedora Core 7,9,12 CentOs 5
Posts: 26

Original Poster
Rep: Reputation: 15
Hi, Just replying to my own post..
I have downloaded Audacity 1.3 beta and compiled it against wxWidgets-2.6
which I had previously compiled for an earlier version of Audacity src
and it seems to work well..so far.
I recommend to try this if you are having troubles..like I was and getting nowhere quick.
Albert
 
  


Reply

Tags
audacity, config


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Audacity: gtk-config problem. Chuong Linux - Software 5 09-24-2006 07:13 AM
Suse 9.3 yast2 hangs saving boot config or edit config deh6 Suse/Novell 0 07-16-2006 03:43 PM
REDHAT 6.2 config / modules : usb storage, wired network, x config audan Linux - Hardware 2 02-18-2006 05:23 PM
Webmin cannot handle Samba config files that use the config or include directives allelopath Linux - Networking 3 01-18-2005 09:36 AM
Upgraded to Kernel ver. 2.6.1 and the config.in file is missing massai Debian 4 01-28-2004 12:50 PM


All times are GMT -5. The time now is 01:43 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration