LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-25-2003, 11:49 AM   #1
JesusAddict3791
LQ Newbie
 
Registered: Jul 2003
Location: Laurel, MD
Distribution: Red Hat 9
Posts: 13

Rep: Reputation: 0
ATK and Pango for GAIM


I barely know anything about linux, but I'm trying to install GAIM. In order to do that I need to have GTK which itself needs GLIB, ATK, and Pango installed. I got GLIB installed fine but I can't get the others to install. When I try to ./configure ATK it tells me:

checking for GLIB - version >= 2.0.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error:
*** GLIB 2.0.0 or better is required. The latest version of
*** GLIB is always available from <linuxquestions complained about this url>

I don't understand this since I just installed the latest version of GLIB. I tried to ./configure Pango and it said:

checking for fontconfig >= 1.0.1... Package fontconfig was not found in the pkg-config search path.
Perhaps you should add the directory containing `fontconfig.pc'
to the PKG_CONFIG_PATH environment variable
No package 'fontconfig' found
configure: WARNING: No fontconfig found, skipping tests for FreeType and Xft
configure: error: *** Didn't find any of FreeType, X11, or Win32.
*** Must have at least one backend to build Pango.

Does anyone know what's going on?
 
Old 10-25-2003, 11:51 AM   #2
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
try installing all that stuff in /usr
with configure --prefix=/usr
do that with glib and gtk.
 
Old 10-25-2003, 12:19 PM   #3
JesusAddict3791
LQ Newbie
 
Registered: Jul 2003
Location: Laurel, MD
Distribution: Red Hat 9
Posts: 13

Original Poster
Rep: Reputation: 0
Thanks whansard, I got glib and atk to install, but pango is still giving me the same error. Is it telling me that there's another requirement to install pango?
 
Old 10-25-2003, 01:01 PM   #4
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
i meant you should also configure pango the same as the glib and gtk.
i just didn't say it right. all the stuff that needs that glib and gtk should
be configured the same with the --prefix=/usr
 
Old 10-25-2003, 01:09 PM   #5
JesusAddict3791
LQ Newbie
 
Registered: Jul 2003
Location: Laurel, MD
Distribution: Red Hat 9
Posts: 13

Original Poster
Rep: Reputation: 0
nope, still not working. even when i do it with --prefix=/usr it still gives me the same error.
 
Old 10-26-2003, 12:01 AM   #6
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
did you install the fontconfig thing it was complaining about.
pango is a font type app i think.


4 pango-devanagari-x.la 4 pango-hebrew-x.la
1 .. 12 pango-devanagari-x.so 16 pango-hebrew-x.so
4 pango-arabic-x.la 4 pango-gujarati-x.la 4 pango-myanmar-x.la
28 pango-arabic-x.so 12 pango-gujarati-x.so 12 pango-myanmar-x.so
4 pango-basic-x.la 4 pango-gurmukhi-x.la 4 pango-tamil-x.la
84 pango-basic-x.so 12 pango-gurmukhi-x.so 12 pango-tamil-x.so
4 pango-bengali-x.la 4 pango-hangul-x.la 4 pango-thai-x.la
12 pango-bengali-x.so 28 pango-hangul-x.so 16 pango-thai-x.so


pango has a few libraries and some modules like what i just posted.
that fontconfig is needed to set that stuff up for pango. if that's the
error message you're talking about.
 
Old 10-27-2003, 08:57 PM   #7
JesusAddict3791
LQ Newbie
 
Registered: Jul 2003
Location: Laurel, MD
Distribution: Red Hat 9
Posts: 13

Original Poster
Rep: Reputation: 0
No, I haven't installed it. Where can I get it?
 
Old 11-24-2003, 10:53 AM   #8
SentinelT
LQ Newbie
 
Registered: Oct 2003
Location: Northam, Western Australia
Distribution: Mandrake 10, Suse 9.1, Dynebolic, Demudi, Gentoo
Posts: 24

Rep: Reputation: 15
Thanks whansard
the --prefix=/usr fixed my problem of pango not seeing glib on configure even though glib already installed.

now I can get on with installing new Gimp version

Cheers
Wayne
 
Old 11-24-2003, 11:08 AM   #9
whansard
Senior Member
 
Registered: Dec 2002
Location: Mosquitoville
Distribution: RH 6.2, Gen2, Knoppix,arch, bodhi, studio, suse, mint
Posts: 3,185

Rep: Reputation: 52
thanks. i needed that today.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing GFTP...and gtk, atk, pango... hongman Linux - Software 19 02-20-2005 04:02 PM
Been fighting gtk,glib,atk,pango for days. whansard Linux - Software 0 12-18-2004 11:18 AM
Pango and ATK not linking to correct Glib 70k51k Linux - Software 3 04-05-2004 01:06 AM
Pb installing glib, atk, pango, gtk giill Linux - Software 8 11-23-2003 02:25 PM
installing GTK+2.2.0 (issues with atk-1.2.0 & pango-1.2.0) jlewis_linux Linux - Software 6 06-10-2003 01:21 PM


All times are GMT -5. The time now is 07:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration