LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-30-2009, 12:22 PM   #1
soundpete
LQ Newbie
 
Registered: Jun 2009
Posts: 11

Rep: Reputation: 0
Ati radeon 9600 drivers dont work for 9.04 ubuntu


WHY ARE THE ATI RADEON 9600 DRIVERS NOT WORKING FOR VERSION 9.04, WHEN i KNOW THEY WHERE WORKING FINE FOR THE PREVIOUS VERSION!

CAN SOME ONE TELL ME OR FIX IT SO I CAN USE THEM

THANKS
 
Old 06-30-2009, 01:01 PM   #2
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,952

Rep: Reputation: Disabled
1. Please don't shout. It's not very polite.
2. What drivers were/are you using? those in the ubuntu packages? those from the ATI website?
3. Can you explain what you mean by "not working"? What exactly is happening?
jdk
 
Old 07-21-2009, 10:35 AM   #3
joshuapillar
LQ Newbie
 
Registered: Jul 2009
Posts: 8

Rep: Reputation: 0
My issue too

I don't know if that other guy is going to respond back or not, but I am having an issue installing the latest ATI proprietary driver. I follow the installation directions per ATI with:

"To install the ATI Proprietary Linux driver using the Automatic option, follow these
steps:
1 Launch the Terminal Application/Window and navigate to the ATI Proprietary Linux
driver download.
2 Enter the command sh ./ati-driver-installer-9-5-x86.x86_64.run to launch the ATI
Proprietary Linux driver installer.
The ATI Proprietary Linux Driver Setup dialog box is displayed."


But I get an erro message saying:

"james@james-desktop:~$ sudo sh ./ati-driver-installer-9-5-x86.x86_64.run
[sudo] password for james:
sh: Can't open ./ati-driver-installer-9-5-x86.x86_64.run
james@james-desktop:~$ "

Of course I've tried just running the sh by itself without sudo, but same response.

My issue is that once Linux is booted up it will not recognize my second monitor. I assumed this was because I did not have the ATI driver installed. Help would be most appreciated.
 
Old 07-21-2009, 10:48 AM   #4
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,952

Rep: Reputation: Disabled
Hi Josh,
First off, Welcome to LQ!
Since you're new, let me explain that it's bad form to hijack someone else's thread (take a thread started out by someone else and change it to suit your own needs. In the future please don't do this; start your own thread.

As for your question: you need to make the ati-driver-installer-9-5-x86.x86_64.run file executable. First at a terminal type this (assuming your in the same folder as the install file)
Code:
ls -l ati-driver-installer-9-5-x86.x86_64.run
Mine looks like this.
Code:
-rwxr-xr-x 1 jdkaye jdkaye 84841550 2009-03-28 09:59 ati-driver-installer-9-3-x86.x86_64.run
Do you notice the little "x"'s towards the beginning of the line? I suspect you don't have any so the file is not executable in its current form. Do you notice the owner? That's me, jdkaye so to do anything to this file I don't need to be root or use sudo. If you are the owner of your file the same applies to you.
Just type at a terminal this command
Code:
chmod ugoa+x ati-driver-installer-9-5-x86.x86_64.run
and then try to execute it again. You must be root or use sudo to execute the file.
Cheers,
jdk

Last edited by jdkaye; 07-21-2009 at 10:51 AM.
 
Old 07-21-2009, 10:55 AM   #5
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
I think he's in the wrong directory.

Eg if the file is on your Desktop, you'll need to cd Desktop
before you do the sudo sh ./ati-driver-installer-9-5-x86.x86_64.run
Or, just give the full path to the file:
sudo sh /home/joshua/Desktop/ati-driver-installer-9-5-x86.x86_64.run

Last edited by tredegar; 07-21-2009 at 10:56 AM. Reason: sudo !
 
Old 07-21-2009, 10:55 AM   #6
sycamorex
LQ Veteran
 
Registered: Nov 2005
Location: London
Distribution: Slackware64-current
Posts: 5,600
Blog Entries: 1

Rep: Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045Reputation: 1045
Quote:
"james@james-desktop:~$ sudo sh ./ati-driver-installer-9-5-x86.x86_64.run
[sudo] password for james:
sh: Can't open ./ati-driver-installer-9-5-x86.x86_64.run
james@james-desktop:~$ "
Have you chmod'ed it?

Quote:
chmod +x ati-driver-installer......
 
Old 07-21-2009, 11:06 AM   #7
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,952

Rep: Reputation: Disabled
Quote:
Originally Posted by tredegar View Post
I think he's in the wrong directory.

Eg if the file is on your Desktop, you'll need to cd Desktop
before you do the sudo sh ./ati-driver-installer-9-5-x86.x86_64.run
Or, just give the full path to the file:
sudo sh /home/joshua/Desktop/ati-driver-installer-9-5-x86.x86_64.run
Who knows where he put it. But isn't there generally a message like "No such file or directory" when you're in the wrong folder? That's what I get on my system.
cheers,
jdk
 
Old 07-21-2009, 11:12 AM   #8
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
bash:
Code:
tred@vaio:~$ sh ./foo
sh: Can't open ./foo
tred@vaio:~$ ./foo
bash: ./foo: No such file or directory
tred@vaio:~$
 
Old 07-21-2009, 12:53 PM   #9
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,952

Rep: Reputation: Disabled
Code:
jdkaye@Attila:~$ sh ./ati-driver-installer-9-3-x86.x86_64.run
sh: ./ati-driver-installer-9-3-x86.x86_64.run: No such file or directory
jdkaye@Attila:~$ ./ati-driver-installer-9-3-x86.x86_64.run
bash: ./ati-driver-installer-9-3-x86.x86_64.run: No such file or directory
jdkaye@Attila:~$
???
jdk
 
Old 07-21-2009, 01:02 PM   #10
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
@jdkaye (and off topic, so apologies in advance)
Weird. I'm running kubuntu 8.04, bash 3.2-0ubuntu18.
To be honest, when I saw the OP's error message:
Quote:
sh: Can't open ./ati-driver-installer-9-5-x86.x86_64.run
I thought "weird, shouldn't he see "No such file or directory"? ", so I tried it myself. Hence my in post #8
Are you perhaps running some other shell?
 
Old 07-21-2009, 01:09 PM   #11
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Still off-topic...
Quote:
Are you perhaps running some other shell?
No, I am as /bin/sh -> /bin/dash
Learn something new every day

Wondering how joshuapillar is getting on ....
 
Old 07-21-2009, 01:13 PM   #12
joshuapillar
LQ Newbie
 
Registered: Jul 2009
Posts: 8

Rep: Reputation: 0
Quote:
Originally Posted by jdkaye View Post
Hi Josh,
First off, Welcome to LQ!
Since you're new, let me explain that it's bad form to hijack someone else's thread (take a thread started out by someone else and change it to suit your own needs. In the future please don't do this; start your own thread.

As for your question: you need to make the ati-driver-installer-9-5-x86.x86_64.run file executable. First at a terminal type this (assuming your in the same folder as the install file)
Code:
ls -l ati-driver-installer-9-5-x86.x86_64.run
Mine looks like this.
Code:
-rwxr-xr-x 1 jdkaye jdkaye 84841550 2009-03-28 09:59 ati-driver-installer-9-3-x86.x86_64.run
Do you notice the little "x"'s towards the beginning of the line? I suspect you don't have any so the file is not executable in its current form. Do you notice the owner? That's me, jdkaye so to do anything to this file I don't need to be root or use sudo. If you are the owner of your file the same applies to you.
Just type at a terminal this command
Code:
chmod ugoa+x ati-driver-installer-9-5-x86.x86_64.run
and then try to execute it again. You must be root or use sudo to execute the file.
Cheers,
jdk
Thanks for the clue. sorry about "hijacking".

I'm going to work on what you've suggested and then wade through the other comments as well. I definitely new to Linux, but I do know I'm running Ubuntu 9.04 pretty much out of the box, if that helps with letting you know what my shell and other configuration parameters are.

I have seen a lot of chatter about the ATI drivers not working with the latest ubuntu because of the Xorg version, but I'll be sure to report back after applying your changes.

thanks
 
Old 07-21-2009, 01:40 PM   #13
joshuapillar
LQ Newbie
 
Registered: Jul 2009
Posts: 8

Rep: Reputation: 0
No solution yet

Ok so check this out, see attachment.

I took a screen shot to be sure I'm saying this correctly.

Now I'm getting the message:

"james@james-desktop:~$ ls -l ati-driver-installer-9-6-x86.x86_64.run
ls: cannot access ati-driver-installer-9-6-x86.x86_64.run: No such file or directory"

and still

"james@james-desktop:~$ sh ./ati-driver-installer-9-6-x86.x86_64.run
sh: Can't open ./ati-driver-installer-9-6-x86.x86_64.run"

I did the screen shot so you could see that the file is indeed on my desktop.

Where to go from here?
Attached Images
File Type: jpg Screenshot.jpg (88.4 KB, 4 views)
 
Old 07-21-2009, 02:11 PM   #14
tredegar
LQ 5k Club
 
Registered: May 2003
Location: London, UK
Distribution: Debian "Jessie"
Posts: 6,036

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
The command pwd will print your working directory
I suspect it'll show /home/james
It needs to be /home/james/Desktop

You need to cd Desktop or cd desktop (linux is case sensitive) then try that command again.

Once you are there an ls should show you the ati.... file you need

It's complicated by the fact that your hostname is james-desktop
EDIT: and you need sudo at the start of the sh ./ati...

The little "~" before the "shell prompt" $ is telling you you are in "home" (probably /home/james but I am guessing here)

Last edited by tredegar; 07-21-2009 at 02:13 PM.
 
Old 07-21-2009, 02:40 PM   #15
joshuapillar
LQ Newbie
 
Registered: Jul 2009
Posts: 8

Rep: Reputation: 0
I navigated to the Desktop via "cd Desktop".

I ran ls.

I ran chmod.

I ran sudo sh...and...Success!

However...

I now get this message when trying to initialize the driver per the ATI instructions:

"james@james-desktop:~$ /usr/bin/aticonfig --initial
/usr/bin/aticonfig: No supported adapters detected"

I'll reboot and see if I'm good anyway.
 
  


Reply

Tags
ati, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI Radeon 9600 Drivers crap-at-linux-nead-help Linux - Newbie 6 04-03-2009 04:29 PM
ATI Radeon 9600 Drivers? Spreegem Suse/Novell 3 04-03-2009 04:16 PM
ATI Radeon 9600 SE and Drivers PJLadd Linux - Hardware 1 07-23-2005 01:10 PM
ATI Radeon 9600 drivers question RedRaven Fedora 11 10-24-2004 02:48 PM
[Debian (Knoppix)] ATI Radeon Mobility 9600 Proprietary Drivers? Do they work? false-hopes Linux - Laptop and Netbook 0 08-23-2004 12:19 AM


All times are GMT -5. The time now is 04:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration