LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-25-2013, 08:56 AM   #1
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,644

Rep: Reputation: Disabled
Atheros AR8152 with atl1c driver drains batteries of notebook.


I checked with "powertop". Right after booting the device consumes about 7 W (5 W when "wake up on lan" is activated). This gradually declines over the next hours(!) to about half that value and not without kicking the fan to high activity.

The driver is according to "ethtool -i eth0" the "atl1c version 1.0.1.0-NAPI". There is not even a cable in the jack. Any ideas how to reduce that comsumption to a sensible level?

Last edited by JZL240I-U; 04-26-2013 at 08:00 AM.
 
Old 04-27-2013, 10:29 AM   #2
rnturn
Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0), SuSE (10.x, 11.x, 12.2), Solaris (8-10), Tru64
Posts: 914

Rep: Reputation: 45
Quote:
Originally Posted by JZL240I-U View Post
I checked with "powertop". Right after booting the device consumes about 7 W (5 W when "wake up on lan" is activated). This gradually declines over the next hours(!) to about half that value and not without kicking the fan to high activity.
I take it that your intention is to be working "offline" when you're seeing the problem. Do you have the wireless network activated at those times? I occasionally forget to turn it off when I'm working standalone and on battery power. (And I don't mean being disconnected from any wireless network access points; I mean disabling the wireless network adapter using the keyboard or via a physical slide switch on the case.) I found that battery lifetime is only about 1/3 of what I get when I have the wireless network disabled. It doesn't seem to be anything specific to Linux, either. My old Lenovo laptop running WinXP and the wife's Toshiba running Win7 drained the batteries quite quickly when the wireless adapter was turned on.

HTH...

--
Rick
 
Old 04-29-2013, 01:07 AM   #3
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,644

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by rnturn View Post
... Do you have the wireless network activated at those times? ... (And I don't mean being disconnected from any wireless network access points; I mean disabling the wireless network adapter using the keyboard or via a physical slide switch on the case.) ...
Hi Rick, you are absolutely right, concerning wlan. But this is not about wireless, it's the ethernet chip for the cable connection which is drawing that much power without even any cable in the socket. I had the wireless already disabled, as you suggest. Thanks for answering.

Last edited by JZL240I-U; 04-29-2013 at 03:03 AM.
 
Old 04-29-2013, 11:45 AM   #4
rnturn
Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0), SuSE (10.x, 11.x, 12.2), Solaris (8-10), Tru64
Posts: 914

Rep: Reputation: 45
Quote:
Originally Posted by JZL240I-U View Post
But this is not about wireless, it's the ethernet chip for the cable connection which is drawing that much power without even any cable in the socket.
Ugh... I wonder: can you disable the network interface via the BIOS? And would that actually power down the interface or would it merely cause the system to not make the network interface visible to the OS? If that works, you'd have to remember to re-enable it next time you want to use a wired network connection. (Like I said: ugh!)

Good luck...

--
Rick
 
Old 04-30-2013, 04:14 AM   #5
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,644

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by rnturn View Post
Ugh... I wonder: can you disable the network interface via the BIOS?...
No, I can't. This is on a silly little netbook which has as net-related choices in its BIOS-options solely "network boot enable/disable" and in the sequence of the boot media one can move the hard disk to the first place and the netboot down the line. But.

I found out how to do it in software:

Code:
systemctl stop NetworkManager.service
 
{or just}
 
systemctl stop network
This brings the power consumption of eth0 down to 0 mW, while, funny enough, wlan0 still uses 333 mW. Okay, in can live with that. I'll just do that command by hand when I use the netbook away from an AC power socket. I suppose I could do it with atomatic scripts but that is not really necessary.

Thanks for your input, Rick, solved.

<edit> I just noticed: When I remove the driver for wlan0 with "rmmod ath9k" and stop the network with "systemctl stop network", both devices show 0 Watts, i.e. zero power consumption for wlan0 and eth0. Nice. </edit>

Last edited by JZL240I-U; 04-30-2013 at 04:29 AM.
 
Old 04-30-2013, 08:11 AM   #6
rnturn
Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0), SuSE (10.x, 11.x, 12.2), Solaris (8-10), Tru64
Posts: 914

Rep: Reputation: 45
Quote:
Originally Posted by JZL240I-U View Post

[snip]

I found out how to do it in software:

Code:
systemctl stop NetworkManager.service
 
{or just}
 
systemctl stop network
I suppose I could do it with atomatic scripts but that is not really necessary.
Good to hear you got the solution.

I'm lazy enough that I'd be making an icon or setting up a panel button run a script to enable/disable those devices.

Quote:
When I remove the driver for wlan0 with "rmmod ath9k" and stop the network with "systemctl stop network", both devices show 0 Watts, i.e. zero power consumption for wlan0 and eth0. Nice.
I'd find myself forgetting the syntax of the commands needed to deal with the power management which is why I'd be writing the script(s).

Hmm... I wonder if you couldn't set up or modify a power management profile to automagically disable the network when you're running on batteries.

--
Rick
 
Old 04-30-2013, 08:14 AM   #7
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,644

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by rnturn View Post
...I'd find myself forgetting the syntax of the commands needed to deal with the power management which is why I'd be writing the script(s).
I'm playing too often as administrator . Also, this is the command syntax of systemd, the new init process and more, so a good reason to dip into that.

Quote:
Originally Posted by rnturn View Post
...Hmm... I wonder if you couldn't set up or modify a power management profile to automagically disable the network when you're running on batteries.
That's where I am way out of my depths. Have you done anything like this? How?

Last edited by JZL240I-U; 04-30-2013 at 08:16 AM.
 
Old 04-30-2013, 12:56 PM   #8
rnturn
Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0), SuSE (10.x, 11.x, 12.2), Solaris (8-10), Tru64
Posts: 914

Rep: Reputation: 45
I completely understand your stance on doing things manually, especially while you're still learning about systemd. (Sun had me doing that when they changed the way services were managed on Solaris. I was tearing my hair out for a while.)

Quote:
Originally Posted by JZL240I-U View Post
Have you done anything like this?
No... so far I've only tweaked battery charge level alarm thresholds.

Quote:
How?
If I were to need something like that (on my OpenSUSE/KDE-based laptop -- YMMV), I would go into "Configure Desktop -> Power Management -> Energy Saving Settings", go to the "On Battery" tab, and click on the "Run Script" checkbox to have the system run a script that implemented the command(s) to be to run to shutdown the network service. You could also go to the "On AC Power" tab and define another script to start the network service when you go back onto AC power. You'll probably need/want to check that the service is actually up or down before changing the state. I'm rather new to the systemd utility as well and not familiar enough with it to know what it will do if you start an already-running service. I wouldn't think it'd be a problem but I'd verify that before automating any change. (Maybe checking would, at least, let you keep keep extraneous messages out of the system logs.)

HTH...

--
Rick

Last edited by rnturn; 04-30-2013 at 12:57 PM. Reason: Noted the desktop environment.
 
Old 05-02-2013, 01:10 AM   #9
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,644

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by rnturn View Post
...I would go into "Configure Desktop -> Power Management -> Energy Saving Settings", go to the "On Battery" tab, and click on the "Run Script" checkbox to have the system run a script that implemented the command(s) to be to run to shutdown the network service. You could also go to the "On AC Power" tab and define another script to start the network service when you go back onto AC power. ... not familiar enough with it to know what it will do if you start an already-running service. ...
Ahh, the power of KDE. I'll possibly be coming back to this, when things have stabilized. By my observations so far it is no problem to start a running service, the command is simply ignored. I'll verify this in a console with the exact commands to be used.

Thanks for your help and support .
 
Old 05-02-2013, 08:29 AM   #10
rnturn
Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0), SuSE (10.x, 11.x, 12.2), Solaris (8-10), Tru64
Posts: 914

Rep: Reputation: 45
Glad I was able to make a useful suggestion. (heh heh)

Totally off-topic: Have you had any problems with your systems using the Radeon chips? How's the acceleration support? (I'm thinking seriously of dumping my nVidia boards and replacing them with something Radeon-based. I've had nothing but trouble since upgrading to 12.x and haven't gotten any of my systems using nVidia boards to use the proprietary driver yet. I even rendered one system unbootable while following one supposed HOWTO. The nouveau driver is like a cancer and seems to be almost impossible to safely remove from your system. :/ )
 
Old 05-02-2013, 08:40 AM   #11
JZL240I-U
Senior Member
 
Registered: Apr 2003
Location: Germany
Distribution: openSuSE 13.1 / 12.3_64-KDE, Ubuntu 14.04, Fedora 20, Mint 17, Chakra
Posts: 3,644

Original Poster
Rep: Reputation: Disabled
No, I haven't any troubles with all three chips, but look at my signature, the ATI-chips are really low-end and none too modern.

Acceleration support ... hmm, I wouldn't know, I'm not the playing type. Give me any reasonable test and I'll try to check for you.

I'm using ATI because I have AMD driven machines. For my needs they provide the best cost / benefit ratio -- and also I like to support the underdog .
 
Old 05-02-2013, 10:10 AM   #12
rnturn
Member
 
Registered: Jan 2003
Location: Illinois (Chicago area)
Distribution: Red Hat (8.0), SuSE (10.x, 11.x, 12.2), Solaris (8-10), Tru64
Posts: 914

Rep: Reputation: 45
Quote:
Originally Posted by JZL240I-U View Post
No, I haven't any troubles with all three chips, but look at my signature, the ATI-chips are really low-end and none too modern.
I was looking at an HD4350 for one of my systems (with an AGP slot). The most advanced nVidia card I have at the moment is running a 6200 chip. (Pretty old.)

Quote:
Acceleration support ... hmm, I wouldn't know, I'm not the playing type.
I'm no hard-core gamer but I do enjoy blowing off some steam with a few of the OSS FPS games from time to time. There are some other applications that I think benefit from acceleration. (Fspot, for example, is incredibly slow under the nouveau driver. It's either the lack of acceleration or the developers did something very wrong in the version that's shipping with 12.2.)

Quote:
I'm using ATI because I have AMD driven machines. For my needs they provide the best cost / benefit ratio -- and also I like to support the underdog .
Understand. I have been thinking about moving to AMD chips for some time myself and, unfortunately, had to RMA a dual Opteron m'board a few years back due to stability problems. (Maybe later this year I can give them another try.)

Anyway... thanks for the data point.

--
Rick
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Lenovo G470: problem installing Atheros AR8152 v2 ethernet and Broadcom WIreless (RHEL6) subashd Linux - Laptop and Netbook 1 03-18-2012 09:04 AM
Lenovo G470: problem installing Atheros AR8152 v2 ethernet and Broadcom WIreless (RHEL6) subashd Linux - Laptop and Netbook 4 03-18-2012 02:56 AM
NIC Driver Atheros AR8152 mosharof9909 Linux - Laptop and Netbook 8 02-01-2011 01:08 PM
NIC Driver Atheros AR8152 mosharof9909 Linux - Laptop and Netbook 3 01-28-2011 09:05 AM


All times are GMT -5. The time now is 10:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration