LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-05-2001, 12:04 PM   #1
jane207
LQ Newbie
 
Registered: Nov 2001
Posts: 28

Rep: Reputation: 15
Ask help on installing jdk1.3 on Redhat linux7.1!


Hi,
I have downloaded j2re-1_3_1_01-linux-i386-rpm.bin. When I used "tar xvzf j2re-1_3_1_01-linux-i386-rpm.bin" to extract and install it. and it said this is not a gzip file. But I do not know how to install it. I am really new to linux, someone please help me! thanks in advance!

Jane
 
Old 11-05-2001, 12:11 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
a .bin file menas it's executable, typically self installing, just run the bugger

not sure why it's got rpm in it's name, maybe it's internally an rpm so as for easy removal.
 
Old 11-05-2001, 12:17 PM   #3
jane207
LQ Newbie
 
Registered: Nov 2001
Posts: 28

Original Poster
Rep: Reputation: 15
Thanks acid_kewpie.
But when I typed in "j2re-1_3_1_01-linux-i386-rpm.bin", it said "command not foud". What should I do? thanks.
Jane
 
Old 11-05-2001, 12:25 PM   #4
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
your current directory is never on your path

./thatprogramname
 
Old 11-05-2001, 12:34 PM   #5
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
try using gnorpm or kpackage to install it.
 
Old 11-05-2001, 12:46 PM   #6
jane207
LQ Newbie
 
Registered: Nov 2001
Posts: 28

Original Poster
Rep: Reputation: 15
Oops, "permission denied" although I am in root?

Jane
 
Old 11-05-2001, 12:53 PM   #7
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
errr not sure... i'd guess that for some reason it's not executable, check the rights with

ls -l thatprogramnameagain
if there's no x's in the rights:

chmod a+x yeahthatoneagain

maybe you can install it via gnorpm, but i'd very much doubt it. worth a go tho if you can't get that working. big companies tend to do very odd things with their programs.
 
Old 11-05-2001, 02:00 PM   #8
rshaw
Senior Member
 
Registered: Apr 2001
Location: Perry, Iowa
Distribution: Mepis , Debian
Posts: 2,692

Rep: Reputation: 45
ok, this is from sun.
chmod a+x j2re-1_3_1_<version number>-linux-i386-rpm.bin
then: ./j2re-1_3_1_<version number>-linux-i386-rpm.bin that will display the licence agreement , after that, su to root and: rpm -iv jre-1.3.1_<versionnumber>.i386.rpm

Last edited by rshaw; 11-05-2001 at 02:04 PM.
 
Old 11-05-2001, 05:16 PM   #9
jane207
LQ Newbie
 
Registered: Nov 2001
Posts: 28

Original Poster
Rep: Reputation: 15
Thanks, acid_kewpie and rshaw. All jdk fileshave been settled down. Thanks again for your help!

Jane
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Anything I need to know before installing JDK1.5.0, Eclipse, and Dr. Scheme? Erik_the_Red Linux - Software 19 11-06-2005 09:26 AM
trouble installing jdk1.5.0_02 mayasedai Linux - Newbie 8 04-29-2005 06:52 PM
RedHat Linux7.3 kay Linux - Networking 0 03-11-2003 01:17 AM
Installing redhat Linux7.0 dark_light Linux - General 3 06-19-2002 09:28 AM
Redhat 7.1 and Sun's jdk1.3_0, just won't be friends! Zpepperfly Linux - General 3 05-04-2001 12:50 PM


All times are GMT -5. The time now is 11:14 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration