LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-22-2004, 06:30 AM   #1
cgoerner
Member
 
Registered: Apr 2004
Location: South Australia
Distribution: Ubuntu & Debian Sarge
Posts: 32

Rep: Reputation: 15
APT Repositories for GRASS GIS?


I'm using Synaptic on Fedora Core 2 and I want to install GRASS GIS without manually downloading the required dependencies. Are there repositories for this?
Is there an easy way to do this or do I have to do it that hard way?

Chris
 
Old 06-22-2004, 07:18 AM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Looking at the download page, the binaries are in rpm format. What happens if you download and run the rpm file? Assuming you don't already have the dependencies, why not just install them via Synaptic/apt and the run the rpm file?

Moved: This thread is more suitable in Linux-Software and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 06-22-2004, 07:55 AM   #3
cgoerner
Member
 
Registered: Apr 2004
Location: South Australia
Distribution: Ubuntu & Debian Sarge
Posts: 32

Original Poster
Rep: Reputation: 15
I gave that a go but running the rpm gives this output:
Code:
error: Failed dependencies:
gdal >= 1.1.9 is needed by grass-5.7.0-1
tk >= 8 is needed by grass-5.7.0-1
proj >= 4.4.7 is needed by grass-5.7.0-1
libcom_err.so.3 is needed by grass-5.7.0-1
libcrypto.so.1 is needed by grass-5.7.0-1
libdfftw.so.2 is needed by grass-5.7.0-1
libgdal.so.1 is needed by grass-5.7.0-1
libproj.so.0 is needed by grass-5.7.0-1
libssl.so.1 is needed by grass-5.7.0-1
libstdc++-libc6.2-2.so.3 is needed by grass-5.7.0-1
libtcl.so.0 is needed by grass-5.7.0-1
libtk.so.0 is needed by grass-5.7.0-1
I assume I need to install the following rpms but they're not listed in any of my installed apt repositories. I looked on rpmfind.net but there aren't any for fedora. I assume I can't install the mandrake ones.

Quote:
The following libraries are required:

* libpq (e.g. libpq3-7.3.4-2mdk.i586.rpm)
* proj (e.g. proj-4.4.7-1mdk.i586.rpm)
* libproj (e.g. libproj0-4.4.7-1mdk.i586.rpm)
* libgdal(e.g. libgdal0-1.1.9-2mdk.i586.rpm)

and, recommended, also:

* tcl (e.g. tcl-8.3.3-21mdk.i586.rpm)
* tk (e.g. tk-8.3.3-21mdk.i586.rpm)
* gdal tools (e.g. gdal-1.1.9-2mdk.i586.rpm)
* libfftw (must be fft2, e.g. libfftw2-2.1.5-2mdk.i586.rpm)
* libgrass (e.g. libgrass5-1.0.0-1mdk.src.rpm - but only if inserted in one of above packages as dependency)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apt repositories????? BuffloTrace Mandriva 1 05-06-2004 12:09 AM
good apt repositories for RH 7.2? Sephiroth Linux - Software 4 02-13-2004 12:46 PM
the best apt repositories bosewicht Linux - Newbie 1 10-07-2003 01:23 PM
CL apt-get repositories? alsosa Conectiva 4 09-15-2003 09:47 AM
APT-Get Repositories For Mandrake Igman Linux - Software 1 08-18-2003 12:57 AM


All times are GMT -5. The time now is 11:42 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration