LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 12-15-2003, 01:20 PM   #1
salvatore
Member
 
Registered: Oct 2003
Location: Florida
Distribution: Fedora Core 1 and 3
Posts: 68

Rep: Reputation: 15
Post Apt on RH9 Failing


Im using apt on RH9 to perform a dist-upgrade, but Im getting the following errors:

***
[root@home rpm]# apt-get dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
Calculating Upgrade... Done
The following packages will be upgraded
docbook-dtds docbook-style-dsssl docbook-style-xsl docbook-utils
docbook-utils-pdf ethereal-gnome glibc-debug glibc-devel glibc-utils
gnome-utils gnumeric lftp libexif lirc lzo nptl-devel openjade opensp
perl-XML-Parser sgml-common xml-common
The following packages will be REPLACED:
gpgme0315 (by gpgme0316)
The following NEW packages will be installed:
ethereal#0.9.16-0.90.1 glibc#2.3.2-27.9.7 glibc-common#2.3.2-27.9.7
gpgme0316 libgal2 libgcrypt libksba lirc-lib newpg pinentry
The following packages have been kept back
control-center gdm gnome-spell
21 upgraded, 10 newly installed, 1 replaced, 0 removed and 3 not upgraded.
Need to get 0B/78.2MB of archives.
After unpacking 76.9MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
libbonobo >= 2.4.2 is needed by gnumeric-1.2.2-1
E: Transaction set check failed
[root@home rpm]#
***

If I do an apt-get install libbonobo, it says libbonobo is already at the highest version (2.4.0).
A google search says libbonobo is at 2.5.1 (http://rpm.pbone.net/index.php3/stat....i386.rpm.html), do I just need better apt repositories to reflect the recent versions? If so, which ones?


I havent been able to use apt to install/upgrade/or dist-upgrade anything for quite some time now, as Im running into all sorts of dependency problems. Will more recent repositories correct this? If I find one with highest-versions out there, will it do me any good?
At what point am I screwed?

Thanks.
 
Old 12-15-2003, 05:24 PM   #2
mmcgille
LQ Newbie
 
Registered: Aug 2003
Posts: 5

Rep: Reputation: 0
Yep, the repositories you are using don't have the latest libbonobo. You can always try to download and install the latest (your error message is telling you that it needs 2.4.2 or greater: "libbonobo >= 2.4.2")

Try installing 2.4.2, then run apt-get again.

It's pretty common to not have the most current versions in repository. Annoying, but easily overcome.

Matt
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
eth1 failing on boot, IEEE firewire card driver failing, help jackuss_169 Linux - Laptop and Netbook 5 03-05-2005 08:34 AM
apt-get failing to retrieve KDE Beeyah Debian 4 02-01-2004 06:42 PM
rh9 xd2 apt apt-get problem fix and solution transeunt Red Hat 0 12-16-2003 11:54 PM
apt-get failing mindcry Linux - Software 1 09-11-2003 09:23 PM
LILO install failing, Boot failing, but Installation fine. sramelyk Slackware 9 08-23-2003 03:37 PM


All times are GMT -5. The time now is 01:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration