Im using apt on RH9 to perform a dist-upgrade, but Im getting the following errors:
[root@home rpm]# apt-get dist-upgrade
Reading Package Lists... Done
Building Dependency Tree... Done
Calculating Upgrade... Done
The following packages will be upgraded
docbook-dtds docbook-style-dsssl docbook-style-xsl docbook-utils
docbook-utils-pdf ethereal-gnome glibc-debug glibc-devel glibc-utils
gnome-utils gnumeric lftp libexif lirc lzo nptl-devel openjade opensp
perl-XML-Parser sgml-common xml-common
The following packages will be REPLACED:
gpgme0315 (by gpgme0316)
The following NEW packages will be installed:
ethereal#0.9.16-0.90.1 glibc#2.3.2-27.9.7 glibc-common#2.3.2-27.9.7
gpgme0316 libgal2 libgcrypt libksba lirc-lib newpg pinentry
The following packages have been kept back
control-center gdm gnome-spell
21 upgraded, 10 newly installed, 1 replaced, 0 removed and 3 not upgraded.
Need to get 0B/78.2MB of archives.
After unpacking 76.9MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
libbonobo >= 2.4.2 is needed by gnumeric-1.2.2-1
E: Transaction set check failed
If I do an apt-get install libbonobo, it says libbonobo is already at the highest version (2.4.0).
A google search says libbonobo is at 2.5.1 (http://rpm.pbone.net/index.php3/stat....i386.rpm.html
), do I just need better apt repositories to reflect the recent versions? If so, which ones?
I havent been able to use apt to install/upgrade/or dist-upgrade anything for quite some time now, as Im running into all sorts of dependency problems. Will more recent repositories correct this? If I find one with highest-versions out there, will it do me any good?
At what point am I screwed?