Linux - SoftwareThis forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.
Welcome to LinuxQuestions.org, a friendly and active Linux Community.
You are currently viewing LQ as a guest. By joining our community you will have the ability to post topics, receive our newsletter, use the advanced search, subscribe to threads and access many other special features. Registration is quick, simple and absolutely free. Join our community today!
Note that registered members see fewer ads, and ContentLink is completely disabled once you log in.
If you have any problems with the registration process or your account login, please contact us. If you need to reset your password, click here.
Having a problem logging in? Please visit this page to clear all LQ-related cookies.
Introduction to Linux - A Hands on Guide
This guide was created as an overview of the Linux Operating System, geared toward new users as an exploration tour and getting started guide, with exercises at the end of each chapter.
For more advanced trainees it can be a desktop reference, and a collection of the base knowledge needed to proceed with system and network administration. This book contains many real life examples derived from the author's experience as a Linux system and network administrator, trainer and consultant. They hope these examples will help you to get a better understanding of the Linux system and that you feel encouraged to try out things on your own.
Click Here to receive this Complete Guide absolutely free.
I am using Debian and I occasionally open synaptic and upgrade everything. The last time I did, it kinda FUBAR'd things. In any case, when I open synaptic it says there is a broken package. If I try to fix it, it wants to remove apt and 422 non-essential packages. If I try to install anything with apt-get it stated that:
libstdc++6: Depends: gcc-4.0-base (= 4.0.2-3) but 4.0.2-2 is installed
So I went and downloaded the .deb package for gcc-4.0-base 4.0.2-4 and figured I'd try to install aptitude and now it says:
Reading package lists... Done
Building dependency tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
aptitude: Depends: libapt-pkg-libc6.3-5-3.3 but it is not installable
Depends: libsigc++-1.2-5c102 but it is not installable
cpp-4.0: Depends: gcc-4.0-base (= 4.0.2-2) but 4.0.2-4 is installed
g++-4.0: Depends: gcc-4.0-base (= 4.0.2-2) but 4.0.2-4 is installed
gcc-4.0: Depends: gcc-4.0-base (= 4.0.2-2) but 4.0.2-4 is installed
libstdc++6: Depends: gcc-4.0-base (= 4.0.2-3) but 4.0.2-4 is installed
libstdc++6-4.0-dev: Depends: gcc-4.0-base (= 4.0.2-2) but 4.0.2-4 is installed
E: Unmet dependencies. Try using -f.
I should have mentioned that I ran that command before and it listed off all of the stuff it would remove, including apt which it says is essential. Then it says something like you should not do this unless you know exactly what you are doing. If you want to continue type something to the effect of "Yes, I am sure!"
Since I don't know exactly what I'm doing I thought I should probably cancel. Are you saying I should go ahead with it anyway?
Thanks for the post, but it confused the Hell out of me. If it is just the newer versions of libstdc++6 that are causing problems? Could I download an older one and upgrade other stuff? Since I ran the synaptic upgrade it has pretty much crippled my machine. For sure the sound no longer works and k3b no longer works. There are probably a bunch of other things that aren't working that I haven't discovered yet. Is there anything I can do to temporarily fix that until they solve their libstdc++6 woes? Thanks.
Thanks for the post. I just now had time to try it out. First,
doesn't exist on my computer.
I went ahead and did the dist-upgrade anyway and it seemed to go ok, except apt-get spits out a message of broken packages all the time now. I went in to synaptic and filtered for the broken packages but it said there aren't any. I'm trying to get k3b up and running again, but when I try to install it in synaptic I get:
Depends: k3blibs but it is not going to be installed
Depends: kdelibs4c2a (>=4:3.4.3-1) but it is not installable
Depends: libmusicbrainz4c2a (>=2.1.1) but it is not installable
similar errors when installing with apt. I'm feeling kind of exasperated with the whole situation and I'm thinking about just taking everything back to Windows, because I don't have the time to reinstall all of this and I don't think I will ever resolve these problems.
I will try to look into that. I am also having kernel issues. I cannot seem to get my sound to work. Do you know if there are any fully compatible kernels available, or at least config files, where everything modular and I wouldn't have to customize?
Mine worked fine at the start (over a year ago), but I've updated the kernel several times since then. Hell, I can't even get gdm to load under the old kernels now, so I'm kind of stuck where I'm at. Why does it have to be so complicated?