LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 02-05-2012, 04:29 PM   #1
javascriptninja
Member
 
Registered: Jan 2012
Posts: 41

Rep: Reputation: Disabled
apt-get is useless now because of unmet dependencies


Whenever I try to use apt-get to install something I always get this error.

You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
libimobiledevice-utils : Depends: libimobiledevice1 (>= 1.0.2) but 1.0.1-1ubuntu0.1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I already did 'apt-get -f install' but it doesn't fix anything. Here is the output.

Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
liblash2 ipheth-dkms krossruby latex-xft-fonts libmodplug0c2 libcvaux4
libmpich2-dev libxcb-render-util0-dev libboost-program-options1.40.0
banshee-extensions-common libboost-date-time1.40.0 librpmio0 librpm0
xubuntu-plymouth-theme libmagick++2 libdirectfb-extra python-musicbrainz
libx264-94 python-ogg libmpich2-1.2 xubuntu-artwork libdirac-decoder0
xubuntu-wallpapers virtuoso-nepomuk python-vobject xubuntu-icon-theme
libmatroska0 libwebkit1.1-cil libao2 libwv2-4 librsvg2-2.18-cil libcv4
libmowgli1 librpmbuild0 libqtassistantclient4 install-package
python-pyvorbis libqt4-assistant libgtk2-sexy-perl kdepimlibs5 libhighgui4
libqt4-webkit chromium-browser-inspector libboost-regex1.40.0 libsox1a
libsexymm2 libvala0 libdirectfb-dev libjpeg62-dev libxmlrpc-core-c3 libebml0
libaudid3tag2 libmpcdec3 libsysfs-dev packagekit-backend-apt
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
libimobiledevice1
The following packages will be upgraded:
libimobiledevice1
1 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
1 not fully installed or removed.
Need to get 0B/47.5kB of archives.
After this operation, 32.8kB of additional disk space will be used.
Do you want to continue [Y/n]?
(Reading database ... 643522 files and directories currently installed.)
Preparing to replace libimobiledevice1 1.0.1-1ubuntu0.1 (using .../libimobiledevice1_1.0.6-1ubuntu1~maverick1_amd64.deb) ...
Unpacking replacement libimobiledevice1 ...
dpkg: error processing /var/cache/apt/archives/libimobiledevice1_1.0.6-1ubuntu1~maverick1_amd64.deb (--unpack):
trying to overwrite '/usr/share/hal/fdi/information/20thirdparty/31-apple-mobile-device.fdi', which is also in package libimobiledevice0 0.9.7-1ubuntu1.2
Processing triggers for hal ...
Regenerating hal fdi cache ...
Errors were encountered while processing:
/var/cache/apt/archives/libimobiledevice1_1.0.6-1ubuntu1~maverick1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
 
Old 02-05-2012, 04:48 PM   #2
lonesoac0
Member
 
Registered: Jan 2010
Distribution: Ubuntu
Posts: 88

Rep: Reputation: 4
Have you recently tried downloading and installing an independent package with dpkg -i? I recently tried to install a google earth deb that was going for different repositories than my Debian OS was on. I think it was looking for Lenny and I was on Squeeze. If you did try to download and install an independent deb package then you need to deselect it for installation.
 
1 members found this post helpful.
Old 02-05-2012, 05:45 PM   #3
javascriptninja
Member
 
Registered: Jan 2012
Posts: 41

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by lonesoac0 View Post
Have you recently tried downloading and installing an independent package with dpkg -i? I recently tried to install a google earth deb that was going for different repositories than my Debian OS was on. I think it was looking for Lenny and I was on Squeeze. If you did try to download and install an independent deb package then you need to deselect it for installation.
Is deselecting a package the same thing as removing it? How do I do that?
 
Old 02-05-2012, 06:47 PM   #4
lonesoac0
Member
 
Registered: Jan 2010
Distribution: Ubuntu
Posts: 88

Rep: Reputation: 4
Deselecting and removing are different. Deselecting is when a package is not installed yet where as, removing is when a package is installed and it is uninstalled. Go into the aptitude application itself and I am pretty sure that you can some how view your selected packages to be installed. It has been a minute since I have played with the GUI aptitude app. If all else fails you can check out the man pages with the command of:
Code:
man aptitude
I KNOW that there is a command option to view selected packages.
 
Old 02-05-2012, 10:25 PM   #5
evo2
Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Debian, SL
Posts: 5,110

Rep: Reputation: 1102Reputation: 1102Reputation: 1102Reputation: 1102Reputation: 1102Reputation: 1102Reputation: 1102Reputation: 1102Reputation: 1102
Hi,

looks like shoddy packaging. It seems that although both libimobiledevice0 and libimobiledevice1 provide the same file, the pacakges do not conflict. Are both of these from actual Ubuntu repositories or are they from some third party?

Anyway, you should be able to sort this out by removing libimobiledevice0.

Eg.
Code:
apt-get remove --purge libimobiledevice0
or
Code:
dpkg purge libimobiledevice0
HTH,

Evo2.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get has unmet dependencies, but apt-get -f install doesn't solve problem sophanox Linux - Software 1 02-23-2011 10:07 AM
unmet dependencies on apt-get datchie Linux - Newbie 2 11-18-2009 03:07 AM
apt-get unmet dependencies, etc. knappster Linux - Software 13 12-14-2005 10:06 PM
apt-get unmet dependencies jeffbarish Debian 9 10-27-2005 12:19 AM
apt-get & unmet dependencies! beecee Debian 1 01-09-2004 07:44 AM


All times are GMT -5. The time now is 04:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration