LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 11-18-2007, 05:39 PM   #1
tengun
LQ Newbie
 
Registered: Sep 2007
Distribution: Linspire
Posts: 8

Rep: Reputation: 0
"apt-get install" gives me a really long error list when I try to install xsane


Before this, I tried to install xsane by downloading the .deb installer package and issuing "dpkg -i xsane_0.99+0.991-2_i386.deb", and bash gave this output:

Quote:
Selecting previously deselected package xsane.
(Reading database ... 85703 files and directories currently installed.)
Unpacking xsane (from xsane_0.99+0.991-2_i386.deb) ...
dpkg: dependency problems prevent configuration of xsane:
xsane depends on xsane-common (= 0.99+0.991-2); however:
Package xsane-common is not installed.
xsane depends on libatk1.0-0 (>= 1.12.2); however:
Version of libatk1.0-0 on system is 1.9.1-0ubuntu1.0.0.50.linspire0.1.
xsane depends on libcairo2 (>= 1.2.4); however:
Package libcairo2 is not installed.
xsane depends on libfontconfig1 (>= 2.4.0); however:
Version of libfontconfig1 on system is 2.3.2-1.0.0.50.linspire0.4.
xsane depends on libgimp2.0 (>= 2.2.0+rel); however:
Package libgimp2.0 is not installed.
xsane depends on libglib2.0-0 (>= 2.12.0); however:
Version of libglib2.0-0 on system is 2.6.3-1.0.0.50.linspire0.2.
xsane depends on libgtk2.0-0 (>= 2.8.0); however:
Version of libgtk2.0-0 on system is 2.4.13-1.0.0.50.linspire0.5.0.0.m10.1.
xsane depends on libieee1284-3; however:
Package libieee1284-3 is not installed.
xsane depends on libpango1.0-0 (>= 1.14.8); however:
Version of libpango1.0-0 on system is 1.8.2-1.0.0.50.linspire0.3.
xsane depends on libpng12-0 (>= 1.2.13-4); however:
Version of libpng12-0 on system is 1.2.8rel-1.
xsane depends on libsane (>= 1.0.11-3); however:
Package libsane is not installed.
xsane depends on libusb-0.1-4 (>= 2:0.1.12); however:
Version of libusb-0.1-4 on system is 1:0.1.8-17.
xsane depends on libxfixes3 (>= 1:4.0.1); however:
Package libxfixes3 is not installed.
xsane depends on libxinerama1; however:
Package libxinerama1 is not installed.
dpkg: error processing xsane (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
xsane

That's a long list of libraries, and I'd read somewhere that apt-get tries to resolve dependencies, so I uncommented the lines in the /etc/apt/sources.list file to get apt-get working.

Anyhow, when I issued "apt-get install xsane", bash gave me this output:

Quote:
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
libc6-dev: Depends: libc6 (= 2.3.2.ds1-19) but 2.3.6.ds1-13etch2 is to beinstalled or
libc6 (<= 2.3.2.ds1-19.0.0.50.0.0.0.0.m999) but 2.3.6.ds1-13etch2 is to be installed
locales: Depends: glibc-2.3.2.ds1-19 but it is not installable
sane: Depends: libatk1.0-0 (>= 1.12.2) but 1.9.1-0ubuntu1.0.0.50.linspire0.1 is to be installed
Depends: libcairo2 (>= 1.2.4) but it is not going to be installed
Depends: libfontconfig1 (>= 2.4.0) but 2.3.2-1.0.0.50.linspire0.4 is to be installed
Depends: libgimp2.0 (>= 2.2.0+rel) but it is not going to be installed
Depends: libglib2.0-0 (>= 2.12.0) but 2.6.3-1.0.0.50.linspire0.2 isto be installed
Depends: libgtk2.0-0 (>= 2.8.0) but 2.4.13-1.0.0.50.linspire0.5.0.0.m10.1 is to be installed
Depends: libieee1284-3 but it is not going to be installed
Depends: libpango1.0-0 (>= 1.14.8) but 1.8.2-1.0.0.50.linspire0.3 is to be installed
Depends: libsane (>= 1.0.11-3) but it is not going to be installed
Depends: libusb-0.1-4 (>= 2:0.1.12) but 1:0.1.8-17 is to be installed
Depends: libxfixes3 (>= 1:4.0.1) but it is not going to be installed
Depends: libxinerama1 but it is not going to be installed
xsane: Depends: xsane-common (= 0.99+0.991-6) but it is not going to be installed
Depends: libatk1.0-0 (>= 1.13.2) but 1.9.1-0ubuntu1.0.0.50.linspire0.1 is to be installed
Depends: libc6 (>= 2.6-1) but 2.3.6.ds1-13etch2 is to be installed
Depends: libcairo2 (>= 1.4.0) but it is not going to be installed
Depends: libfontconfig1 (>= 2.4.0) but 2.3.2-1.0.0.50.linspire0.4 is to be installed
Depends: libgimp2.0 (>= 2.4.0~rc1) but it is not going to be installed
Depends: libglib2.0-0 (>= 2.14.0) but 2.6.3-1.0.0.50.linspire0.2 is to be installed
Depends: libgtk2.0-0 (>= 2.10.12-3) but 2.4.13-1.0.0.50.linspire0.5.0.0.m10.1 is to be installed
Depends: libieee1284-3 but it is not going to be installed
Depends: libpango1.0-0 (>= 1.16.5) but 1.8.2-1.0.0.50.linspire0.3 is to be installed
Depends: libpng12-0 (>= 1.2.13-4) but 1.2.8rel-1 is to be installed
Depends: libsane (>= 1.0.11-3) but it is not going to be installed
Depends: libusb-0.1-4 (>= 2:0.1.12) but 1:0.1.8-17 is to be installed
Depends: libxfixes3 (>= 1:4.0.1) but it is not going to be installed
Depends: libxinerama1 but it is not going to be installed
Depends: libxrandr2 (>= 2:1.2.0) but 6.8.1-0.4.1.50.linspire0.2 isto be installed
Depends: zlib1g (>= 1:1.2.3.3.dfsg-1) but 1:1.2.2-3.0.0.50.0.0.0.0.m1 is to be installed
W: Couldn't stat source package list ftp://non-us.debian.org sid/non-US/main Packages (/var/lib/apt/lists/non-us.debian.org_debian-non-US_dists_sid_non-US_main_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list ftp://non-us.debian.org sid/non-US/contrib Packages (/var/lib/apt/lists/non-us.debian.org_debian-non-US_dists_sid_non-US_contrib_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list ftp://non-us.debian.org sid/non-US/non-free Packages (/var/lib/apt/lists/non-us.debian.org_debian-non-US_dists_sid_non-US_non-free_binary-i386_Packages) - stat (2 No such file or directory)
W: You may want to run apt-get update to correct these problems
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
So, as bash suggested, I issued "apt-get -f install", and then:

Quote:
Reading Package Lists... Done
Building Dependency Tree... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
libc6-dev: Depends: libc6 (= 2.3.2.ds1-19) but 2.3.6.ds1-13etch2 is installed or
libc6 (<= 2.3.2.ds1-19.0.0.50.0.0.0.0.m999) but 2.3.6.ds1-13etch2 is installed
locales: Depends: glibc-2.3.2.ds1-19 but it is not installable
sane: Depends: libatk1.0-0 (>= 1.12.2) but 1.9.1-0ubuntu1.0.0.50.linspire0.1 is installed
Depends: libcairo2 (>= 1.2.4) but it is not installed
Depends: libfontconfig1 (>= 2.4.0) but 2.3.2-1.0.0.50.linspire0.4 is installed
Depends: libgimp2.0 (>= 2.2.0+rel) but it is not installed
Depends: libglib2.0-0 (>= 2.12.0) but 2.6.3-1.0.0.50.linspire0.2 isinstalled
Depends: libgtk2.0-0 (>= 2.8.0) but 2.4.13-1.0.0.50.linspire0.5.0.0.m10.1 is installed
Depends: libieee1284-3 but it is not installed
Depends: libpango1.0-0 (>= 1.14.8) but 1.8.2-1.0.0.50.linspire0.3 is installed
Depends: libsane (>= 1.0.11-3) but it is not installed
Depends: libusb-0.1-4 (>= 2:0.1.12) but 1:0.1.8-17 is installed
Depends: libxfixes3 (>= 1:4.0.1) but it is not installed
Depends: libxinerama1 but it is not installed
W: Couldn't stat source package list ftp://non-us.debian.org sid/non-US/main Packages (/var/lib/apt/lists/non-us.debian.org_debian-non-US_dists_sid_non-US_main_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list ftp://non-us.debian.org sid/non-US/contrib Packages (/var/lib/apt/lists/non-us.debian.org_debian-non-US_dists_sid_non-US_contrib_binary-i386_Packages) - stat (2 No such file or directory)
W: Couldn't stat source package list ftp://non-us.debian.org sid/non-US/non-free Packages (/var/lib/apt/lists/non-us.debian.org_debian-non-US_dists_sid_non-US_non-free_binary-i386_Packages) - stat (2 No such file or directory)
W: You may want to run apt-get update to correct these problems
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

How do I correct these dependency problems other than manually looking for and installing the correct versions of all these packages? I do know that I have a debian-based system.
 
Old 11-18-2007, 05:54 PM   #2
ultramancool
Member
 
Registered: Jul 2004
Location: Hell
Distribution: Gentoo 2005.1 r1
Posts: 92

Rep: Reputation: 15
It seems you're trying to mix packages from debian, ubuntu and linspire. Bad idea. Don't do it. Stick to 1 distro, not 3, it won't work, you'll end up with broken binaries and dependency problems like this.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"Dynamic MMap ran out of room" error when adding new apt source list hasanito Debian 25 05-27-2013 04:56 AM
Zip gives error "-bash: /usr/bin/zip: Argument list too long" konathamsrinu Programming 3 07-06-2006 11:08 AM
FC4 install errors, "diabling IRQ #10" "nobody cares" error message??? A6Quattro Fedora 6 07-20-2005 01:49 PM
how to install the "packages that have been held back" when doing "apt-get upgrade&qu zero79 Debian 5 06-27-2004 09:19 PM
Error when doing "Apt-get install apache" Verruckt Linux - Newbie 0 03-29-2002 12:53 PM


All times are GMT -5. The time now is 04:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration