LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 10-27-2008, 02:23 PM   #1
bucovaina78
Member
 
Registered: Oct 2004
Location: Belgium / Antwerp
Distribution: Debian,Ubuntu,Finnix,LFS
Posts: 282

Rep: Reputation: 33
apt-get install build-essentials // doesn't work on debian Lenny


I want to install build-essential with apt-get but I get an error message

sorry for the dutch language but I tried to make it as clear as possible, look for bold italic and underline text for translation
1st line is "package list being read"
2nd line "tree of requiries being built"
3rd line "status information being read"
"Let op" = warning, be carefull, caution ...
"wordt geselecteerd omwille van de" is "is selected because of"
I hope that regex is the same in English, no translation for that

Quote:
Pakketlijsten worden ingelezen...
Boom van vereisten wordt opgebouwd...
De status informatie wordt gelezen...
Let op, artsbuilder wordt geselecteerd omwille van de regex 'build*'
Let op, libresid-builder0 wordt geselecteerd omwille van de regex 'build*'
Let op, libresid-builder0c2a wordt geselecteerd omwille van de regex 'build*'
Let op, openoffice.org-report-builder-bin wordt geselecteerd omwille van de regex 'build*'
Let op, libmodule-build-perl wordt geselecteerd omwille van de regex 'build*'
Let op, cvs-buildpackage wordt geselecteerd omwille van de regex 'build*'
Let op, svn-buildpackage wordt geselecteerd omwille van de regex 'build*'
Let op, libextutils-cbuilder-perl wordt geselecteerd omwille van de regex 'build*'
Let op, openoffice.org-report-builder wordt geselecteerd omwille van de regex 'build*'
Let op, build-common wordt geselecteerd omwille van de regex 'build*'
Let op, linux-kbuild-2.6.24 wordt geselecteerd omwille van de regex 'build*'
Let op, pbuilder-uml wordt geselecteerd omwille van de regex 'build*'
Let op, pbuilder wordt geselecteerd omwille van de regex 'build*'
Let op, xorg-build-macros wordt geselecteerd omwille van de regex 'build*'
Let op, xutils-dev wordt geselecteerd in plaats van xorg-build-macros
Let op, build-essential wordt geselecteerd omwille van de regex 'build*'
Sommige pakketten konden niet ge´nstalleerd worden. Dit kan betekenen dat u een onmogelijke situatie gevraagd hebt of dat u de 'unstable'-distributie gebruikt en sommige benodigde pakketten nog vastzitten in 'incoming'.

Aangezien u slechts een enkele opdracht gegeven hebt is het zeer
waarschijnlijk dat het pakket gewoon niet installeerbaar is. U kunt dan
best een foutrapport indienen voor dit pakket.
De volgende informatie helpt u mogelijk verder:

De volgende pakketten hebben niet-voldane vereisten:
build-essential: Vereisten: libc6-dev maar het zal niet ge´nstalleerd worden of
libc-dev
Vereisten: gcc (>= 4:4.1.1) maar het zal niet ge´nstalleerd worden
Vereisten: g++ (>= 4:4.1.1) maar het zal niet ge´nstalleerd worden
pbuilder: Vereisten: gcc maar het zal niet ge´nstalleerd worden
Aanbevelingen: cowdancer maar het is niet installeerbaar
The underlined text after the 'let op' lines is saying that I asked for an impossible situation because I'm running unstable distribution and some required packages are stuck in "incoming".

The Italic and bigger text text is saying: required gcc ... but it wil not be instaled.
If I understand this well, those packages are needed/part of build-essential and because I'm running Debian Lenny, those packages are not in the list yet, and not installable.

What can I do? I can't imagine that it's impossible to run Debian Lenny without the ability of a compiler?
 
Old 10-27-2008, 02:44 PM   #2
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,734
Blog Entries: 12

Rep: Reputation: 457Reputation: 457Reputation: 457Reputation: 457Reputation: 457
aptitude install build-essential should work just fine.

Are you running Lenny which is testing or Sid/unstable?
 
Old 10-27-2008, 02:45 PM   #3
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Rep: Reputation: 121Reputation: 121
Here's a babelfish translation of your insert. Two words didn't translate. I used http://babelfish.yahoo.com/
Code:
parcel lists are read in… 
Tree of requirements is built… 
The status information is read… 
Pay attention to, of the is selected because of the regex ' build*' 
Pay attention to, libresid-builder0 it is selected because of the regex ' build*' 
Pay attention to, libresid-builder0c2a it is selected because of the regex ' build*' 
Pay attention to, openoffice.org - report-builder-bin are selected because of the regex ' build*' 
Pay attention to, libmodule-build-perl are selected because of the regex ' build*' 
Pay attention to, CV buildpackage are selected because of the regex ' build*' 
Pay attention to, svn-buildpackage are selected because of the regex ' build*' 
Pay attention to, libextutils-cbuilder-perl are selected because of the regex ' build*' 
Pay attention to, openoffice.org - report-builder are selected because of the regex ' build*' 
Pay attention to, build-common are selected because of the regex ' build*' 
Pay attention to, linux-kbuild-2.6.24 it is selected because of the regex ' build*' 
Pay attention to, pbuilder-uml are selected because of the regex ' build*' 
Pay attention to, pbuilder are selected because of the regex ' build*' 
Pay attention to, xorg-build-macros are selected because of the regex ' build*' 
Pay attention to, xutils-dev are selected instead of xorg-build-macros 
Pay attention to, build-essential are selected because of the regex ' build*' Some parcels could not be installed. This can mean that an impossible situation has asked you or that you ' unstable' - uses distribution and some required parcels still are stuck in ' incoming'. Since you have commissioned only a single it is very probably that the parcel is simply not installeerbaar. YOU can then best foutrapport submit for this parcel. The next information helps you possibly further: The following parcels have niet-voldane requirements: build-essential: Requirements: libc6-dev but it will not be installed or libc-dev Requirements: gcc (> = 4:4.1 .1) but it will not be installed Requirements: g++ (> = 4:4.1 .1) but it will not be installed pbuilder: Requirements: gcc but it will not be installed Recommendations: cowdancer but it is not installeerbaar
 
Old 10-27-2008, 03:05 PM   #4
bucovaina78
Member
 
Registered: Oct 2004
Location: Belgium / Antwerp
Distribution: Debian,Ubuntu,Finnix,LFS
Posts: 282

Original Poster
Rep: Reputation: 33
Quote:
Originally Posted by craigevil View Post
aptitude install build-essential should work just fine.

Are you running Lenny which is testing or Sid/unstable?
Not really sure, I think it's testing, but here's my sources.list:


#
# deb cdrom:[Debian GNU/Linux LennyBeta2 _Lenny_ - Official Beta i386 DVD Binary-1 20080607-17:21]/ lenny contrib main

deb cdrom:[Debian GNU/Linux LennyBeta2 _Lenny_ - Official Beta i386 DVD Binary-1 20080607-17:21]/ lenny contrib main

deb http://ftp.be.debian.org/debian/ lenny main
deb-src http://ftp.be.debian.org/debian/ lenny main

deb http://security.debian.org/ lenny/updates main contrib
deb-src http://security.debian.org/ lenny/updates main contrib
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
sound doesn't work on debian lenny dante_des Linux - Hardware 4 08-19-2009 10:05 AM
Where can I download the build-essentials package for RHEL 4? ShaqDiesel Red Hat 3 08-29-2008 09:22 PM
How well does KDE work with Debian Lenny? danbuter Debian 26 03-17-2008 09:44 AM
2.6.22 cpufreqd does not work, (Debian lenny) kaz2100 Linux - Kernel 1 09-20-2007 03:12 PM
Do not manage to get apt-get build-depend to work! fif Linux - Newbie 0 02-16-2005 10:38 AM


All times are GMT -5. The time now is 04:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration