LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 09-18-2004, 10:55 PM   #1
ulaoulao
Member
 
Registered: Jul 2004
Posts: 34

Rep: Reputation: 15
apt-get + broken packages = death


Ok "they" say you never have to reinstall or reboot Linux. If this is true show me how to fix this. Every time I get this error I lose my system. I love apt-get and think itís a marvelous idea!! But Iím scared to use it because of this very out come.



Example I tried to install ez-ipupdate, need less to say it didn't go well, ok so I install ddclient instead, but now my apt-get is broken?


root@spawnlinux:/etc/samba# apt-get install samba
Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these:
The following packages have unmet dependencies:
ez-ipupdate: Depends: debconf-tiny but it is not installable
freeglut3: Depends: libc6 (>= 2.3.2.ds1-4) but 2.3.1-16 is to be installed
libncurses5-dev: Depends: libncurses5 (= 5.4-4) but 5.3.20030719-1 is to be installed
samba: Depends: samba-common (= 3.0.6-3) but 2.2.3a-12.3 is to be installed
Depends: libacl1 (>= 2.2.11-1) but it is not going to be installed
Depends: libc6 (>= 2.3.2.ds1-4) but 2.3.1-16 is to be installed
Depends: libcupsys2-gnutls10 (>= 1.1.20final-1) but it is not going to be installed
Depends: libkrb53 (>= 1.3.2) but it is not going to be installed
Depends: libpam-runtime (>= 0.76-13.1) but 0.76-9 is to be installed
swat: Depends: samba (= 2.2.3a-12.3) but 3.0.6-3 is to be installed
wine-utils: Depends: wine but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
root@spawnlinux:/etc/samba# You might want to run `apt-get -f install' to correct these:
>




or




root@spawnlinux:/etc/samba# apt-get upgrade samba Reading Package Lists... Done
Building Dependency Tree... Done
You might want to run `apt-get -f install' to correct these.
The following packages have unmet dependencies:
ez-ipupdate: Depends: debconf-tiny but it is not installable
freeglut3: Depends: libc6 (>= 2.3.2.ds1-4) but 2.3.1-16 is installed
libncurses5-dev: Depends: libncurses5 (= 5.4-4) but 5.3.20030719-1 is installed
wine-utils: Depends: wine but it is not installed
E: Unmet dependencies. Try using -f.
root@spawnlinux:/etc/samba#



also I tired asking the OS:

root@spawnlinux:~# dpkg -C
The following packages have been unpacked but not yet configured.
They must be configured using dpkg --configure or the configure
menu option in dselect for them to work:
libglut3 the OpenGL Utility Toolkit
libncurses5-dev Developer's libraries and docs for ncurses
freeglut3 OpenGL Utility Toolkit
ez-ipupdate A client for most dynamic DNS services.



I tried using dselect and did the configure option and it said:


1157 packages upgraded, 225 newly installed, 15 to remove and 1 not upgraded.
4 packages not fully installed or removed.
Need to get 758MB/779MB of archives.
After unpacking 437MB of additional disk space will be used.
Do you want to continue? [Y/n]



Now I not going to install that many packages something has to be wrong.. please help!!.. I think all I need here is simple understanding.
 
Old 09-18-2004, 11:29 PM   #2
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
you are using way wrong apt sources for whatever system you have

what system (distribution) exactly is this and where did you get the apt ??
(exactly what is the full name of the apt package you installed)

you say dpkg ??? is this a debian system ??
or an apt-rpm thing
 
Old 09-19-2004, 10:55 AM   #3
ulaoulao
Member
 
Registered: Jul 2004
Posts: 34

Original Poster
Rep: Reputation: 15
This is a three day fresh install of Libranet. The only change I made was a insall of ez-ipupdate_3.0.11b5-1_i386.deb. Maybe that package did something wrong???

my apt when doig a apt-get update says:

Hit http://non-us.debian.org sarge/non-US/main Packages
Hit http://non-us.debian.org sarge/non-US/main Release
Hit http://non-us.debian.org sarge/non-US/contrib Packages
Hit http://non-us.debian.org sarge/non-US/contrib Release
Hit http://non-us.debian.org sarge/non-US/non-free Packages
Hit http://non-us.debian.org sarge/non-US/non-free Release
Hit http://libranetlinux.com updates/2.8/ Packages
Hit http://libranetlinux.com updates/2.8/ Release
Hit http://libranetlinux.com security/2.8/ Packages
Hit http://libranetlinux.com security/2.8/ Release
Hit ftp://ftp.debian.org sarge/main Packages
Hit ftp://ftp.debian.org sarge/main Release
Hit ftp://ftp.debian.org sarge/contrib Packages
Hit ftp://ftp.debian.org sarge/contrib Release
Hit ftp://ftp.debian.org sarge/non-free Packages
Hit ftp://ftp.debian.org sarge/non-free Release
Hit ftp://security.debian.org sarge/updates/main Packages
Hit ftp://security.debian.org sarge/updates/main Release
Hit ftp://security.debian.org sarge/updates/contrib Packages
Hit ftp://security.debian.org sarge/updates/contrib Release
Hit ftp://security.debian.org sarge/updates/non-free Packages
Hit ftp://security.debian.org sarge/updates/non-free Release
Hit ftp://security.debian.org stable/updates/main Packages
Hit ftp://security.debian.org stable/updates/main Release
Hit ftp://security.debian.org stable/updates/contrib Packages
Hit ftp://security.debian.org stable/updates/contrib Release
Hit ftp://security.debian.org stable/updates/non-free Packages
Hit ftp://security.debian.org stable/updates/non-free Release


from another forum I fellow says "Do what dselect has as asked you to do. It is the fastest wy to a stable system."

http://www.linuxforum.com/forums/ind...=0#entry446519


Last edited by ulaoulao; 09-19-2004 at 02:36 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Broken Packages hongman Linux - Software 2 04-13-2005 06:48 AM
apt-get is broken irvken Linux - Software 3 12-12-2004 05:18 AM
what's with all those broken packages darkleaf Debian 8 09-29-2004 02:40 PM
Broken Packages Kujila Linux - Software 2 02-01-2004 06:07 PM
apt-get is broken, please help! agentforsythe Linux - General 3 01-12-2004 04:24 AM


All times are GMT -5. The time now is 08:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration