-   Linux - Software (
-   -   APR-util with APR - configure error on Linux (

nicky77 03-10-2010 07:39 AM

APR-util with APR - configure error on Linux
I've got a strange problem when configuring APR and APR-util for use with Subversion. I have compiled APR to /usr/local/apr and now I'm trying to compile APR-util with the following configure line:

./configure --prefix=/usr/local/apr-util --with-apr=/usr/local/apr/ --with-berkeley-db=/usr/local/BerkeleyDB.4.8/

But this gives the error:

checking for APR... configure: error: the --with-apr parameter is incorrect. It must specify an install prefix, a build directory, or an apr-config file.

Doing a quick check in /usr/local/apr shows i have the following directories:

bin build-1 include lib

I've also tried directly specifying the apr-config file, e.g --with-apr=/usr/local/apr/apr-1-config, but this makes no difference.

Anyone have any ideas?

knudfl 03-10-2010 10:25 AM

APR-util looks for "apr-1-config".
cd apr-util-1.3.9/
./configure --with-apr=/usr/local/apr/bin/

___ which is the location, you have created for apr.

How do you think, subversion will ever work ?
When you place its run time libraries in multiple
non system paths ?.

And better in the first place install subversion
with : sudo apt-get install subversion .

All times are GMT -5. The time now is 02:20 AM.