LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-20-2003, 04:59 AM   #1
craddy
LQ Newbie
 
Registered: Sep 2003
Posts: 20

Rep: Reputation: 0
apc powerchute


HI,

Im having problems installing APC's Powerchute. When i try to execute it (.bin file) it says
"Exception in main class "JExpressLoader""

leaving me stumped!

all i want is for the UPS to work (had problems with apcupsd too, so i thought i wold try this).

Thanks for any help.

Richard
 
Old 11-05-2003, 09:00 PM   #2
sethen
LQ Newbie
 
Registered: Apr 2003
Location: Switzerland of Maine
Distribution: RedHat 8.0
Posts: 21

Rep: Reputation: 15
I'm having the same issue. As far as i can tell, i think you need to be running XWindows. At least thats all i can get out of their website....
 
Old 11-06-2003, 12:23 PM   #3
craddy
LQ Newbie
 
Registered: Sep 2003
Posts: 20

Original Poster
Rep: Reputation: 0
it seems crazy that it is so hard! ups's being designed for the server market-where linux has roots/is used often.

i made more progress...but the rpm found on the APC cd requires some libraries that arenít installed. I found the libraries it needs but cant install them. im not at work at the moment so im not sure what lib's it needs. anyway-any info you get would be much appreciated!

crad
 
Old 11-06-2003, 12:28 PM   #4
sethen
LQ Newbie
 
Registered: Apr 2003
Location: Switzerland of Maine
Distribution: RedHat 8.0
Posts: 21

Rep: Reputation: 15
My CD only has a BIN file on it, no RPM. I've tried finding the RPM, but to no luck.
 
Old 11-06-2003, 06:39 PM   #5
craddy
LQ Newbie
 
Registered: Sep 2003
Posts: 20

Original Poster
Rep: Reputation: 0
well, im not certain it was a rpm...pretty sure though. i will be able to check on monday, if it is i could email it to you.
 
Old 11-17-2003, 11:13 AM   #6
kc8duw
LQ Newbie
 
Registered: Nov 2003
Posts: 1

Rep: Reputation: 0
I am wondering if this was ever resolved? i am getting this error and am wondering if X is required.

Thanks

Jeff Kelley
Network Administrator
Lectronix, Inc.
 
Old 11-18-2003, 03:57 PM   #7
craddy
LQ Newbie
 
Registered: Sep 2003
Posts: 20

Original Poster
Rep: Reputation: 0
hey- not resolved as of yet. i work mondays doing admin for an local office. im quite forgetfull, so i will find out all i can next monday (reminder set on my phone )
 
Old 06-04-2004, 11:05 AM   #8
Helmet
LQ Newbie
 
Registered: Jun 2004
Location: Washington DC
Distribution: RHEL, Ubuntu
Posts: 4

Rep: Reputation: 0
Has anyone resolved this issue? I'm having exaclty the same problem as you all. How did you manage? Please help....

Thanks
 
Old 06-04-2004, 04:28 PM   #9
craddy
LQ Newbie
 
Registered: Sep 2003
Posts: 20

Original Poster
Rep: Reputation: 0
Hiya,

I'm sorry to say i haven't, although i haven't been trying! Way to much college work at the moment so all this techie stuff has to wait. Sorry mate!

crad
 
Old 06-07-2004, 08:47 AM   #10
Helmet
LQ Newbie
 
Registered: Jun 2004
Location: Washington DC
Distribution: RHEL, Ubuntu
Posts: 4

Rep: Reputation: 0
Well.... happy to say problem solved.

Downloaded the latest version and ran the rpm file, not the bin, with its "--prefix" option. Although I don't know what the problem really was, installation with the new version was seamless.

Thanks and regards
 
Old 10-12-2004, 09:23 AM   #11
lysander
LQ Newbie
 
Registered: Oct 2004
Posts: 1

Rep: Reputation: 0
I am having the same problem as you were. I have tried to install the 'bin' file with no success. All I get is a 'javaExpressLoader' error.

Could you please post the URL to where I can downlaod the latest version with the 'rmp' file.

Hopefully this will solve it.

Cheers.
 
Old 10-18-2004, 04:29 PM   #12
Helmet
LQ Newbie
 
Registered: Jun 2004
Location: Washington DC
Distribution: RHEL, Ubuntu
Posts: 4

Rep: Reputation: 0
Here's the URL: http://www.apc.com/tools/download/so...&os_list=Linux
they have a newer version now: 7.0.2 for Linux.

Hope it works for you
 
Old 02-06-2005, 11:33 AM   #13
mykhal
LQ Newbie
 
Registered: Feb 2005
Location: czech republic
Posts: 1

Rep: Reputation: 0
Talking

Hi,

pbe_agent_linux_jvm.bin is executable zip sfx archive, so you are able to extract it using "unzip" command.
Then look into jinstall.log which has been generated during the failed attempt to install for the exact command.. i have there:

"/bin/java/jre/1.4//bin/java" -Djava.util.prefs.userRoot\=/bin/jav>a/jre/1.4 -Djava.util.prefs.systemRoot\=/bin/java/jre/1.4 -DProduct.Nodes\=5 -DProduct.Type\='FREE' -DProduct.NodeLeve>l\=5 -DProduct.FeatureLevel\=BASIC -cp .:./install.jar:./m11.jar:./comm.jar:./ds.jar:./pcbe_ds.jar:./RXTXComm.jar\:./M>odifyShutdownLinux.jar load

so i pasted into shell, and it works. Unfortunately, during the installation, is turned out, that the software does not support APC Cyberfort, because it uses USB port, instead of required serial port.
 
Old 02-20-2006, 08:46 AM   #14
scs14aug
LQ Newbie
 
Registered: Nov 2005
Location: NH, USA
Posts: 1

Rep: Reputation: 0
I was having the same trouble on a Sun Netra (Solaris 9) when I was using a remote X session from another Sun box. When I used VNC to connect to the Netra (which must have simulated a X console) the whole show installed just fine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
APC UPS Smart_UPS v/s 650 MikeAtVillage Linux - Hardware 4 07-05-2005 04:08 AM
apc Back-ups 650 a10392 Linux - Software 1 12-03-2004 10:51 AM
apc Back-ups a10392 Debian 1 12-03-2004 10:24 AM
APC UPC - cannot find UPS device Parksy Linux - Hardware 13 11-27-2004 01:14 PM
APC PowerChute bad_andy Linux - Software 8 10-08-2004 03:23 AM


All times are GMT -5. The time now is 09:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration