LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-02-2006, 05:18 PM   #1
foucault
LQ Newbie
 
Registered: May 2005
Location: Athens, Greece
Distribution: Ubuntu 6.06 "Dapper Drake"
Posts: 25

Rep: Reputation: 15
Apache2 won't load index.php files


Hello everyone,
I decided to try apache2 webserver. In the root of my web directories (/var/www) resides an index.php file. Either giving http://localhost or http://localhost/index.php the main page won't load and my browser will pop up a dialog to save the file (which is a phtml file if I give http://localhost or a php file if I give http://localhost/index.php). Strangely enough this happens only with index files. I know I should edit DirectoryIndex to load up index.php and is properly set. However the server refuses to see it. Any ideas?

I am attaching my apache2.conf and httpd.conf

APACHE2.CONF
Code:
# Based upon the NCSA server configuration files originally by Rob McCool.
# Changed extensively for the Debian package by Daniel Stone <daniel@sfarc.net>
# and also by Thom May <thom@debian.org>.

# ServerRoot: The top of the directory tree under which the server's
# configuration, error, and log files are kept.
#
# NOTE!  If you intend to place this on an NFS (or otherwise network)
# mounted filesystem then please read the LockFile documentation
# (available at <URL:http://www.apache.org/docs/mod/core.html#lockfile>);
# you will save yourself a lot of trouble.

ServerRoot "/etc/apache2"

# The LockFile directive sets the path to the lockfile used when Apache
# is compiled with either USE_FCNTL_SERIALIZED_ACCEPT or
# USE_FLOCK_SERIALIZED_ACCEPT. This directive should normally be left at
# its default value. The main reason for changing it is if the logs
# directory is NFS mounted, since the lockfile MUST BE STORED ON A LOCAL
# DISK. The PID of the main server process is automatically appended to
# the filename. 

LockFile /var/lock/apache2/accept.lock

# PidFile: The file in which the server should record its process
# identification number when it starts.

PidFile /var/run/apache2.pid

# Timeout: The number of seconds before receives and sends time out.

Timeout 300

# KeepAlive: Whether or not to allow persistent connections (more than
# one request per connection). Set to "Off" to deactivate.

KeepAlive On

# MaxKeepAliveRequests: The maximum number of requests to allow
# during a persistent connection. Set to 0 to allow an unlimited amount.
# We recommend you leave this number high, for maximum performance.

MaxKeepAliveRequests 100

# KeepAliveTimeout: Number of seconds to wait for the next request from the
# same client on the same connection.

KeepAliveTimeout 15

##
## Server-Pool Size Regulation (MPM specific)
## 

# prefork MPM
# StartServers ......... number of server processes to start
# MinSpareServers ...... minimum number of server processes which are kept spare
# MaxSpareServers ...... maximum number of server processes which are kept spare
# MaxClients ........... maximum number of server processes allowed to start
# MaxRequestsPerChild .. maximum number of requests a server process serves
<IfModule prefork.c>
StartServers         5
MinSpareServers      5
MaxSpareServers     10
MaxClients          20
MaxRequestsPerChild  0
</IfModule>

# pthread MPM
# StartServers ......... initial  number of server processes to start
# MaxClients ........... maximum  number of server processes allowed to start
# MinSpareThreads ...... minimum  number of worker threads which are kept spare
# MaxSpareThreads ...... maximum  number of worker threads which are kept spare
# ThreadsPerChild ...... constant number of worker threads in each server process
# MaxRequestsPerChild .. maximum  number of requests a server process serves
<IfModule worker.c>
StartServers         2
MaxClients         150 
MinSpareThreads     25
MaxSpareThreads     75
ThreadsPerChild     25
MaxRequestsPerChild  0
</IfModule>

# perchild MPM
# NumServers ........... constant number of server processes
# StartThreads ......... initial  number of worker threads in each server process
# MinSpareThreads ...... minimum  number of worker threads which are kept spare
# MaxSpareThreads ...... maximum  number of worker threads which are kept spare
# MaxThreadsPerChild ... maximum  number of worker threads in each server process
# MaxRequestsPerChild .. maximum  number of connections per server process (then it dies)
<IfModule perchild.c>
NumServers           5
StartThreads         5
MinSpareThreads      5
MaxSpareThreads     10
MaxThreadsPerChild  20
MaxRequestsPerChild  0
AcceptMutex fcntl
</IfModule>

User www-data
Group www-data

# The following directives define some format nicknames for use with
# a CustomLog directive (see below).
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %b" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent


# Global error log.
ErrorLog /var/log/apache2/error.log

# Include module configuration:
Include /etc/apache2/mods-enabled/*.load
Include /etc/apache2/mods-enabled/*.conf

# Include all the user configurations:
Include /etc/apache2/httpd.conf

# Include ports listing
Include /etc/apache2/ports.conf

# Include generic snippets of statements
Include /etc/apache2/conf.d/[^.#]*

#Let's have some Icons, shall we?
Alias /icons/ "/usr/share/apache2/icons/"
<Directory "/usr/share/apache2/icons">
    Options Indexes MultiViews
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

# Set up the default error docs.
#
# Customizable error responses come in three flavors:
# 1) plain text 2) local redirects 3) external redirects
#
# Some examples:
#ErrorDocument 500 "The server made a boo boo."
#ErrorDocument 404 /missing.html
#ErrorDocument 404 "/cgi-bin/missing_handler.pl"
#ErrorDocument 402 http://www.example.com/subscription_info.html
#

#
# Putting this all together, we can Internationalize error responses.
#
# We use Alias to redirect any /error/HTTP_<error>.html.var response to
# our collection of by-error message multi-language collections.  We use 
# includes to substitute the appropriate text.
#
# You can modify the messages' appearance without changing any of the
# default HTTP_<error>.html.var files by adding the line;
#
#   Alias /error/include/ "/your/include/path/"
#
# which allows you to create your own set of files by starting with the
# /usr/local/apache2/error/include/ files and
# copying them to /your/include/path/, even on a per-VirtualHost basis.
#

<IfModule mod_negotiation.c>
<IfModule mod_include.c>
    Alias /error/ "/usr/share/apache2/error/"

    <Directory "/usr/share/apache2/error">
        AllowOverride None
        Options IncludesNoExec
        AddOutputFilter Includes html
        AddHandler type-map var
        Order allow,deny
        Allow from all
        LanguagePriority en es de fr
        ForceLanguagePriority Prefer Fallback
    </Directory>

    ErrorDocument 400 /error/HTTP_BAD_REQUEST.html.var
    ErrorDocument 401 /error/HTTP_UNAUTHORIZED.html.var
    ErrorDocument 403 /error/HTTP_FORBIDDEN.html.var
    ErrorDocument 404 /error/HTTP_NOT_FOUND.html.var
    ErrorDocument 405 /error/HTTP_METHOD_NOT_ALLOWED.html.var
    ErrorDocument 408 /error/HTTP_REQUEST_TIME_OUT.html.var
    ErrorDocument 410 /error/HTTP_GONE.html.var
    ErrorDocument 411 /error/HTTP_LENGTH_REQUIRED.html.var
    ErrorDocument 412 /error/HTTP_PRECONDITION_FAILED.html.var
    ErrorDocument 413 /error/HTTP_REQUEST_ENTITY_TOO_LARGE.html.var
    ErrorDocument 414 /error/HTTP_REQUEST_URI_TOO_LARGE.html.var
    ErrorDocument 415 /error/HTTP_SERVICE_UNAVAILABLE.html.var
    ErrorDocument 500 /error/HTTP_INTERNAL_SERVER_ERROR.html.var
    ErrorDocument 501 /error/HTTP_NOT_IMPLEMENTED.html.var
    ErrorDocument 502 /error/HTTP_BAD_GATEWAY.html.var
    ErrorDocument 503 /error/HTTP_SERVICE_UNAVAILABLE.html.var
    ErrorDocument 506 /error/HTTP_VARIANT_ALSO_VARIES.html.var

</IfModule>
</IfModule>

DirectoryIndex index.html index.cgi index.pl index.php index.xhtml

# UserDir is now a module
#UserDir public_html
#UserDir disabled root

#<Directory /home/*/public_html>
#	AllowOverride FileInfo AuthConfig Limit
#	Options Indexes SymLinksIfOwnerMatch IncludesNoExec
#</Directory>

AccessFileName .htaccess

<Files ~ "^\.ht">
    Order allow,deny
    Deny from all
</Files>

UseCanonicalName Off

TypesConfig /etc/mime.types
DefaultType text/plain

HostnameLookups Off

IndexOptions FancyIndexing VersionSort

AddIconByEncoding (CMP,/icons/compressed.gif) x-compress x-gzip

AddIconByType (TXT,/icons/text.gif) text/*
AddIconByType (IMG,/icons/image2.gif) image/*
AddIconByType (SND,/icons/sound2.gif) audio/*
AddIconByType (VID,/icons/movie.gif) video/*

# This really should be .jpg.

AddIcon /icons/binary.gif .bin .exe
AddIcon /icons/binhex.gif .hqx
AddIcon /icons/tar.gif .tar
AddIcon /icons/world2.gif .wrl .wrl.gz .vrml .vrm .iv
AddIcon /icons/compressed.gif .Z .z .tgz .gz .zip
AddIcon /icons/a.gif .ps .ai .eps
AddIcon /icons/layout.gif .html .shtml .htm .pdf
AddIcon /icons/text.gif .txt
AddIcon /icons/c.gif .c
AddIcon /icons/p.gif .pl .py
AddIcon /icons/f.gif .for
AddIcon /icons/dvi.gif .dvi
AddIcon /icons/uuencoded.gif .uu
AddIcon /icons/script.gif .conf .sh .shar .csh .ksh .tcl
AddIcon /icons/tex.gif .tex
AddIcon /icons/bomb.gif core

AddIcon /icons/back.gif ..
AddIcon /icons/hand.right.gif README
AddIcon /icons/folder.gif ^^DIRECTORY^^
AddIcon /icons/blank.gif ^^BLANKICON^^


# This is from Matty J's patch. Anyone want to make the icons?
#AddIcon /icons/dirsymlink.jpg ^^SYMDIR^^
#AddIcon /icons/symlink.jpg ^^SYMLINK^^

DefaultIcon /icons/unknown.gif

ReadmeName README.html
HeaderName HEADER.html

IndexIgnore .??* *~ *# HEADER* RCS CVS *,t

AddEncoding x-compress Z
AddEncoding x-gzip gz tgz

AddLanguage da .dk
AddLanguage nl .nl
AddLanguage en .en
AddLanguage et .et
AddLanguage fr .fr
AddLanguage de .de
AddLanguage el .el
AddLanguage it .it
AddLanguage ja .ja
AddLanguage pl .po
AddLanguage ko .ko
AddLanguage pt .pt
AddLanguage no .no
AddLanguage pt-br .pt-br
AddLanguage ltz .ltz
AddLanguage ca .ca
AddLanguage es .es
AddLanguage sv .se
AddLanguage cz .cz
AddLanguage ru .ru
AddLanguage tw .tw
AddLanguage zh-tw .tw

LanguagePriority en da nl et fr de el it ja ko no pl pt pt-br ltz ca es sv tw


#AddDefaultCharset	ISO-8859-1

AddCharset ISO-8859-1  .iso8859-1  .latin1
AddCharset ISO-8859-2  .iso8859-2  .latin2 .cen
AddCharset ISO-8859-3  .iso8859-3  .latin3
AddCharset ISO-8859-4  .iso8859-4  .latin4
AddCharset ISO-8859-5  .iso8859-5  .latin5 .cyr .iso-ru
AddCharset ISO-8859-6  .iso8859-6  .latin6 .arb
AddCharset ISO-8859-7  .iso8859-7  .latin7 .grk
AddCharset ISO-8859-8  .iso8859-8  .latin8 .heb	
AddCharset ISO-8859-9  .iso8859-9  .latin9 .trk
AddCharset ISO-2022-JP .iso2022-jp .jis
AddCharset ISO-2022-KR .iso2022-kr .kis
AddCharset ISO-2022-CN .iso2022-cn .cis
AddCharset Big5        .Big5       .big5
# For russian, more than one charset is used (depends on client, mostly):
AddCharset WINDOWS-1251 .cp-1251   .win-1251
AddCharset CP866       .cp866
AddCharset KOI8-r      .koi8-r .koi8-ru
AddCharset KOI8-ru     .koi8-uk .ua
AddCharset ISO-10646-UCS-2 .ucs2
AddCharset ISO-10646-UCS-4 .ucs4
AddCharset UTF-8       .utf8

AddCharset GB2312      .gb2312 .gb 
AddCharset utf-7       .utf7
AddCharset utf-8       .utf8
AddCharset big5	       .big5 .b5
AddCharset EUC-TW      .euc-tw	
AddCharset EUC-JP      .euc-jp
AddCharset EUC-KR      .euc-kr
AddCharset shift_jis   .sjis

#AddType application/x-httpd-php .php
#AddType application/x-httpd-php-source .phps

AddType application/x-tar .tgz

# To use CGI scripts outside /cgi-bin/:
#
#AddHandler cgi-script .cgi

# To use server-parsed HTML files
#
<FilesMatch "\.shtml(\..+)?$">
    SetOutputFilter INCLUDES
</FilesMatch>

# If you wish to use server-parsed imagemap files, use
#
#AddHandler imap-file map

BrowserMatch "Mozilla/2" nokeepalive
BrowserMatch "MSIE 4\.0b2;" nokeepalive downgrade-1.0 force-response-1.0
BrowserMatch "RealPlayer 4\.0" force-response-1.0
BrowserMatch "Java/1\.0" force-response-1.0
BrowserMatch "JDK/1\.0" force-response-1.0

#
# The following directive disables redirects on non-GET requests for
# a directory that does not include the trailing slash.  This fixes a 
# problem with Microsoft WebFolders which does not appropriately handle 
# redirects for folders with DAV methods.
#

BrowserMatch "Microsoft Data Access Internet Publishing Provider" redirect-carefully
BrowserMatch "^WebDrive" redirect-carefully
BrowserMatch "^gnome-vfs" redirect-carefully 
BrowserMatch "^WebDAVFS/1.[012]" redirect-carefully

# Allow server status reports, with the URL of http://servername/server-status
# Change the ".your_domain.com" to match your domain to enable.
#
#<Location /server-status>
#    SetHandler server-status
#    Order deny,allow
#    Deny from all
#    Allow from .your_domain.com
#</Location>


# Allow remote server configuration reports, with the URL of
#  http://servername/server-info (requires that mod_info.c be loaded).
# Change the ".your_domain.com" to match your domain to enable.
#
#<Location /server-info>
#    SetHandler server-info
#    Order deny,allow
#    Deny from all
#    Allow from .your_domain.com
#</Location>

# Include the virtual host configurations:
Include /etc/apache2/sites-enabled/[^.#]*
HTTPD.CONF
Code:
# This is here for backwards compatability reasons and to support
#  installing 3rd party modules directly via apxs2, rather than
#  through the /etc/apache2/mods-{available,enabled} mechanism.
#
#LoadModule mod_placeholder /usr/lib/apache2/modules/mod_placeholder.so
DirectoryIndex index.html index.cgi index.pl index.php index.xhtml
I have tried removing the entry from httpd.conf, but nothing happened.

I would like your help because I've tried any possible solution that I could find across the net still nothing happened, so I'm kinda desperate

Thank you all in advance

Last edited by foucault; 07-03-2006 at 11:31 AM.
 
Old 07-03-2006, 10:37 AM   #2
ZST
LQ Newbie
 
Registered: Apr 2006
Posts: 21

Rep: Reputation: 15
Your directory index looked good at first glance, make sure your are using that httpd.conf file. please give the following results:


ps aux|grep apache
ps aux|grep httpd
netstat -na|grep :80
---------------------


if you see apache2 running, but not using the conf file, restart it with the right conf file, you can use:
/path/to/apache2 -f /path/to/httpd.conf

also, im lazy and dont' want to go through your .conf file, but make sure there are no other calls for .php files or index.* files:

grep .php /path/to/httpd.conf>1&&less 1
grep index. /path/to/httpd.conf>2&&less 2

More than likely, your still running your old .conf file or even the old apache binary
 
Old 07-03-2006, 11:24 AM   #3
foucault
LQ Newbie
 
Registered: May 2005
Location: Athens, Greece
Distribution: Ubuntu 6.06 "Dapper Drake"
Posts: 25

Original Poster
Rep: Reputation: 15
Update,
I have also noticed that apache won't even load HTML files from the root (/var/www) directory. As far as I can see. Apache won't load any page from the root directory. For example when I give to my browser http://localhost/ firefox will display me a dialog asking me to SAVE a PHTML file.

It seems like there is a problem with the webroot directory in particular. For example if i give http://localhost/phpmyadmin/ firefox will properly display the index.php of phpmyadmin included in this directory. Also if I create a folder in web-root let's suppose myFolder if I point firefox to http://localhost/myFolder the page will display properly showing the index file no matter if it is html php or any other possible extension. Apache just denies to read ANY index file when given http://localhost/ prompting me to save the phtml file . I have also noticed that if I put an index.php (or any other php file) in the web-root directory and point the browser to http://localhost/anypossiblephpfile.php I will only get a wonderful dialog asking me to save a php file.

What is going on here? I know I am not very smart but I still can't understand what might be causing the issue. Could it be there file-permission problem? (ok, ok don't shoot)

ZST, thank you for your reply. I've tried what you said and everything looks fine. Just to make you know I have made a clean install from ubuntu's repos, so there is not any "old" binary or config file.

Could it just be a browser issue?

HELP!! SOMEBODY!

Last edited by foucault; 07-03-2006 at 11:34 AM.
 
Old 07-03-2006, 12:27 PM   #4
ZST
LQ Newbie
 
Registered: Apr 2006
Posts: 21

Rep: Reputation: 15
What virtual host file do you have from line
Include /etc/apache2/sites-enabled/[^.#]*

Lets see an ls of that directory and inside the file(s)
 
Old 07-03-2006, 01:22 PM   #5
btmiller
Senior Member
 
Registered: May 2004
Location: In the DC 'burbs
Distribution: Arch, Scientific Linux, Debian, Ubuntu
Posts: 4,143

Rep: Reputation: 322Reputation: 322Reputation: 322Reputation: 322
Well, here's one problem ... the line that tells Apache to process PHP files are commented out:

Code:
#AddType application/x-httpd-php .php
Also, I don't see anything in your httpd.conf that actually loads a PHP module. Do you have PHP compiled as module, are you running it as CGI, or is it compiled directly into Apache? Unless it's compiled directly into Apache your config will not work because Apache is never asked to load PHP. And regardless the commented out line above guarantees Apache will not try to process PHP files.
 
Old 07-04-2006, 11:47 AM   #6
foucault
LQ Newbie
 
Registered: May 2005
Location: Athens, Greece
Distribution: Ubuntu 6.06 "Dapper Drake"
Posts: 25

Original Poster
Rep: Reputation: 15
Thank you for your replies,
as far as I know apache2 will load the modules from the mods-enabled directory as shown in the following line of apache2.conf

Code:
# Include module configuration:
Include /etc/apache2/mods-enabled/*.load
Include /etc/apache2/mods-enabled/*.conf
In this directory exist two files concerning php
php5.conf
Code:
<IfModule mod_php5.c>
  AddType application/x-httpd-php .php .phtml .php3
  AddType application/x-httpd-php-source .phps
</IfModule>
and
php5.load
Code:
LoadModule php5_module /usr/lib/apache2/modules/libphp5.so
As you can see apache is instructed to load the module and to process the php files.

Also, concerning the virtual hosts
000-default (included in sites-enabled)
Code:
NameVirtualHost *
<VirtualHost *>
	ServerAdmin webmaster@localhost
	
	DocumentRoot /var/www
	<Directory />
		Options FollowSymLinks
		AllowOverride None
	</Directory>
	<Directory /var/www/>
		Options Indexes FollowSymLinks MultiViews
		AllowOverride None
		Order allow,deny
		allow from all
		# Uncomment this directive is you want to see apache2's
		# default start page (in /apache2-default) when you go to /
		#RedirectMatch ^/$ /apache2-default/
	</Directory>

	ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
	<Directory "/usr/lib/cgi-bin">
		AllowOverride None
		Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
		Order allow,deny
		Allow from all
	</Directory>

	ErrorLog /var/log/apache2/error.log

	# Possible values include: debug, info, notice, warn, error, crit,
	# alert, emerg.
	LogLevel warn

	CustomLog /var/log/apache2/access.log combined
	ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>
 
Old 07-05-2006, 01:43 AM   #7
ZST
LQ Newbie
 
Registered: Apr 2006
Posts: 21

Rep: Reputation: 15
Take out the last line in httpd.conf via comment, and add in something like this

<VirtualHost *>
ServerAdmin whatever@a.com
DocumentRoot /var/www
ServerName localhost.com
ErrorLog /var/log/apache/localhost.error
CustomLog /var/log/apache/localhost.com combined
ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
ScriptAlias /images/ /usr/lib/images
</VirtualHost>

You can make the scriptalias's whatever, but try to put the config's in the httpd.conf and not in the inculde file, but do not just copy it straight over, just use the template i gave you there, and see if it works after that. Let me know how it works for you.
 
Old 07-07-2006, 02:11 PM   #8
foucault
LQ Newbie
 
Registered: May 2005
Location: Athens, Greece
Distribution: Ubuntu 6.06 "Dapper Drake"
Posts: 25

Original Poster
Rep: Reputation: 15
Thank you all, but after all was a browser issue (Doh!). A whole week of editing and re-editing files just to find out that FF has messed up with the profile. I've deleted it and created a new one.

Anyway, thank you all so much for your valuable help. I am sure I will put those advices in good use when needed!
 
Old 07-08-2006, 09:34 AM   #9
ZST
LQ Newbie
 
Registered: Apr 2006
Posts: 21

Rep: Reputation: 15
Good deal -- hope everything goes well for you now
 
Old 06-02-2008, 10:04 AM   #10
hurt138
LQ Newbie
 
Registered: Jan 2007
Distribution: Debian GNU/Linux
Posts: 9

Rep: Reputation: Disabled
I actually had this same issue with apache2 and php5 in Debian and Ubuntu.

At the time of install I "apt-get install apache2 phpmyadmin". Which use to pull all the dependency fine and setup the server for me. After some mucking around I finally just reconfigured phpmyadmin with "dpkg-reconfigure phpmyadmin" restart apache2 and everything started working for me.

Hope this helps someone out.
 
Old 05-03-2009, 05:46 PM   #11
leopardCub
LQ Newbie
 
Registered: Apr 2009
Posts: 2

Rep: Reputation: 0
I know this thread is OLD news, but I just had this problem and think something on this page may have helped...

in /etc/apache2/mods-enabled/ i didnt have any files relating to php (even though i had installed libapache2-mod-php5, php5, php5-common), so i created php5.conf and php5.load and filled them with what you quoted as having in yours. i also did a million other things, but eventually it just started working again. lots of apache restarts, browser cache emptying, trying other browsers (at one point deleting my firefox profile). restarting my computer. something worked... (btw i currently have nothing in my httpd.conf). i do have the following line in my apache2.conf tho:
AddType application/x-httpd-php .php

just thought i'd write this stuff down in case it ever helps someone else. SUCH an annoying problem!
 
Old 03-20-2010, 10:08 PM   #12
Pinoud Liu
LQ Newbie
 
Registered: Mar 2010
Posts: 1

Rep: Reputation: 0
I got this problem either, and it really made me crazy. But finally, I knew what's wrong.

Instead of opening the file '*.php' in the directory '/var/www/' directly, we should type '//localhost/*.php' in the address bar of our internet browser.

Hope this may help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache2+PHP5 won't serve index.php...sometimes! michaelsanford Linux - Software 1 06-11-2006 09:24 PM
Suse 9.3/apache2/php4 - Firefox tries to download index.php, other *php pages work stefanlasiewski Suse/Novell 1 01-18-2006 07:12 PM
Apache2 no index.html page babelbrennt Debian 1 11-10-2005 08:35 AM
page won't load (apache2+php on TSL 2.1) restless Linux - Software 1 08-13-2004 10:54 PM
apache2 refuses to load php JanRigter Linux - Software 1 07-01-2003 02:31 PM


All times are GMT -5. The time now is 07:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration