LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-01-2003, 10:35 AM   #1
c-ker
LQ Newbie
 
Registered: Aug 2003
Posts: 5

Rep: Reputation: 0
Apache2 and SusE 8.2


Would anyone know what the reason for apache2 ignoring my .htaccess files?

I have previously installed the same php program called claroline on a mandrake 9.1 and it worked fine, but with SusE 8.2, it just plainly ignores the .htaccess files (they are generated during the installation of the php program)

Does anyone know if there is a place in httpd2.conf I can look to check that apache is looking for .htaccess files?

Thanks
 
Old 08-01-2003, 12:30 PM   #2
MacKtheHacK
Member
 
Registered: Jul 2003
Location: Boston, MA, USA
Distribution: RedHat, SuSE, Gentoo, Slackware, Mandrake ...
Posts: 111

Rep: Reputation: 15
Check that the AccessFileName directive in your http2.conf says to look for .htaccess files and not some other name. That's the first thing to look for. Also, make sure your server has mod_auth enabled. See the fine documentation at http://httpd.apache.org/docs-2.0/howto/auth.html for additional help.
 
Old 08-01-2003, 01:10 PM   #3
c-ker
LQ Newbie
 
Registered: Aug 2003
Posts: 5

Original Poster
Rep: Reputation: 0
I looked in httpd2.conf and found .htaccess and I mod_auth is enabled, looks like its off to the apache documentation site for me.

Thanks for the tips
 
Old 08-01-2003, 02:53 PM   #4
beyond_2000
Member
 
Registered: Oct 2002
Location: Guangdong,Chinese
Distribution: Redhat AS 3.0 + FC1
Posts: 72

Rep: Reputation: 15
you should install mod_php4 for apache2 , because suse does not supply mod_php4 for apache2 by default for security reason. Download it from it's official site
ftp://ftp.suse.com/pub/projects/apache/
 
Old 08-01-2003, 03:07 PM   #5
Cooner
Member
 
Registered: Jul 2003
Location: Hastings, MN. USA
Distribution: Ubuntu 10.xx
Posts: 109

Rep: Reputation: 15
check you httpd.conf for a line AllowOveride
default it gets set to none
set it to AuthConfig for start then do some research for more options but that should get it started.
Also if you are using Virtual Hosting make sure you did'nt overide this setting in the VH directives.
HTH
 
Old 08-02-2003, 09:16 AM   #6
c-ker
LQ Newbie
 
Registered: Aug 2003
Posts: 5

Original Poster
Rep: Reputation: 0
AuthConfig

I seem to have etc/apache2 directory with a httpd.conf in it and also a etc/httpd

I have put AllowOverride AuthConfig in both and when I entered my .htaccess directory it challenged me, but this was only once!

I tried it again and it didnt work

I opened up a new instance of a web browser and tried it again, but to no avail,

This is driving me up the wall

Any other tips (apart from reading the apache manual)?

Thanks
 
Old 08-02-2003, 11:01 AM   #7
c-ker
LQ Newbie
 
Registered: Aug 2003
Posts: 5

Original Poster
Rep: Reputation: 0
success!!

After changing every httpd.conf file I had (3 in all!!), the .htaccess is now recognised, although the pages I protect are available by url after you have navigated away from them until you close the browser and open a new instance.

That will do for the mean time.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache2 on Suse 9.3 - File Permissions jacobt Linux - Software 3 12-02-2005 05:47 PM
Suse 10 64 bit apache2 sorry? barrythai SUSE / openSUSE 4 10-25-2005 02:51 PM
apache2 + https on suse 9.2 linux svanati SUSE / openSUSE 0 02-22-2005 02:47 PM
Apache2 uninstall on SUSE Janooo Linux - Newbie 4 12-22-2004 11:49 AM
SuSE 9.0, Apache2, and Webmin dkpw Linux - Software 2 08-22-2004 12:21 AM


All times are GMT -5. The time now is 05:13 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration