LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-15-2003, 04:29 PM   #1
WiWa
Member
 
Registered: Aug 2003
Distribution: Redhat 9.0, Fedora Core, Suse 9.1, Mandrake
Posts: 82

Rep: Reputation: 15
Apache: You are not authorized to ...


Hi all,

I have installed an Apache webserver. I want to have my website (www.wauters-mannaert.be) running on this server. This Apache webserver is behind an E-Tech ADSL Router on which port 80 is open. I also have Dynamic DNS working of which I'm sure it is OK.

From my internal network I can perfectly view my website. However, people surfing to my site cannot access the site and get http 403 error (You are not authorized to view this page).

Although I know 100% sure that my friends tried to access the page, I do not see anything in my access_log file, which I fiund strange. If people get a 403 message, you would at least expect an entry in access_log. Does anyone know what is wrong. Basically I have two questions;

1) Why do people get the message 403. Is there sth wrong with my httpd.conf file (see below)
2) Why are there no entries in the access_log. Port 80 is open on
my ADSL-router

Anyone help is appreciated, because I don't know what could be wrong here.

Here is a part of my httpd.conf file.

##
## httpd.conf -- Apache HTTP server configuration file
##


### Section 1: Global Environment
ServerType standalone
ServerRoot "/usr/local/apache"
#LockFile /usr/local/apache/logs/httpd.lock
PidFile /usr/local/apache/logs/httpd.pid
ScoreBoardFile /usr/local/apache/logs/httpd.scoreboard
Timeout 300
KeepAlive Off
MaxKeepAliveRequests 100
KeepAliveTimeout 15
MinSpareServers 5
MaxSpareServers 10
StartServers 5
MaxClients 150
MaxRequestsPerChild 0
Listen *:80
#BindAddress *
<IfDefine SSL>
LoadModule ssl_module libexec/libssl.so
</IfDefine>

ClearModuleList
AddModule mod_env.c
AddModule mod_log_config.c
AddModule mod_mime.c
AddModule mod_negotiation.c
AddModule mod_status.c
AddModule mod_include.c
AddModule mod_autoindex.c
AddModule mod_dir.c
AddModule mod_cgi.c
AddModule mod_asis.c
AddModule mod_imap.c
AddModule mod_actions.c
AddModule mod_userdir.c
AddModule mod_alias.c
AddModule mod_access.c
AddModule mod_auth.c
AddModule mod_so.c
AddModule mod_setenvif.c
<IfDefine SSL>
AddModule mod_ssl.c
</IfDefine>
AddModule mod_php4.c

#ExtendedStatus On

### Section 2: 'Main' server configuration
Port 80
<IfDefine SSL>
Listen 80
Listen 443
User apache
Group apache
ServerAdmin root@wauters-mannaert.be
ServerName thorgal
DocumentRoot "/usr/local/apache/htdocs/wauters-mannaert/"
<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>

<Directory "/usr/local/apache/htdocs/wauters-mannaert/">
Options Indexes FollowSymLinks MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>

<IfModule mod_userdir.c>
UserDir public_html
</IfModule>

#<Directory /home/*/public_html>
# AllowOverride FileInfo AuthConfig Limit
# Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
# <Limit GET POST OPTIONS PROPFIND>
# Order allow,deny
# Allow from all
# </Limit>
# <LimitExcept GET POST OPTIONS PROPFIND>
# Order deny,allow
# Deny from all
# </LimitExcept>
#</Directory>

<IfModule mod_dir.c>
DirectoryIndex index.html index.htm
</IfModule>

AccessFileName .htaccess

<Files ~ "^\.ht">
Order allow,deny
Deny from all
Satisfy All
</Files>

#CacheNegotiatedDocs

UseCanonicalName On

<IfModule mod_mime.c>
TypesConfig /usr/local/apache/conf/mime.types
</IfModule>

DefaultType text/plain

<IfModule mod_mime_magic.c>
MIMEMagicFile /usr/local/apache/conf/magic
</IfModule>

HostnameLookups On

ErrorLog /usr/local/apache/logs/error_log

LogLevel warn
LogFormat "%h|%l|%u|%t|%m|%U|%q|%H|%>s|%b|%{accept-language}i" custom
LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-agent}i\"" common
LogFormat "%t|%{Referer}i -> |%U" referer
LogFormat "%t|%{User-agent}i" agent
CustomLog /usr/local/apache/logs/access_log common

CustomLog /usr/local/apache/logs/referer_log referer
CustomLog /usr/local/apache/logs/browser_log agent
CustomLog /usr/local/apache/logs/custom_log custom

ServerSignature On

# EBCDICConvertByType On=InOut text/* message/* multipart/*
# EBCDICConvertByType On=In application/x-www-form-urlencoded
# EBCDICConvertByType On=InOut application/postscript model/vrml
# EBCDICConvertByType Off=InOut */*

<IfModule mod_alias.c>

Alias /icons/ "/usr/local/apache/icons/"

<Directory "/usr/local/apache/icons">
Options Indexes MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>

Alias /manual/ "/usr/local/apache/htdocs/manual/"

<Directory "/usr/local/apache/htdocs/manual">
Options Indexes FollowSymlinks MultiViews
AllowOverride None
Order allow,deny
Allow from all
</Directory>

ScriptAlias /cgi-bin/ "/usr/local/apache/cgi-bin/"

<Directory "/usr/local/apache/cgi-bin">
AllowOverride None
Options None
Order allow,deny
Allow from all
</Directory>

</IfModule>
 
Old 08-15-2003, 04:42 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
They are possibly seeing your router config page? I assume that runs on port 80. Try a different port.
 
Old 08-15-2003, 04:49 PM   #3
WiWa
Member
 
Registered: Aug 2003
Distribution: Redhat 9.0, Fedora Core, Suse 9.1, Mandrake
Posts: 82

Original Poster
Rep: Reputation: 15
Hi,

I changed now in httpd everything from 80 to 81. In my router, I added a virtual route so that public it works on port 80 but private it goes to port 81. Is that what you mean? I cannot test, because in my private network I don't see the problem.


Wim
 
Old 08-15-2003, 04:51 PM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
no the other way round - people on the outside will conenct to port 81 which forwards to port 80 on the server.
 
Old 08-15-2003, 04:57 PM   #5
WiWa
Member
 
Registered: Aug 2003
Distribution: Redhat 9.0, Fedora Core, Suse 9.1, Mandrake
Posts: 82

Original Poster
Rep: Reputation: 15
Thanks, of course you're right. This is the entry in my E-tech router:

public 81
private 80
protocol TCP
private address 10.0.0.8 (Apache server)


I left in my httpd.conf file everything on port 80 in that case. It does not seem to work?

Wim
 
Old 08-15-2003, 05:08 PM   #6
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
It deosn't work? Same message or different?

What are the external users connecting to?
http://your.public.ip.address:81/
or
http://10.0.0.8:81/
 
Old 08-15-2003, 05:13 PM   #7
WiWa
Member
 
Registered: Aug 2003
Distribution: Redhat 9.0, Fedora Core, Suse 9.1, Mandrake
Posts: 82

Original Poster
Rep: Reputation: 15
They should use http://www.wauters-mannaert.be:81. I cannot test if it works. I have no 'external' computers. If you give in that URL, do you see a normal page?
 
Old 08-15-2003, 05:26 PM   #8
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Ok for me:
Quote:
Beste bezoeker,

Zoals u wellicht al kon opmerken is deze website nog in volle opbouw. De meeste mensen hebben websites die al bij al geen wereldschokkend nieuws te melden hebben en daarin verschilt ook deze website niet.

De bedoeling is enerzijds om wat interessante informatie te delen alsook een aantal foto's van onze gemaakte reizen of trips aan te bieden. Anderzijds is het ook een soort van testpagina om de werking van de Apache webserver beter te begrijpen. In de toekomst zullen - indien de tijd het toelaat - wellicht zelfgemaakte scripts (gastenboek, uurwerk, webmail, ...) draaien.



Met vriendelijke groeten,


Wim Wauters
 
Old 08-15-2003, 05:28 PM   #9
WiWa
Member
 
Registered: Aug 2003
Distribution: Redhat 9.0, Fedora Core, Suse 9.1, Mandrake
Posts: 82

Original Poster
Rep: Reputation: 15
Cool...Thanks a lot for your help...Last question:

Now, how can I make that my external users do not have to add the :81 at the end. I would like to do some kind of translations that if they type in www.wauters-mannaert.be, this actually means www.wauters-mannaert.be:81

Wim
 
Old 08-15-2003, 05:42 PM   #10
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
I don't think you can unless there is a way to disable the admin interface from listening on the external ip address.
 
Old 08-15-2003, 05:45 PM   #11
WiWa
Member
 
Registered: Aug 2003
Distribution: Redhat 9.0, Fedora Core, Suse 9.1, Mandrake
Posts: 82

Original Poster
Rep: Reputation: 15
Or I can maybe try to force my E-Tech router to work/listen on another port than 80, say 82 and then use 80 for my webserver. Hope that works...I'm not very knowledgeable on this port stuff...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
This account is not authorized to login from this station mediocrity Linux - Networking 1 04-30-2005 02:20 PM
user not authorized to log into samba server from win XP station wolgar Linux - Newbie 1 09-21-2004 11:15 PM
CUPS: "This server could not verify that you are authorized to use this resrouce" hamish Linux - Software 0 07-02-2004 04:57 AM
Peer is not authorized to use remote address fransemail Linux - General 12 05-04-2004 03:51 PM
Relaying Authorized users only in Sendmail??? markstevens Linux - Software 4 07-22-2003 10:03 AM


All times are GMT -5. The time now is 11:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration