LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-02-2003, 01:49 PM   #1
Gear_freak2000
Member
 
Registered: Jun 2003
Posts: 90

Rep: Reputation: 15
apache wont start... any ideas...


[root@cytoweb local]# /etc/init.d/httpd start
Starting httpd: Syntax error on line 6 of /etc/httpd/conf.d/auth_mysql.conf:
Cannot load /etc/httpd/modules/mod_auth_mysql.so into server: libmysqlclient.so.
10: cannot open shared object file: No such file or directory
FAILED]
[root@cytoweb local]#

Any idea on how 2 fix this problem!!

Thanks for any help!
 
Old 06-02-2003, 01:52 PM   #2
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Well it clearly tells you that it cannot load mod_auth_mysql.so as it probably is a wrong path.. etc. Check your path to make sure its correct to load that module.
 
Old 06-02-2003, 01:53 PM   #3
Gear_freak2000
Member
 
Registered: Jun 2003
Posts: 90

Original Poster
Rep: Reputation: 15
no wait scrap that!

I want 2 remove apache from my server so i can install it again.... how do i go about removing it?
 
Old 06-02-2003, 01:56 PM   #4
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 234Reputation: 234Reputation: 234
Quote:
Originally posted by Gear_freak2000
no wait scrap that!

I want 2 remove apache from my server so i can install it again.... how do i go about removing it?
What's wrong with it now, your reason to remove it that is? Just wondering really.
 
Old 06-02-2003, 01:59 PM   #5
Gear_freak2000
Member
 
Registered: Jun 2003
Posts: 90

Original Poster
Rep: Reputation: 15
sorry let me make things a bit more clear...

Im using REDHAT 9.0 i want 2 remove the one that it installs so that can install it from source....

i thought i had removed it but when i try and install the new one i get this error:


<LOADS OF cp: things>
cp: `include/util_xml.h' and `/usr/local/httpd-2.0.46/include/util_xml.h' are th
e same file
make[1]: *** [install-include] Error 1
make[1]: Leaving directory `/usr/local/httpd-2.0.46'
make: *** [install-recursive] Error 1
[root@cytoweb httpd-2.0.46]#
 
Old 06-02-2003, 02:10 PM   #6
Crashed_Again
Senior Member
 
Registered: Dec 2002
Location: Atlantic City, NJ
Distribution: Ubuntu & Arch
Posts: 3,503

Rep: Reputation: 57
How did you uninstall it exactly?
 
Old 06-02-2003, 02:12 PM   #7
Gear_freak2000
Member
 
Registered: Jun 2003
Posts: 90

Original Poster
Rep: Reputation: 15
i unisntalled it using the add/remove programs thing that comes with redhat 9.0...

if i try

rpm -e httpd

i get this error

[root@cytoweb httpd-2.0.46]# rpm -e httpd
error: Failed dependencies:
httpd-mmn = 20020628 is needed by (installed) mod_perl-1.99_07-5
httpd-mmn = 20020628 is needed by (installed) mod_python-3.0.1-3
httpd-mmn = 20020628 is needed by (installed) php-4.2.2-17
httpd-mmn = 20020628 is needed by (installed) mod_auth_mysql-1.11-12
httpd-mmn = 20020628 is needed by (installed) mod_auth_pgsql-0.9.12-14
libapr.so.0 is needed by (installed) mod_perl-1.99_07-5
libaprutil.so.0 is needed by (installed) mod_perl-1.99_07-5
webserver is needed by (installed) webalizer-2.01_10-11
httpd is needed by (installed) redhat-config-httpd-1.0.1-18
httpd >= 2.0.40 is needed by (installed) mod_perl-1.99_07-5
httpd >= 2.0.40 is needed by (installed) mod_python-3.0.1-3
httpd >= 2.0.40 is needed by (installed) mod_auth_mysql-1.11-12
httpd >= 2.0.40 is needed by (installed) mod_auth_pgsql-0.9.12-14
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache wont start stlyz3 Linux - Software 14 05-30-2005 02:25 PM
apache service wont start tenmiles Linux - General 3 11-26-2004 01:45 AM
apache wont start mrgeoff Linux - Software 8 10-27-2004 03:46 PM
Apache wont start. Never seen this error before mpriddy Linux - Software 1 10-12-2004 04:44 PM
apache 1.3 wont start on redhat 7.3 buddamonk Linux - Software 3 03-03-2004 11:31 PM


All times are GMT -5. The time now is 06:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration