LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-21-2005, 03:57 AM   #1
stlyz3
Member
 
Registered: Mar 2005
Posts: 54

Rep: Reputation: 15
Apache wont start


Im running Fedora Core 3 on my webserver. This is on a fresh install. Ran apachectl configtest and everything is fine. I ran apachectl start and no errors. I run apachectl stop i get:

httpd (no pid file) not running

When /etc/init.d/httpd start is ran i get
httpd: (FAILED)

is there some way of getting apache to start correctly?
 
Old 05-21-2005, 08:42 AM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Is apache running?
ps -ef | grep httpd
 
Old 05-23-2005, 10:38 AM   #3
stlyz3
Member
 
Registered: Mar 2005
Posts: 54

Original Poster
Rep: Reputation: 15
When run, it says that apache isnt running. Is there something else I can try?
 
Old 05-23-2005, 01:09 PM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
What do you get from:
ps -ef | grep httpd

What errors show up in the apache error_log file?
 
Old 05-26-2005, 01:34 PM   #5
stlyz3
Member
 
Registered: Mar 2005
Posts: 54

Original Poster
Rep: Reputation: 15
It give me:

root 3319 1 0 13:48 ? 00:00:00 /usr/sbin/httpd -k start
apache 3320 3319 0 13:48 ? 00:00:00 /usr/sbin/httpd -k start
apache 3321 3319 0 13:48 ? 00:00:00 /usr/sbin/httpd -k start
apache 3322 3319 0 13:48 ? 00:00:00 /usr/sbin/httpd -k start
apache 3323 3319 0 13:48 ? 00:00:00 /usr/sbin/httpd -k start
apache 3324 3319 0 13:48 ? 00:00:00 /usr/sbin/httpd -k start
apache 3325 3319 0 13:48 ? 00:00:00 /usr/sbin/httpd -k start
apache 3326 3319 0 13:48 ? 00:00:00 /usr/sbin/httpd -k start
apache 3327 3319 0 13:48 ? 00:00:00 /usr/sbin/httpd -k start
root 3330 2800 0 13:48 tty1 grep httpd

I dont know what that really means. When I run apachectl start it tells me that it can find the servers fully qualified domain name so its using localhost.localdomain.
 
Old 05-26-2005, 01:37 PM   #6
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
That means apache is running.

If you have a FQDN then specify it in your hosts file and in httpd.conf otherwise it should run fine anyway.
 
Old 05-26-2005, 01:51 PM   #7
stlyz3
Member
 
Registered: Mar 2005
Posts: 54

Original Poster
Rep: Reputation: 15
Smile

Can you please tell me what an FQDN is? I dont know exactly.

Thanks for helping me through this process!
 
Old 05-26-2005, 01:55 PM   #8
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
You said it yourself earlier
FQDN=Fully Qualified Domain Name
 
Old 05-26-2005, 02:06 PM   #9
stlyz3
Member
 
Registered: Mar 2005
Posts: 54

Original Poster
Rep: Reputation: 15
So would I add a line for one of the ip addresses that i have in the hosts file? Lets say
192.168.2.200 iprats.com

?
 
Old 05-26-2005, 02:10 PM   #10
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Yes. Then set this in httpd.conf:
ServerName iprats.com
 
Old 05-26-2005, 02:15 PM   #11
stlyz3
Member
 
Registered: Mar 2005
Posts: 54

Original Poster
Rep: Reputation: 15
Thumbs up

Wonderful! That works!!
Thanks alot for your help with this!!
 
Old 05-27-2005, 05:34 PM   #12
stlyz3
Member
 
Registered: Mar 2005
Posts: 54

Original Poster
Rep: Reputation: 15
With that said, I now have a new problem and it is with SSL and apache. Mod_ssl is installed. The problem that i have been running into with the problem earlier is that if I turn off encryption using Webmin on the virtual domain, then everything works fine without a ServerName present in httpd.conf. If I turn it on and restart apache, then apache wont start. If I put in a domain name in httpd.conf then it simply says httpd:failed.

When I setup a domain using virtualmin in Webmin, it says that SSL Enable is turned not available. do you know of what I can do to get https:// enabled on the site and still have apache run smoothly?
 
Old 05-28-2005, 09:07 AM   #13
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
I have no idea what webmin is doing when you are changing these options.

Do you get any errors in your apache error_log file?
 
Old 05-29-2005, 04:08 PM   #14
stlyz3
Member
 
Registered: Mar 2005
Posts: 54

Original Poster
Rep: Reputation: 15
Where is the apache error log located?
 
Old 05-30-2005, 01:25 PM   #15
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
It depends on your configuration. /var/log/httpd is a fairly standard location.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apache service wont start tenmiles Linux - General 3 11-26-2004 12:45 AM
apache wont start mrgeoff Linux - Software 8 10-27-2004 02:46 PM
Apache wont start. Never seen this error before mpriddy Linux - Software 1 10-12-2004 03:44 PM
Apache wont start in Gentoo netquest1 Linux - Software 2 02-17-2004 09:13 PM
apache wont start on boot Pete Dogg Linux - Software 12 10-30-2003 12:26 PM


All times are GMT -5. The time now is 07:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration