LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-02-2003, 05:41 PM   #1
Gear_freak2000
Member
 
Registered: Jun 2003
Posts: 90

Rep: Reputation: 15
Apache wont install.....


Ok... im just not having anyluck with apache.... (with linux in genral)

Ok here is my problem....

I installed REDHAT 9.0... Without apache, mysql or php

I installed Mysql (Working fine)

i downloaded httpd-2.0.46.tar.gz

Put it into /usr/local/

gunzip then untar it...

enter the Dir and type

./configure --prefix=/usr/local/httpd-2.0.46 --enable-module=so

then type make

when its made

I type make install

It all seems 2 be going fine... But then... gets 2 a point and says

cp: `include/util_ebcdic.h' and `/usr/local/httpd-2.0.46/include/util_ebcdic.h'
are the same file
cp: `include/util_filter.h' and `/usr/local/httpd-2.0.46/include/util_filter.h'
are the same file
cp: `include/util_ldap.h' and `/usr/local/httpd-2.0.46/include/util_ldap.h' are
the same file
cp: `include/util_md5.h' and `/usr/local/httpd-2.0.46/include/util_md5.h' are th
e same file
cp: `include/util_script.h' and `/usr/local/httpd-2.0.46/include/util_script.h'
are the same file
cp: `include/util_time.h' and `/usr/local/httpd-2.0.46/include/util_time.h' are
the same file
cp: `include/util_xml.h' and `/usr/local/httpd-2.0.46/include/util_xml.h' are th
e same file
make[1]: *** [install-include] Error 1
make[1]: Leaving directory `/usr/local/httpd-2.0.46'
make: *** [install-recursive] Error 1


ARG! any ideas whats up? maybe i should try an older version of apache?

THANKS FOR ANY HELP!!!
 
Old 06-02-2003, 06:45 PM   #2
mcleodnine
Senior Member
 
Registered: May 2001
Location: Left Coast - Canada
Distribution: s l a c k w a r e
Posts: 2,731

Rep: Reputation: 45
Try unpacking the tarball into a different directory. You are trying to install it (the binary, lib and include files) into the same directory as your source tree (by using the --prefix= )

I use a schema like this for my source builds.

/usr/src/packages
/usr/src/packages/apache-1.3.27
/usr/src/packages/php-4.3.20
etc...

You may also want to have a look at the LAMPS link in the Networking secion of the "Links" pages here at LQ. Apache from source can be a bit of a beast the first time around.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache wont start stlyz3 Linux - Software 14 05-30-2005 02:25 PM
apache wont start mrgeoff Linux - Software 8 10-27-2004 03:46 PM
2 probs, apt-get wont download anything. blackbox wont install minibootsy Linux - Software 2 06-10-2004 02:55 AM
Apache 2 wont work vladoboss Linux - Software 3 06-03-2004 05:11 AM
Suse 9, RH9 wont install properly. Mandrake 9 wont boot properly? Help. l2ich84 Linux - Newbie 1 01-31-2004 12:02 PM


All times are GMT -5. The time now is 12:55 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration