LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 01-23-2004, 06:30 PM   #1
kleptophobiac
Member
 
Registered: Jun 2003
Distribution: Arch
Posts: 315

Rep: Reputation: 30
Apache won't compile...


I'm trying to use apache, ssl, and php. Here's the error I get when I make apache:

Code:
gcc -c  -I../os/unix -I../include   -DLINUX=22 -DMOD_SSL=208116 -DEAPI -DNO_DL_NEEDED `../apaci` gen_test_char.c
gcc  -DLINUX=22 -DMOD_SSL=208116 -DEAPI -DNO_DL_NEEDED `../apaci` -L/usr/local/ssl/lib  -o gen_test_char gen_test_char.o  -Wl,-rpath,/usr/local/ssl/lib  -rdynamic -L/usr/local/ssl/lib -Lmodules/php4 -L../modules/php4 -L../../modules/php4 -lmodphp4    -rdynamic -L/usr/local/ssl/lib -lcrypt   -lcrypt -lssl -lcrypto -lresolv -lm -ldl -lnsl  -lcrypt -lcrypt   -lm -lcrypt  -lssl -lcrypto -lexpat
./gen_test_char >test_char.h
gcc -c  -I../os/unix -I../include   -DLINUX=22 -DMOD_SSL=208116 -DEAPI -DNO_DL_NEEDED `../apaci` alloc.c
gcc -c  -I../os/unix -I../include   -DLINUX=22 -DMOD_SSL=208116 -DEAPI -DNO_DL_NEEDED `../apaci` buff.c
gcc -c  -I../os/unix -I../include   -DLINUX=22 -DMOD_SSL=208116 -DEAPI -DNO_DL_NEEDED `../apaci` http_config.c
gcc -c  -I../os/unix -I../include   -DLINUX=22 -DMOD_SSL=208116 -DEAPI -DNO_DL_NEEDED `../apaci` http_core.c
gcc -c  -I../os/unix -I../include   -DLINUX=22 -DMOD_SSL=208116 -DEAPI -DNO_DL_NEEDED `../apaci` http_log.c
gcc -c  -I../os/unix -I../include   -DLINUX=22 -DMOD_SSL=208116 -DEAPI -DNO_DL_NEEDED `../apaci` http_main.c
gcc -c  -I../os/unix -I../include   -DLINUX=22 -DMOD_SSL=208116 -DEAPI -DNO_DL_NEEDED `../apaci` http_protocol.c
gcc -c  -I../os/unix -I../include   -DLINUX=22 -DMOD_SSL=208116 -DEAPI -DNO_DL_NEEDED `../apaci` http_request.c
gcc -c  -I../os/unix -I../include   -DLINUX=22 -DMOD_SSL=208116 -DEAPI -DNO_DL_NEEDED `../apaci` http_vhost.c
gcc -c  -I../os/unix -I../include   -DLINUX=22 -DMOD_SSL=208116 -DEAPI -DNO_DL_NEEDED `../apaci` util.c
gcc -c  -I../os/unix -I../include   -DLINUX=22 -DMOD_SSL=208116 -DEAPI -DNO_DL_NEEDED `../apaci` util_date.c
gcc -c  -I../os/unix -I../include   -DLINUX=22 -DMOD_SSL=208116 -DEAPI -DNO_DL_NEEDED `../apaci` util_script.c
gcc -c  -I../os/unix -I../include   -DLINUX=22 -DMOD_SSL=208116 -DEAPI -DNO_DL_NEEDED `../apaci` util_uri.c
util_uri.c: In function `ap_parse_uri_components':
util_uri.c:367: `uri_delims' undeclared (first use in this function)
util_uri.c:367: (Each undeclared identifier is reported only once
util_uri.c:367: for each function it appears in.)
make[3]: *** [util_uri.o] Error 1
make[2]: *** [subdirs] Error 1
make[2]: Leaving directory `/usr/src/apache_1.3.29/src'
make[1]: *** [build-std] Error 2
make[1]: Leaving directory `/usr/src/apache_1.3.29'
make: *** [build] Error 2
 
Old 01-23-2004, 06:43 PM   #2
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
That's bad. Looks more like a gcc incompatibility then anything else. Perhaps you are using one version of gcc which won't work with the program that you are trying to compile. I can see that you are using Slackware 9.0 as me. Get the pre-compiled packages from www.slackware.com/getslack for Apache, ssl, php and mysql. I started learning php yesterday and everything is working in a perfect harmony with a painless installation. If you are willing to use a newer version of those packages, then you may want to use Slack 9.1 packages instead.

Side Note: I've tried to upgrade Apache, mysql and php with swaret, and they all got broken...

Regards!

Last edited by Mega Man X; 01-23-2004 at 06:44 PM.
 
Old 01-23-2004, 10:05 PM   #3
kleptophobiac
Member
 
Registered: Jun 2003
Distribution: Arch
Posts: 315

Original Poster
Rep: Reputation: 30
This is actually slackware 9.1...
 
Old 01-23-2004, 10:22 PM   #4
Mega Man X
LQ Guru
 
Registered: Apr 2003
Location: ~
Distribution: Ubuntu, FreeBSD, Solaris, DSL
Posts: 5,339

Rep: Reputation: 64
Cool, then go into www.slackware/getslack, download and install swaret (if you already don't have it) then type

swaret --install apache

Or simply use the apache from there
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
I can't get GD to compile in Apache rixride00 Linux - Newbie 1 10-01-2004 02:17 PM
Apache 2 and PHP 4.3.3 compile help gquiring Red Hat 1 11-03-2003 08:14 PM
compile resin with apache ? htdatlq Linux - Newbie 0 10-30-2003 10:10 PM
Apache 2 with SSL doesn't compile jqcaducifer Linux - Networking 0 08-03-2003 06:13 PM
apache compile on RH9 llee Linux - Software 7 05-05-2003 04:46 PM


All times are GMT -5. The time now is 06:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration