LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-27-2003, 12:22 PM   #1
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Rep: Reputation: 30
apache with PHP and PERL


Hello!
If I want to write CGI scripts under my Apache server do I need to compile Apache with Perl support?
And if I want to use PHP in my pages do I need do compile Apache with
PHP support?
If both answers are yes, how can I compile Apache together with PHP and Perl Support?
I know how to do that separately, but dunno how together.

if my question wansn't to complicated, plz help
 
Old 06-27-2003, 01:51 PM   #2
slam
Member
 
Registered: Mar 2003
Posts: 36

Rep: Reputation: 15
from what I understand

if needed you should be able to add as many options as you want on the compile of apache. I've done php but not perl.
although I cannot remember exactly the what I did.
not much help here. good luck
 
Old 06-28-2003, 05:21 AM   #3
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Original Poster
Rep: Reputation: 30
I have compiled Apache with PHP, and now Apache cannot even read my config file.
 
Old 06-28-2003, 07:01 AM   #4
slizadel
LQ Newbie
 
Registered: Jun 2003
Distribution: RH9, Gentoo, Slack
Posts: 23

Rep: Reputation: 15
Here is a link to guide you through installing Apache, MySQL, PHP, and mod_perl, to name a few. Don't worry, there is an english version, you just have to click on the link in the top left-hand corner of the page. If you do not want some of the addons installed, just skip over their installation steps and modify the ./configure of the other packages so that they do not try to install with those packages. Hope this information helps.
 
Old 06-28-2003, 08:10 AM   #5
nautilus_1987
Member
 
Registered: Aug 2002
Distribution: Slackware 8.1
Posts: 750

Original Poster
Rep: Reputation: 30
thnx slizadel, but I have already installed Apache, now look what I got:
[root@ /usr/local/apache]# bin/httpd -l
Compiled-in modules:
http_core.c
mod_so.c
suexec: disabled; invalid wrapper /usr/local/apache/bin/suexec
[root@ /usr/local/apache]#
[root@ /usr/local/apache]# bin/httpd -d /underground/www/maniak/
Syntax error on line 5 of /underground/www/maniak/conf/httpd.conf:
Invalid command 'TransferLog', perhaps mis-spelled or defined by a module not included in the server configuration
[root@ /usr/local/apache]#
================================
WTF, I have compiled all modules in how can I load them, so my server would work?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
apache, php, perl, mysql equinox Slackware 12 02-16-2005 10:53 AM
Problem with perl module for w3c validator to work on my local Apache+PHP+perl instal tbamt Linux - Software 0 12-16-2004 06:37 PM
Apache, PHP, MySQL, Perl coolamit78 Linux - Software 3 04-20-2004 02:59 AM
chrooting apache v2 (php, ssl, perl support) ; perl configuration markus1982 Linux - Security 3 01-26-2003 07:15 PM
Replacing PHP with Perl in Apache? miknight Programming 1 12-20-2002 02:32 AM


All times are GMT -5. The time now is 05:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration