LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-03-2005, 12:33 AM   #1
critical
Member
 
Registered: Feb 2005
Location: New Zealand
Distribution: Debian, Ubuntu
Posts: 46

Rep: Reputation: 15
Apache Virtualhosts + PHP error


Hey guys

I'm getting a weird error message in PHP

Warning: Failed opening '/home/pakage/public_html/index.php' for inclusion (include_path='.:/usr/share/pear') in Unknown on line 0

I have a virtual host pointing to /home/pakage/public_html

I can access index.html but I get that error when running index.php

any ideas?

thanks guys and girls =)
 
Old 08-03-2005, 01:05 AM   #2
guideweb
Member
 
Registered: Mar 2004
Location: /planet/earth
Posts: 110

Rep: Reputation: 15
Re: Apache Virtualhosts + PHP error

Quote:
Originally posted by critical
Hey guys

I'm getting a weird error message in PHP

Warning: Failed opening '/home/pakage/public_html/index.php' for inclusion (include_path='.:/usr/share/pear') in Unknown on line 0
Strange ....
Maybe you have set 'auto_prepend_file' or 'auto_append_file' in your php.ini ?
If you do make sure file is readable.
Quote:

I have a virtual host pointing to /home/pakage/public_html

I can access index.html but I get that error when running index.php
If you want to load by default 'index.php' you can add in your httpd.conf (under /etc/httpd/conf/)
DirectoryIndex index.php index.html (and the other index file you want to load)
Quote:
any ideas?

thanks guys and girls =) [/B]

Last edited by guideweb; 08-03-2005 at 01:08 AM.
 
Old 08-03-2005, 01:16 AM   #3
critical
Member
 
Registered: Feb 2005
Location: New Zealand
Distribution: Debian, Ubuntu
Posts: 46

Original Poster
Rep: Reputation: 15
Thanks for replying guideweb

I checked those 2 settings, they were uncommented but no set, I commented them out and it still doesn't work

I also checked and the file is readable and executable by all users

Thanks for the tip about the DefaultDocument, I had that set... the only reason I have 2 index's is for testing php...

Any more ideas?
 
Old 08-03-2005, 01:21 AM   #4
critical
Member
 
Registered: Feb 2005
Location: New Zealand
Distribution: Debian, Ubuntu
Posts: 46

Original Poster
Rep: Reputation: 15
oooh! found the problem

I doubled checked the permissions and I had set the directory right but it didn't pass the settings down

Anyways it's working find now!

Thanks for your help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache VirtualHosts and VSFTPd critical Linux - Software 3 09-14-2005 03:12 PM
Apache VirtualHosts Problem stratisphere Linux - Newbie 4 11-27-2004 01:20 AM
VirtualHosts & apache 2.0.48 TiCkO Linux - Networking 2 07-13-2004 04:20 PM
Apache + mod_ssl + virtualhosts problems rohypnol Linux - Networking 1 11-26-2003 01:48 PM
Virtualhosts in apache. where am i going wrong. SSBN Linux - Networking 20 07-11-2003 05:02 AM


All times are GMT -5. The time now is 06:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration