LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 06-27-2002, 05:19 AM   #1
roscoau
LQ Newbie
 
Registered: Jun 2002
Posts: 3

Rep: Reputation: 0
Angry Apache upgrade dependancies


[Mandrake 8.1]

I'm trying to do the recommended security upgrade for Apache and have downloaded the files listed at:

<http://www.mandrakesecure.net/en/adv...2002-039-2.php>

Trying to apply them however (rpm -Fvh *.rpm) results in a number of dependancy failures:

--------------------------------
[root@bunyip apache_upgrade]# rpm -Fvh *.rpm
error: failed dependencies:
apache-conf >= 1.3.22 is needed by apache-1.3.22-10.1mdk
apache-conf = 1.3.22 is needed by apache-mod_perl-1.3.22_1.26-4.1mdk
apache-conf = 1.3.22 is needed by mod_perl-common-1.3.22_1.26-4.1mdk
apache-common = 1.3.20 is needed by apache-conf-1.3.20-3mdk
apache-common = 1.3.20 is needed by mod_php-4.0.6-5mdk
apache-common = 1.3.20 is needed by mod_ssl-2.8.4-2mdk
apache = 1.3.20 is needed by apache-suexec-1.3.20-3mdk
apache = 1.3.20 is needed by mod_ssl-2.8.4-2mdk
----------------------------------

Suggestions please?

-Ross
 
Old 06-27-2002, 07:22 AM   #2
Mik
Senior Member
 
Registered: Dec 2001
Location: The Netherlands
Distribution: Ubuntu
Posts: 1,316

Rep: Reputation: 47
Use urpmi

Or go install all the rpms it asks for yourself. Lots of fun looking them up one by one and finding out there are more dependency problems.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
apache upgrade mabus92920 Linux - Newbie 8 01-18-2005 08:08 PM
Apache upgrade Spyiish Slackware 11 11-04-2004 12:12 PM
apache upgrade 2.0.46 to 2.0.48 xfurious_mindx Linux - Software 0 03-10-2004 06:46 PM
Apache upgrade 1.3.27 to 1.3.28 (HELP!) thebrothaulv2h8 Linux - Software 0 09-10-2003 12:40 PM
Apache upgrade problem josephswagner Linux - Software 1 12-05-2002 08:44 AM


All times are GMT -5. The time now is 02:45 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration