LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-20-2005, 08:03 PM   #1
mrjamin
LQ Newbie
 
Registered: Sep 2003
Location: UK
Distribution: FC7
Posts: 27

Rep: Reputation: 15
"apachectl startssl" fails: can't bind port 443


Hi,

I've just been trying to get mod_ssl working on my local linux machine (used as a fileserver, media server and webserver), but every time i issue
Code:
apachectl startssl
I get:

Code:
# apachectl startssl
(98)Address already in use: make_sock: could not bind to address [::]:443
no listening sockets available, shutting down
Unable to open logs
My ssl.conf is all set up correctly, as are my certs/keys etc.

Here's the lines I'm using that relate to SSL and ports in my httpd.conf:

Code:
<IfDefine SSL>
        Listen 443
        SSLEngine on
        SSLProtocol all
        SSLCipherSuite HIGH:MEDIUM
</IfDefine>
Any idea what could be the cause of the problem?
Code:
netstat -ln | grep 443
That doesn't show a thing!

Thanks in advance,

MrJ

Last edited by mrjamin; 06-20-2005 at 08:15 PM.
 
Old 06-20-2005, 08:09 PM   #2
Harlin
Member
 
Registered: Dec 2004
Location: Atlanta, GA U.S.
Distribution: I play with them all :-)
Posts: 316

Rep: Reputation: 30
Make sure 443 isnt being used by anything else.

Harlin Seritt
 
Old 06-20-2005, 08:14 PM   #3
mrjamin
LQ Newbie
 
Registered: Sep 2003
Location: UK
Distribution: FC7
Posts: 27

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by Harlin
Make sure 443 isnt being used by anything else.
isn't that what "netstat -ln | grep 443" does?? As I said, that doesn't return anything.
 
Old 06-20-2005, 08:17 PM   #4
Harlin
Member
 
Registered: Dec 2004
Location: Atlanta, GA U.S.
Distribution: I play with them all :-)
Posts: 316

Rep: Reputation: 30
My apologies mrj, I didn't see that. You are absolutely correct.
 
Old 07-04-2005, 11:09 AM   #5
mrjamin
LQ Newbie
 
Registered: Sep 2003
Location: UK
Distribution: FC7
Posts: 27

Original Poster
Rep: Reputation: 15
Ok, I fixed it. I (rather stupidly) missed the fact that httpd.conf was calling in ssl.conf for ssl config stuff, which was also setting the listen directive for port 443, so it was failing on this second listen directive.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache Port 443 Verbal Kint Linux - Software 0 10-04-2005 03:07 AM
apache mod_ssl not using port 443 davidsrsb Slackware 8 06-07-2005 10:33 AM
"Opposite" to a "Listening" in Port Lingo General_Tso Linux - Security 6 02-11-2004 11:19 AM
Apache won't answer on Port 80, but will on 443 KevinJ Linux - Software 10 02-04-2003 08:10 PM
Adding "apachectl startssl" to startup morbo Linux - Networking 2 10-01-2002 05:48 AM


All times are GMT -5. The time now is 06:48 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration