LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Apache show "Forbidden" after switched runlevel 5 to ON (http://www.linuxquestions.org/questions/linux-software-2/apache-show-forbidden-after-switched-runlevel-5-to-on-782756/)

shlomi.s 01-17-2010 08:11 AM

Apache show "Forbidden" after switched runlevel 5 to ON
 
hi All,

i wanted to auto-start apache and mysql each time the server is turn-on so i read some document on the net that explaining how to do that - and it's good - the services are loading when the OS start.
(as i said in the subject - i switched the runlevel 5 of httpd service to ON mode instead of the default - OFF)

BUT! the problem is that after i did it - for all of my apache's virtual-hosts i'm getting 403 - Forbidden notice.

when i doing it manually, mean, the server is load and then I'm logging-in with root user and do: 'httpd -k start', it's running perfectly.

i have hard filling that this 'runlevel 5' setting run the apache under user without permissions to those virtual-host folders (they're under 755 mode).


p.s. the mysqld service running ok with the runlevel 5 configuration!
p.s. (2) - i'm using Fedora 12

thanks for you help and i hope you understood me!!

Shlomi.

carltm 01-23-2010 08:59 PM

Did you install httpd from Fedora or from another source?

If it is the Fedora version, you should be able to run
"service httpd start" and have it run without errors. You
could then run "chkconfig httpd on" to set the service
to start at the default runlevels, which includes 5.

If you still have problems, you might need to look at the
error log files for apache.


All times are GMT -5. The time now is 05:10 PM.