LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 03-08-2004, 03:24 PM   #1
root3d
Member
 
Registered: Jan 2004
Distribution: Mandrake 9.2
Posts: 40

Rep: Reputation: 15
apache problems


I just downloaded and installed Apache 2.0.48. I directed my browser to localhost:80 and nothing happened (timeout occurred). I checked my httpd.conf file and the "Listen" directive was set to 80. Any ideas? All I want is to test a few CGI scripts, nothing major. All I need is a minimal configuration, but even that isn't working. What are some things to do to have it serve up index.html (properly)? Thanks.
 
Old 03-08-2004, 03:27 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Did you start it?
apachectl start

To see if it is running post the output of:
netstat -nlp
ps -ef | grep http
 
Old 03-08-2004, 03:33 PM   #3
root3d
Member
 
Registered: Jan 2004
Distribution: Mandrake 9.2
Posts: 40

Original Poster
Rep: Reputation: 15
Yep, it was started.
Code:
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 127.0.0.1:32768         0.0.0.0:*               LISTEN      1645/xinetd
tcp        0      0 127.0.0.1:18020         0.0.0.0:*               LISTEN      634/webconfd
tcp        0      0 0.0.0.0:841             0.0.0.0:*               LISTEN      1083/rpc.statd
tcp        0      0 0.0.0.0:111             0.0.0.0:*               LISTEN      1018/portmap
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      2916/httpd
tcp        0      0 0.0.0.0:10000           0.0.0.0:*               LISTEN      1873/perl
tcp        0      0 0.0.0.0:6000            0.0.0.0:*               LISTEN      1595/X
tcp        0      0 0.0.0.0:631             0.0.0.0:*               LISTEN      1680/cupsd
udp        0      0 0.0.0.0:10000           0.0.0.0:*                           1873/perl
udp        0      0 127.0.0.1:53            0.0.0.0:*                           1618/tmdns
udp        0      0 0.0.0.0:835             0.0.0.0:*                           1083/rpc.statd
udp        0      0 0.0.0.0:68              0.0.0.0:*                           2408/dhclient
udp        0      0 0.0.0.0:68              0.0.0.0:*                           1500/dhclient
udp        0      0 0.0.0.0:838             0.0.0.0:*                           1083/rpc.statd
udp        0      0 224.0.0.251:5353        0.0.0.0:*                           1618/tmdns
udp        0      0 192.168.1.100:5353      0.0.0.0:*                           1618/tmdns
udp        0      0 127.0.0.1:5353          0.0.0.0:*                           1618/tmdns
udp        0      0 0.0.0.0:111             0.0.0.0:*                           1018/portmap
udp        0      0 0.0.0.0:631             0.0.0.0:*                           1680/cupsd
Active UNIX domain sockets (only servers)
Proto RefCnt Flags       Type       State         I-Node PID/Program name    Path
unix  2      [ ACC ]     STREAM     LISTENING     3714   1599/saslauthd      /var/lib/sasl2/mux
unix  2      [ ACC ]     STREAM     LISTENING     3696   1595/X              /tmp/.X11-unix/X0
unix  2      [ ACC ]     STREAM     LISTENING     3522   1461/xfs            /tmp/.font-unix/fs-1
unix  2      [ ACC ]     STREAM     LISTENING     5324   2172/kdeinit: Runni /tmp/ksocket-decept0r/kdeinit-:0
unix  2      [ ACC ]     STREAM     LISTENING     5353   2178/kdeinit: klaun /tmp/ksocket-decept0r/klauncherbVZSga.slave-socket
unix  2      [ ACC ]     STREAM     LISTENING     5626   2190/artsd          /tmp/mcop-decept0r/pcp742634pcs_reston01_va_comcast_net-088e-404b7b36
unix  2      [ ACC ]     STREAM     LISTENING     5371   2181/fam            /tmp/.fam_socket
unix  2      [ ACC ]     STREAM     LISTENING     5328   2175/kdeinit: dcops /tmp/.ICE-unix/dcop2175-1078688560
unix  2      [ ACC ]     STREAM     LISTENING     5650   2195/kdeinit: ksmse /tmp/.ICE-unix/2195
Code:
root      2916     1  0 15:35 ?        00:00:00 /usr/local/apache2/bin/httpd -k start
nobody    2917  2916  0 15:35 ?        00:00:00 /usr/local/apache2/bin/httpd -k start
nobody    2918  2916  0 15:35 ?        00:00:00 /usr/local/apache2/bin/httpd -k start
nobody    2919  2916  0 15:35 ?        00:00:00 /usr/local/apache2/bin/httpd -k start
nobody    2920  2916  0 15:35 ?        00:00:00 /usr/local/apache2/bin/httpd -k start
nobody    2921  2916  0 15:35 ?        00:00:00 /usr/local/apache2/bin/httpd -k start
 
Old 03-08-2004, 03:35 PM   #4
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Well it is listening:
Code:
tcp        0      0 0.0.0.0:80              0.0.0.0:*               LISTEN      2916/httpd
So I assume it must be your firewall. Do you have anything blocking port 80?
iptables -nL
 
Old 03-08-2004, 03:37 PM   #5
root3d
Member
 
Registered: Jan 2004
Distribution: Mandrake 9.2
Posts: 40

Original Poster
Rep: Reputation: 15
I haven't set up a firewall yet (oops!) lol.
 
Old 03-08-2004, 05:26 PM   #6
root3d
Member
 
Registered: Jan 2004
Distribution: Mandrake 9.2
Posts: 40

Original Poster
Rep: Reputation: 15
Ok, all I need is a simple configuration. Do I have to add anything to the DocumentRoot before I can see a webpage (I assumed their already was a default one). All I did to install it was the simple, three step
Code:
./configure
make
make install
Is that the problem? Do I need to add/edit anything in my httpd.conf file? I've searced Apaches documentation and haven't found anything about setting up a barebones server.

Any help? Thanks.

<EDIT>
Heh, I got it to serve index.html. httpd.conf was configured properly, I just wasn't typing the correct URL. It needed 192.168.1.100:80 rather than localhost:80. I'll figure out the CGI stuff on my own. Plenty of docs on that.
</EDIT>

Last edited by root3d; 03-08-2004 at 06:01 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache problems BrettPower Linux - Networking 3 03-06-2004 11:52 PM
Apache Problems ASP Linux - Software 1 10-14-2003 03:17 PM
Apache problems rooster13 Linux - Networking 6 07-17-2003 12:41 AM
Apache virtualhost problems, apache install problems nyroc Linux - Software 2 06-10-2003 12:16 AM
Apache problems RecoilUK Linux - Networking 6 07-13-2001 07:42 PM


All times are GMT -5. The time now is 08:15 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration