Welcome to the most active Linux Forum on the web.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 09-05-2006, 10:59 AM   #1
Registered: Sep 2005
Posts: 114

Rep: Reputation: 15
Apache problem: httpd (pid 2206?) not running

Apache is not running even though it says it's started. I try to stop it and it gives this:
httpd (pid 2206?) not running

Why is the pid "2206?" ?

How do I fix this?

I think I posted this in the wrong forum, can a moderator move this to the server forum? Thanks!

Last edited by newlinuxnewbie; 09-05-2006 at 11:03 AM.
Old 09-05-2006, 11:12 AM   #2
Registered: Mar 2006
Location: Ohio, USA
Distribution: Red Hat, Fedora, Knoppix,
Posts: 542

Rep: Reputation: 33
No idea which distro your running ....but

In Red Hat or Fedora using the service command you can do a:
service httpd start
if it says it's running but you don't believe it stop or restart the service like so:
service httpd restart
service httpd stop
then you can start it. You should get prompts which say ok when it starts or or the dreaded 'failed' message.
If it fails (or says ok, but doesn't work) go to /var/log and view the tail end of the messages file. It should give you a hint as to why it's failing.
Old 09-05-2006, 11:17 AM   #3
Registered: Sep 2005
Posts: 114

Original Poster
Rep: Reputation: 15
I run this and it'll say started
/usr/local/apache/bin/apachectl start

But I find it it isn't running so I stopped it
/usr/local/apache/bin/apachectl stop

And it gives this error
httpd (pid 2206?) not running

I just found the problem, usr partition was full, freed up some space and it's working again.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
running httpd.conf without restarting apache mpower Linux - Newbie 3 03-16-2005 06:20 PM
httpd service stop fails, no pid, this after latest update squadja Red Hat 2 08-11-2004 03:29 PM
httpd apache problem ebasi Linux - Software 1 07-24-2004 01:20 PM
APACHE - HTTPD will not stay running thePod Linux - Software 2 04-15-2004 11:27 PM
httpd chokes on ScriptAlias line in Apache httpd.conf lhoff Linux - Software 1 07-14-2003 11:32 PM

All times are GMT -5. The time now is 08:45 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration