LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 04-23-2003, 02:24 PM   #1
bkortleven
LQ Newbie
 
Registered: Apr 2003
Location: belgium - antwerp
Posts: 2

Rep: Reputation: 0
Unhappy apache + php error


I get the following error message running apachectl configtest, after installing php 4.3.1 on a newly installed Mandrake 9.1 server, running apache 1.3.27 and mod_perl 1.27:

Syntax error on line 208 of /usr/local/apache/conf/httpd.conf:
API module structure `php4_module' in file /usr/local/apache/libexec/libphp4.so is garbled - perhaps this is not an Apache module DSO?

Anyone any idea how or what to do to get it out, and get php running in apache???

Thanks!!!
 
Old 04-23-2003, 02:36 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
It sounds like "libphp4.so" could be corrupted

Try reinstalling mod_php
http://rpmfind.net/linux/rpm2html/se...mandrake&arch=
 
Old 04-23-2003, 04:31 PM   #3
bkortleven
LQ Newbie
 
Registered: Apr 2003
Location: belgium - antwerp
Posts: 2

Original Poster
Rep: Reputation: 0
php error

OK, how? I don't see any rpm's for php4.3.x AND I tried installing it already!!! it's just that I wanted to use DSO on my apache modules... just like the perl module I FINALLY got in the apache!

so, I just need the file libphp4.so, used for apache 1.3.27 and php 4.3.x

anyone???

 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Error in PHP 5.0.5 and Apache 1.3.34 - Cannot load libphp5.so jun_tuko Linux - Software 7 01-06-2008 12:12 AM
Debian + Apache + PHP + MySQL.so = Error critical Linux - Software 4 08-04-2005 05:18 AM
Apache Virtualhosts + PHP error critical Linux - Software 3 08-03-2005 01:21 AM
Apache + PHP error Peper Linux - Software 1 12-20-2004 10:27 AM
Apache & PHP error - libphp4.so.... ReSync Linux - General 7 08-06-2002 02:52 PM


All times are GMT -5. The time now is 10:16 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration